Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: NAS Issue

31 May 2011   #1

7 Home Premium 64bit
NAS Issue

I have a Western Digital Netcenter NAS drive attached to my router via ethernet. I have two windows 7 notebooks connected to my network wirelessly. One notebook sees the NAS drive as a computer on the network and can access the files on its shared folder through the \\WD-NetCenter\Shared Files\ nomenclature. The other notebook was set up to do the same and worked fine until today when it suddenly cannot connect to the NAS in that manner. The only way I have been able to connect is through the NAS' IP address in the manner of \\ When I try to connect to it by name, the response is that it cannot be accessed. Any ideas on what might have changed or how to remedy the problem? Thanks.

My System SpecsSystem Spec
31 May 2011   #2

Windows 7 Enterprise

It'l probably be a DNS issue.
Have you power-cycled your router?
My System SpecsSystem Spec
31 May 2011   #3

Win7 & Win8 64bit


I would give the NAS a little break too, turn it off completely for a couple of minutes, restart the computer as well.
Try connecting when both are up and running.
My System SpecsSystem Spec

01 Jun 2011   #4

7 Home Premium 64bit

thanks, I tried power-cycling both the router and the NAS but the result is the same. My computer sees the WD-Netcenter as a computer on the network, accessible by \\WD-Netcenter\Shared Files\ but my girlfriend's computer doesn't automatically recognize it and can only connect using \\ When trying to connect using the name, a dialog box appears saying "Windows cannot access \\WD-Netcenter\Shared Files." I also have a media center device, WDTV Live Hub, connected to my network wirelessly. Again, my computer automatically recognizes it as a computer on the network. My girlfriend's computer does see this device but it views it as a media device and wants to open it with Windows Media Player instead of Windows Explorer. She can view it as a drive by \\ just like the NAS.
My System SpecsSystem Spec
01 Jun 2011   #5

XP / Win7 x64 Pro

Are both computers in the same workgroup?
My System SpecsSystem Spec
01 Jun 2011   #6

Microsoft Windows 7 Home Premium 64bit SP1

I had the same type of issue when setting up my home network. The problem I had was the sharing permissions were not set right for the second computer. On your NAS system did you set permissions for both of your laptops? I can be a little tricky to setup. Even is you are all on the same homegroup, you have to set the permissions for all before all pcs can access the files. Hope this helps. Good luck.
My System SpecsSystem Spec
01 Jun 2011   #7

7 Home Premium 64bit

Both computers, the NAS too, are in the same workgroup. Neither of our two notebooks are using the Windows 7 functionality Homegroup because, until recently, my computer was the only one running W7. The NAS has a public shared folder "Shared Files." It doesn't have any specific security settings other than username and password. It is running the software that was native to it when I bought it (back when a 160 GB drive was state-of-the-art!).
My System SpecsSystem Spec
01 Jun 2011   #8


seems to be DNS related, try registerning dns on the trouble laptop.

run / cmd / type: ipconfig /registerdns

Or just map a network drive to the ip address?
My System SpecsSystem Spec
01 Jun 2011   #9

7 Home Premium 64bit

As Brady suggested, I tried ipconfig /registerdns and there was no change. Also, as suggested, I did map a drive to the ip address and I think that will work fine. I already had her change her links and iTunes music folder to refer to the ip address. So this might be solved from a practical standpoint. But still... what's up with this? It just isn't right...
My System SpecsSystem Spec
01 Jun 2011   #10

Windows 7 Enterprise

It is still a DNS issue.
Try what Brady suggests.
Otherwise, you'll need to set the DNS server on your local network card settings.

(I'l get screenshots up soon)

To do this, open your network connections.

rightclick the network adapter and select properties.

Select Internet Protocol Version 4 (TCP/IPv4), click properties

On the properties page, select 'Use the following DNS server addresses'

Change the preferred DNS server to the IPv4 of your ROUTER
Change the alternate DNS server to the IPv4 of your ISP

(Dont use these IP addresses. I made them up as an example)

Click ok on all boxes.

Go back to command prompt, and try Brady's suggestion again
My System SpecsSystem Spec

 NAS Issue

Thread Tools

Similar help and support threads
Thread Forum
Boot issue, 0xc0000098 ci.DLL file issue
OK so I hope this can be a quick fix and thanks for your help. * Randomly computer didn't start, get something telling me that the ci.dll file is missing or corrupt and error 0xc0000098 * safe mode and last know good configuration both result in bsod * Tried a few things, disconnect all...
BSOD Help and Support
net start command line issue - 64bit issue?
I am trying (in vain) to issue a net start command "net start - "C:\Program Files (x86)\uTorrent\utorrent.exe", on the command line. The error message is "the filename, directory name or volume label syntax is incorrect". I believe the 3 details are correct, as i am looking at the utorrent.exe file...
General Discussion
HP Multi Print/Scan Issue Re Install Issue?
I have an HP M1522 NF multi function peripheral attached to a PC running Windows 7. I needed to re install the drivers and software the other day but now it will only install the printer drivers and not the scanner drivers or any of the accompaying software?
Hardware & Devices
jpeg permission issue / possible encryption issue
Hello, I am new to the forums and have looked around just about everywhere I can think of for a similar topic and thus far have been unable to locate any help. If this has been previously covered, please point me in the direction and I will read up. So as for my issue.... I was running...
General Discussion
Interesting connectivity issue, just a browser issue
Opps, maybe not so unique since I just noticed an ENTIRE forum for browsers...perhaps moving this is appropriate...if so, please do. I will be reading up in there. Its interesting because I can't find any mention of it anywhere on this site. Specifically browser connectivity is lost after a...
Network & Sharing
8800GT Driver issue? Or maybe its a bios issue.
Hi all. I'm not sure where to start with this issue, it's bit spread out but it all started while I was gaming and the game froze and then the computer crashed. The freezing happened every once in a while, but the crashing had never happened. During the restart I see...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 13:41.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App