Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Wireless N only getting 54mbps

01 Jun 2011   #1
choccy31

WIN 7 Home 64
 
 
Wireless N only getting 54mbps

Hi there,


I got a new Dell desktop - XPS7100 in April with Wireless N Wlan card and everything was running fine speed wise however for last two weeks I am suddenly only being able to get maximum speed of 54mbps on my wi-fi connection.


I have installed drivers to latest etc but still cannot get back to the speeds I should be getting on my 50Meg BB.

Nothing has changed with the router or anything so am at a loss as to why this has suddenly happened.

Help please!


My System SpecsSystem Spec
.
01 Jun 2011   #2
Maguscreed

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

try releasing control from the application that came with the wireless device and turning it back over to windows, or vice versa, whichever may be the case. This is usually a application oriented problem in my experience and not a hardware oriented once (unless signal strength is an issue)
My System SpecsSystem Spec
01 Jun 2011   #3
choccy31

WIN 7 Home 64
 
 

Thanks for response.

How do I releae control?

Thanks
My System SpecsSystem Spec
.

01 Jun 2011   #4
Maguscreed

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

If you are using the application that came with the card there should be a setting in the options that says something close to the effect of "allow windows to control this connection"
you would untick that then use the normal windows wireless manager that should pop up afterwards control the connection.
My System SpecsSystem Spec
01 Jun 2011   #5
choccy31

WIN 7 Home 64
 
 

I normally go into device manager in win 7 and that is where the adaptor settings are.

Never seen the "allow windows to control this connection" bit?
My System SpecsSystem Spec
01 Jun 2011   #6
Maguscreed

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

That's not where you should be adjusting settings for the wireless connection there should be a small icon in the task bar indicating a wireless connection is available and that is where you should click to set it up. If you have been messing with the actual device settings via the device manager there is no telling what setting you may have changed that has limited the bandwidth.
My System SpecsSystem Spec
01 Jun 2011   #7
choccy31

WIN 7 Home 64
 
 

Hi,

No, i have not made any changes in tha tsection but just had not seen any options as you suggested above.

I will look again when I get home and see if this will help.

It was fine up until 2 weeks ago now and then I just noticed it had changed out the blue.

Thanks, I will update later.
My System SpecsSystem Spec
01 Jun 2011   #8
mckillwashere

Windows 7 x86/x64, Server 2008r2, Web Server 2008
 
 

Choccy, Have you checked your router to make sure it is not running in "G" mode?
My System SpecsSystem Spec
01 Jun 2011   #9
choccy31

WIN 7 Home 64
 
 

Quote   Quote: Originally Posted by mckillwashere View Post
Choccy, Have you checked your router to make sure it is not running in "G" mode?
Hi not had a chance to as yet. Although no changes have been madeto suddenly change what was working perfectly at 50 meg.

Will look into that as well.

Ta
My System SpecsSystem Spec
01 Jun 2011   #10
choccy31

WIN 7 Home 64
 
 

Hi

Tonight went into router and changed the security settings and updated the firmware and seems to have made a difference now.

Currently I'm now showing 130.Mbps on mine and my brothers ipad 2 was zooming on the net earlier as is my mobile which can be closer to the router signal then my desktop.

I do have a wireless N USB which i could use in future to get closer to signal but think will be ok for now.

Thanks for all your help :-)
My System SpecsSystem Spec
Reply

 Wireless N only getting 54mbps




Thread Tools




Similar help and support threads
Thread Forum
Working with 2 wireless networks - Internet access and HDMI wireless
Hi, I have just got an EZCast home multimedia wireless sharing device. It works great from my acer laptop and from my android phone. HTC one! My problem is that it works as an access point so both my phone and my laptop need to connect as clients. when I do this I have no connection to the internet...
Network & Sharing
Wireless Connection Speed limited to 54mb/s on Wireless-N equipment
I have a new dual band wireless-AC router (Linksys EA6300) and just installed an Intel AC 7260 wireless card in my laptop. The wireless network I am connected to indicates that it is a 802.11n connection, but in the Wireless Network Connection Status it only shows a connection speed of 54mb/s. ...
Network & Sharing
WiFi speed down from 300Mbps to 54Mbps??
For my laptop, the speed was 300Mbps few days before but it changed to 54Mbps last night. I did not change any settings for my router and adapter and the only software I installed during this period is Windows update of March. I found the client monitor in router's setup page displays 802.11n is...
Network & Sharing
Win 7 connecting to n router @54mbps
My HP mini 110 with win7 starter edition is connecting to a linksys wrt120n router at 54 mbps with router right next to computer. this router replaced my linksys g router. This is my first post to a forum, let me know if did anything wrong and I will correct it.
Network & Sharing
Wireless Connection ONLY 54MBps
I decided to buy a new Router to try and get some quicker speeds, no luck so far, heres what I have. Qwest DSL modem only 1.5Mbps connect to A Cisco Linksys E2000 Advanced Wireless-N Router with a CAT6 cable going between the modem and the router What am I doing wrong. Between the...
Network & Sharing
PCI-E intel 5300 wireless doesn't work. Then the USB wireless adapter
Dear all, I thought I have met this problem before before my two wireless adapters both stopped working. PCI-E INTEL 5300 TP-LINK WN821N My case is a little different from those I found on this forum. 1. When I upgraded my thinkpad x200 to win7 64bit, I don't have "Wireless Network...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:01.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App