Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: PC is not accessible

05 Jun 2011   #1

W7 Ultimate x64
PC is not accessible

I recently changed ISPs, and in the process decided to upgrade my router as I have been wanting a gigabit one. Well everything went fine, set up all my PCs as required (needed to forward a few ports for a few applications). Somehow though I have encountered a problem.

I have two Windows 7 Ultimate x64 PCs, which I have networked together. I am able to login with a remote desktop connection just fine, I am able to access the homegroup section fine too. But the section under "Network" doesn't work. Well it works in that I can see PC1 and PC2, but if I click on the remote PC. I get the error:

\\PD-PC is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.
The remote procedure call failed and did not execute.

They are on the same router and subnet, and wired if it matters. They are actually the only two things plugged into it, all other PCs use the FiOS provided router. My router is the D-Link DGL4100. No third party firewalls, just the Windows one (and the router one). Prior to the change in routers, everything worked fine.

I have searched around the internet, and almost every thread I go to seems to have a different "fix" for this, none have worked for me. I am stumped. I am sorry if I have forgotten to provide you with some information that would help

My System SpecsSystem Spec
05 Jun 2011   #2

Windows 7 Ultimate N 64-bit

i take it UPNP is enabled on the router? the only thing i can think of if they work fine on another router.
My System SpecsSystem Spec
05 Jun 2011   #3

W7 Ultimate x64

Yes I do have UPNP enabled.

Thanks for the response.
My System SpecsSystem Spec

06 Jun 2011   #4

Windows 7 Ultimate N 64-bit

able to ping through IP and or name to see if it goes through the routers DNS. by sounds of it with all drivers up to date, ur gonna have to contact router manuf
My System SpecsSystem Spec
06 Jun 2011   #5

W7 Ultimate x64

Checking with the router setup page I have a new funny thing that is happeneing.

According to the router, I only have two things connected to it. My current PC (PDi7) and a wireless router. Both are connected, but so is my other desktop (which would be named PD). I am able to ping it fine, with both and PD-PC with no dropped packets or latency. Odd thing is everything is fine still, internet still works fine on it. I am able to transfer files between the PCs. Streaming works. I can still login with a remote desktop connection.

Something else I recently noticed. I have most of my music on the remote PC, as that is essentially what I use it for a NAS and an HTPC at times. So I have my media player setup (foobar2000) to recognize the remote drives. It works, but if I try and "open containing folder" for a file that would be on a remote drive nothing happens. If a file is on a local drive, that option works.

So maybe this is a router issue. I will try D-Link and see what they say.

Thanks again for your time and patience.
My System SpecsSystem Spec

 PC is not accessible

Thread Tools

Similar help and support threads
Thread Forum
Why are some websites not accessible?
I have one computer and one laptop. All of a sudden the desktop cannot access and two other websites. The connection just times out. The laptop is able to access these websites - both are on the same network. Also, I restored an old backup when things were working just fine, and I am...
Browsers & Mail
Drive is not Accessible...
Something has gone wrong with one of my internal HDD's. When i boot i get a message telling me that the drive is corrupted and i should run a chkdsk, which i do. But the chkdsk only last a few seconds and doesn't actually check anything. I can see the drive in explorer but can't access it. ...
Hardware & Devices
C:\is not accessible
I have read other solutions on the forum, but have yet to find one that really works for me. I have booted up in Safe Command System mode and typed Explorer when I get another prompt. This opens Windows 7, and my C drive is accessible and has security info. The problem is, when I simply boot up,...
General Discussion
XP drive not accessible
Shared XP drives are shown on W7 machine but are not accessible. The following are done for trouble shooting: 1)Shutting down AV and firewall, 2)clean boot, 3)Safe mode with network and 4)turning off "password protected sharing" on W7. Any suggestion is appreciated.
Network & Sharing
Folder is not Accessible
hi i have windows 7 ultimate 32 i installed some software to movie editing then i needed some patch for compatibility which i get from internet i am quiet advanced in using pc and internet my laptop is hp hdx9095ea when i wanted to install patches my windows keeps poping messages...
System Security
RAM not accessible???
Before I installed Windows 7, I had taken out my 2 GB RAM (coz my friend wanted it). Later on when I got it back, it says that there's 4GB RAM, but only 1.87 GB is usable. Even the BIOS shows 4 GB RAM. Can anybody help me out?
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App