Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Network not connected (but really is)

15 Jun 2011   #1

Windows 7 Home Premium 64bit
Network not connected (but really is)

Windows says I'm not connected to a network yet here I am magically posting this tread.

I'm connected to a Netgear WNDR3700v2 via Ethernet cable and not in the uplink port.

I have an ip I can see it in ipconfig however Network & Sharing center has no active connections. I can't connect to the homegroup however I can see all of the devices on the network in windows explorer.

I have the newest driver for my NIC and have uninstalled and re-installed it. I have plugged in to another switch with the same results.

If I try to "See full map" I get the following message "Windows cannot create the network map because the network's location type is Public. In order to view the network map, you must set the network's location type to Home or Work in the Network and Sharing Center"

I don't have any connections listed to be able to change it's location....

I looked in: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles, it was empty no Network GUIDs were listed at all so I can't change the location there...

Any Ideas?

Attached Images
Network not connected (but really is)-network.jpg 
My System SpecsSystem Spec
15 Jun 2011   #2

Windows 7 Ultimate x64/Windows 8 Consumer Preview x64/Ubuntu 11.04

I'm assuming you have another computer on the network?
Also, try this. Navigate to:
Control Panel\System and Security\System
Click on Device Manager. Under the 'Network Adapters' tab, can you see your network adapter? I've attached an example, just in case.

Network not connected (but really is)-untitled.png

My System SpecsSystem Spec
15 Jun 2011   #3

Windows 7 Home Premium 64bit
It is

Yes NIC shows up in device manager

Attached Thumbnails
Network not connected (but really is)-nic.jpg  
My System SpecsSystem Spec

15 Jun 2011   #4

Windows 7 Ultimate x64/Windows 8 Consumer Preview x64/Ubuntu 11.04

I'm not sure what the problem is.... What other computers are on the network and what OS is installed on them? You might have to do an in-place upgrade/repair but don't do it yet. Do you have a restore point available?
My System SpecsSystem Spec
16 Jun 2011   #5

Windows 7 Home Premium 64bit
Several devices

I have several...

Desktop - XP
XBOX 360
Blu-Ray Player

Laptop - 7
Netbook - 7

Wired Via Wireless bridge:
Desktop - 7

I can see them in windows explorer along with the router.

no restore points from prior to when I noticed the problem
My System SpecsSystem Spec
19 Jun 2011   #6

Windows 7 Home Premium x64


I've had a similar problem.
And I found a fix, only until recently.

Try doing this. Open regedit then navigate to HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList
Then right click and click Permissions.

Click advanced then check "replace all child object permissions.."

click okay then disconnect and connect again.

See if that works. Good luck.
My System SpecsSystem Spec
20 Jun 2011   #7

Windows 7 Home Premium 64bit

Tried it still no effect

Attached Thumbnails
Network not connected (but really is)-status.jpg  
My System SpecsSystem Spec
01 Jan 2016   #8

Windows 7 64bit Home Premium
Not Conected but Really Connected -- Yellow Asterisk(or star)

I have the exact same diagram you x in the network map, can't show the full network for very same reasons -- it's apparently "public" must be change to home or work(but can't do that either), there a yellow asterisk in the wireless icon in the system tray(always at boot up). NIC adapter(s) have been uninstalled and reinstalled several times, and obviously the network map is wrong since I'm connected.

Know this thread is 1665 days old, but was this ever resolved ?
1.) Why the yellow asterisk? and how to get rid of it easily.
2.) Why am I still connected, yet network map shows I'm not
3.) This is driving be nuts....any help would be greatly appreciated

surely there must be a registry entry that can fix this?

Thanks in advance!
My System SpecsSystem Spec
01 Jan 2016   #9

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Well according to your screenshot its lease ran out in 2011!!!
You need to go into the router and change the settings.

My System SpecsSystem Spec

 Network not connected (but really is)

Thread Tools

Similar help and support threads
Thread Forum
The Network icon shows Not Connected, but I'm connected
Hi to all The Network icon shows Not Connected, but I'm connected and can brows the internet. my prblem solved but after restart my computer this problem come back. I'm confused:confused: because I tried many ways to sole it! I disconnected my pc from modem, waited about 30 seconds and...
Network & Sharing
Network Icon Displays a Red X but I'm Connected to a Wireless Network
Hi! I seemed to have this problem for a long time. I am a little experienced with problems and programming, so if you could post pictures in the steps provided, it would make it easier for me! The network icon displays a red X symbol and an ethernet cable symbol with a computer screen symbol...
Network & Sharing
Connected to Wireless network, but windows says Not connected
OK, so i am connected to my wireless network, but windows says that i am not connected
Network & Sharing
W7 VPN connected but cannot access network or map network drive
I am trying to set up a VPN with using a Windows 7 ultimate maching as a server. The current client is also W7 I've been through the two tutorials on this site and set it up. Forwarded port 1723 to the relevant PC, set PPTP and when the dust had settled, the client PC (accessing the internet via...
Network & Sharing
network system tray icon shows not connected but I am connected
So, this is not a major issue but kind of annoying. Recently I have noticed that the system tray icon for the wireless network always has that little red X and if I open the Network and Sharing Center it says "You are not currently connected to any networks." When I click "See Full Map" it shows...
Network & Sharing
VPN Connected but no network access; TCP/IP Not connected
I'm having problems getting a VPN to work which seems to be a common problem but I cannot find a solution Basic hardware: XP and 2 win7 Ultimate computers (A&B). B is the VPN server. Router: Thomson SpeedTouch TG585v7Xp . Port Forward tester confirms port 1723 is open Internet access via...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:58.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App