Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Win7 sees LAN but won't connect--asks for network password

20 Jun 2011   #1

Windows 7 Home Premium 64 bit, SP1
Win7 sees LAN but won't connect--asks for network password

I've read lots of posts & tutorials. The answer is probably out there someplace, but after a week of getting nowhere, I ask for help.

I have a home LAN set up as a WORKGROUP. In the wrkgrp is a W2K computer, a printer (have to go through the W2K system to get to it), and my laptop, with Win7.

The W2K computer sees and can access the Win7 shared files & folders.
The Win7 computer access's the internet through my LAN and router.

It discovers the W2K system and shows it as part of the LAN but when I try to access the W2K computer, authentication fails.

From the Win7 network directory, I click on the W2k computer.
I get a popup that asks for the Network password: enter the user name on the machine I am trying to access, enter the user password.

For information, the popup also indicates that the Win7 laptop is a member of a domain (the laptop's name).

I put in the username and pwd for the account on the W2K computer, but it won't connect. The popup returns, telling me what I entered was wrong. It tells me that the \\(domain name)\(user name) password failed.

I tried mapping to a drive on the W2K computer with its UNC, but get the same popup and the same failure.

I thought maybe the "network password" request meant enter the network name & password that I gave to the LAN in the router, but using those didn't let it authenticate, either.

I turned off the setting requring password authentication for connecting to other machines.

Since the Win7 machine came with Netbeui enabled, I re-enabled that on my W2K system, still no go.

I reset both systems to use TCP/IP instead of netbeui. --no luck, again. --I did have another Win7 computer (the mobo burnt up) set up to work only with TCP/IP. That computer connected to the W2K computer, just fine.

--I don't like the popup box telling me the Win7 laptop is a member of a domain when it is on a workgroup but don't know if that has an effect or not.--

Oh, I tried turning off/on the Win7's firewall.
Made certain no "Norton" stuff was running.
I also created "local," accounts with "user" rights on the W2K computer for the Win7 users; but didn't set any profiles for them. None of the above helped.

Soooo, will someone please go through this with me, find out what I missed, and get the Win7 computer to connect with the other computer on my LAN?


My System SpecsSystem Spec
27 Jun 2011   #2

Windows 7 Ultimate x64 SP1

If the workgroups are set to be the same on all systems, then you should use the same username and password. If you aren't willing to do that, you should try mapping by replacing the domain name with the remote computer name. So if you are on a Windows 7 computer, you can connect to the older computer by using the \\oldcomputername\usernameonoldcomputer and see if that works.

The easiest way to network computers on a home non-domain network has always been to use the same workgroup names, and set the same username and password combo on all machines. I've never had a problem doing this since the current network stack config was used in Win 2000 all the way up to Server 2008 R2 boxes.
My System SpecsSystem Spec
27 Jun 2011   #3

Windows 7 Home Premium 64 bit, SP1

I tried those things but none worked.
I still get the popup box that asks for "Enter Network Password." Then it tells me the computer I'm trying to connect to, which is the correct one, ands asks for the username and password.
That comes back with the same screen, except this time it tells me the computer I'm trying to connect to is my Win7 laptops name \ username of the W2K system-- which is the same on both systems.
I enter the password (same on each system) and I get the same popup.

I tried mapping, but the "Enter Network Password" appears just the same as above, with the same results of no access.

Could there be a credintial foul-up? I do not know how to set them.
I've never had to mess with anything like that before and as I menioned, W2K to Win7 to W2K was working fine on the LAN that had the other laptop.

And here, W2K to Win7, even with different usernames & pwrds (which I've now changed to be the same) works fine. It's the Win7 machine that won't connect, even though it sees the other computer on the LAN.

I still get the "Enter Network Password" and it still tells me the laptop is a member of a domain called the laptop's name. However, in the network map it clearly states the computer is part of a workgroup and even shows the name of the wireless network. I can access the internet through the Win7 laptop, either with cat5 through the router or wirelessly. So, I don't think it's a problem with the Win7 system seeing and getting through the router.

I just don't know what to do next.

My System SpecsSystem Spec

27 Jun 2011   #4

Windows 7 Ultimate x64

what happens when you just click on

Start and in the search box you type: \\name_of_2k_Computer {enter}

Do you get a share list, or a prompt for credentials.

Usually, when connecting to a machine not on the domain, from another machine that is on a domain (i know this isn't your case, just sayin). then you usually put in \\domain\username. If there is no domain on the W2k box, try \\machinename\username. Where machine name is the netbios name of the W2k box.

Also, type in
ping name_of_win2k_machine and be sure it's responding with the right name. I'm assuming this would work since you are getting prompted for credentials.
My System SpecsSystem Spec
06 Jul 2011   #5

Windows 7 Home Premium 64 bit, SP1

guess what: I figured it out. all my computers are peer to peer, so nothing should show up as being in a domain.
All computers have same usernames and passwords. "Everyone" is active and given full rights.
--still no go--
Pulled more hair out.
I went way back to basic computer setup. Checked the time. All systems were within a few seconds of each other and AM/PM was set correctly.
I happened to notice the date.
The Win7 laptop was ahead by 1 day.
I fixed that.
And -- problem solved!
Win7 can connect to all shares, even to my printer that is attached to the Win2K machine.
Wow. I couldn't believe I missed that.
I guess it's easy to compare the time and overlook the date, especially if it's really close.

Thanks for all the help
My System SpecsSystem Spec
16 May 2012   #6

Windows 7 Ultimate x64

OMG thank you. I had the same problem. My windows 2000 computer's time was off by 50 minutes, and I could see it from my Win7 laptop, but not access the files, kept getting username/password error.

My System SpecsSystem Spec
02 Feb 2014   #7

W7ult x64
Solved the logon requirement fiasco

My new XP machine kept asking for a password when I tried to connect from a w7 laptop. It was using my laptop name as "domain" example.
Solution: [don't laugh] I shared a folder on the xp m/c DWL With it being a new install of XP, there were no "shares" configured. The error message should have said: "no shared folders on this computer", instead of asking for log in name and password. But... as someone who has tried to write just a basic error file in a program, I am not too pissed off at the Boys in Redmond.
My System SpecsSystem Spec

 Win7 sees LAN but won't connect--asks for network password

Thread Tools

Similar help and support threads
Thread Forum
Cannot connect to Network drive. (Enter network password)
My network contains: 10 PCs and laptops running (Windows7 & Windows8). 2 network printers 1 Network Drive (WD Mybook Live Duo) Workgroup environment Here everything is fine. But one of the windows 8 laptop cannot access network folder. It prompt username and password. whenever I am trying...
Network & Sharing
Network Sharing asks for Password
Hello, I have 3 computers (1 XP, and 2 Windows 7). Win 7 computers can always access network shares on Win XP without a password. However, I can't seem to get this working Win 7 to Win 7. I have searched the internet for an answer, but so far haven't been able to solve it. Here's the setup:...
Network & Sharing
WLAN network connection asks for user and password ???
Hi, I've setup my father's notebook (Win 7 32Bit) to connect via WLAN to the router. Another notebook is already running on that router (did not tried it parallel at the same time yet). I've setup SSID (I've made it visible at the router for the initial connection), WPA2 & TKIP incl....
Network & Sharing
Network sharing suddenly asks for username and password
I have 3 Windows 7 (Home Premium 64 bit) machines on a peer to peer network. I have an accounting package that stores the files on one machine (Iíll call it Box1). On the another machine (Box2) I have mapped the data files on Box1 as \\Box1\datafiles (Z:). Everythingís been working fine for several...
Network & Sharing
Network share all of the sudden asks for username and password???
I have 2 windows 7 machines and xbox 360. I use xbox to watch movies or stream music from my computer. Everything worked fine untill out of the blue my windows machine started to ask for a username a password to see it. I cant even see the shared folders on the computer anymore. I have checked my...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:12.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App