Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: W7 X-64 and IIS. No connection from LAN

19 Jul 2009   #1

Linux CENTOS 7 / various Windows OS'es and servers
W7 X-64 and IIS. No connection from LAN

Hi all
anybody got a webserver with IIS working yet on W7 X-64 and been able to connect to it from another machine on the same LAN.

Enc screenshot of the problem

The server works fine if I'm on that machine (http://localhost)

If I'm downstairs in the conservatory with a laptop and want to connect to the server (http://local-ip) I just CAN'T connect anyhow.

Machine is pingable, and can see it on the network. Can access disks etc etc.

Just cant access the webserver. Client Laptop is running either W7 x-64 or Windows XP -- either OS won't connect.

I've also got a Linux server running apache on the same LAN -- Not a sausage of a problem --connects every time). (Different port so no conflict there). Also I can bring the Linux machine down when testing anyway just in case.

Why on earth is Windows Networking such a DOG.

(all firewalls are off while testing and port forwarding on the router is fine)

IIS server works fine on Windows XP -- but W7 -----!!!!

I like W7 - but I MUST get the web server working.

(A virtual XP machine running on W7 also works fine as the web server so I KNOW the problem has got to be IIS and W7 X-64)

To simplify matters I'm running the RC version (7100) for this test -- I did try later builds with the same problem.

Really greatful if anybody can solve this problem -- I should be able to access my own web server from within my LAN -- It's a bit useless if I have to go to the physical machine to do any work on it.




(Update -- IIS needed a fix on the Web server W7 machine -- install the LATEST version -- I think 7.5 otherwise gives probs)


Attached Images
W7 X-64  and IIS. No connection from LAN-server.png 
My System SpecsSystem Spec
26 Jul 2009   #2

windows 7 rc ultimate
windows 7/iis7.5 pain :-(

Hi jimbo45 -

Could you give more details about your solution?

It appears that I'm having the same problem you originally described but I'll type it out just to be sure

I have two machines running windows 7 rc x64 7100 - they can both ping/remote desktop/share files but neither machine can browse websites hosted on the default site on port 80 of the other machine.

I've just completely removed all iis-related components, rebooted, re-installed everything needed* yet still the other machine cannot see the site.


I've used fiddler to check the request which is leaving the other computer. It looks fine, a standard GET. On the website host computer, I can see that no connection arrives (I'm using a software which has built-in connection-monitoring features and see no connection to port 80 either blocked or allowed). It as though the connection goes missing somewhere between the two computers.

I notice that SYSTEM is listening to port 80 using TCPv6 and wonder if this is somehow related to the issue as I have extremely limited knowledge of TCPv6. For IPv4, I have static IPs for all computers on the network but the IPv6 are all dynamically assigned by the same router/gateway.

I've attempted to disable IPv6 using the registry poke described here: How to disable certain Internet Protocol version 6 (IPv6) components in Windows Vista - but IIS (SYSTEM) still listens on TCPv6

Generally, I have windows firewall completely disabled for the home and public profiles and my other software firewall enabled. I have also tried this with all firewalls disabled and my router's modem disconnected from the 'net - still with no success.

I have no clue what is happening... Any ideas?
My System SpecsSystem Spec
26 Jul 2009   #3


Have you checked the sites bindings to the IP address and port in IIS manager?
My System SpecsSystem Spec

26 Jul 2009   #4

windows 7 rc ultimate

Hi - thanks for reply. Binding is the default:
type:http, host name:<blank>, port:80, ip address: *, binding information: <blank>

Sorry for delay - I hadn't enabled 'instant email notification'...

Edit: it turns out (i believe) that my ipv6 addresses are auto-assigned, i.e. fe80...

Edit2: ...and I can't ping using the ipv6 address ! - surely this is related....
My System SpecsSystem Spec
02 Sep 2010   #5

Windows 7 Professional 32bit

Hi - Would you please let know the possible solution.... I am facing the same problem and trying for a fix...
My System SpecsSystem Spec
21 Jan 2011   #6

Windows 7 Ultimate 64

Just wanted to bump this because I just ran into the issue with two coworkers machines. We were trying to get IE6 to connect to their local IIS sites from within a Windows Virtual PC VM.

While troubleshooting, I couldn't even telnet to port 80 on their machines from my own machine. I even disabled windows firewall service.

The solution ended up being having to explicitly enable the INBOUND rule for World Wide Web services in the Windows Firewall with Advanced Security console. I guess even when disabling the firewall, some rules are still on...

Start -> Firewall
Windows Firewall with Advanced Security
Inbound Rules
scroll to the bottom, right-click on the World Wide Web Services [HTTP Traffic In] rule and click enable.

Hope this helps others!
My System SpecsSystem Spec
22 Feb 2012   #7

windows ultimate 7 64bit

thanks j2theb, I was running into the same problem and your solution fixed it...
My System SpecsSystem Spec

 W7 X-64 and IIS. No connection from LAN

Thread Tools

Similar help and support threads
Thread Forum
'Bluetooth connection' is shown in my Network Connection suddnly.
Hi, I really had not this 'Bluetooth connection' before. But, I really don't know that pairing my Nokia Bluetooth with my HP Laptop Bluetooth would add this Bluetooth connection or NOT. I really guess this Bluetooth Connection was listed there when I connected my Lapotp Bluetooh with Nokia...
Network & Sharing
Local Area Connection missing from network adapters, no connection
I have a Windows 7 Home Premium computer that is not connected to the internet. I have checked the drivers and they are all installed correctly and operational. When I go into the adapter settings there is no Local Area Connection adapter. I have included some screen shots of what I am seeing if...
Network & Sharing
Wireless Connection - WIFI connection not showing up
I have a iMac and I have installed Windows7 using Bootcamp v4.0. When I use the computer on MacOS X I am able to connect to the Wireless Connection named (ORACLE@PG), also when I restart the computer the same connection shows on the boot-loader screen. But when I am on the Windows 7, I am unable...
Network & Sharing
Wireless connection works, wired connection does not.
So last night, my wired connection was working. I did not install any new software or download anything. Tried getting on the internet today and nothing. My computer has an IP Address but I can't get onto the internet at all. I can't ping google. I can ping my IP address assigned, can't ping my...
Network & Sharing
Wireless network connection lost internet connection
Hi everyone, I work in an office where we have a main desktop computer which is connected to the internet via a Time Warner modem. The modem is connected by cable to a netgear wireless router, and up until today there have been no problems connecting to the internet from the laptops that use the...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:53.
Twitter Facebook Google+