Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows wont let me enable wifi adaptor

03 Jul 2011   #11

Microsoft Community Contributor Award Recipient

Windows 7 x64

You have multiple devices operating on the same frequency it would appear.
Sorry but I don't have a solution for that

My System SpecsSystem Spec
07 Jul 2011   #12

Windows 7 home premium


I uninstalled AVG, then ran avgremover to strip out all the cr#p it left behind. (Then I found remnants of Kaspersky anti-virus installation from 2 years ago so used kavremover to get rid of that too.) Thanks for that, Maguscreed.

Then uninstalled wifi card and it's drivers, and rebooted into safe mode. Installed latest card drivers and it worked fine.

Re-booted into normal mode - still working fine - and then installed Avira Free version, which doesn't seem to have any problems with it as it's all working.

So, it looks like it was down to AVG having issues with driver installation, or at least THESE drivers as I've not experienced this before.
My System SpecsSystem Spec
07 Jul 2011   #13

Microsoft Community Contributor Award Recipient

Windows 7 x64

yeah, people argue about which av is best to use. I just keep saying MSE it's not the best protection but it is far less likely to cause system problems like that.
My System SpecsSystem Spec

29 May 2013   #14

windows 8 Pro x64

Quote   Quote: Originally Posted by Maguscreed View Post
yeah, people argue about which av is best to use. I just keep saying MSE it's not the best protection but it is far less likely to cause system problems like that.

I have the tenda W322P as well with exactly same problem i.e. says it's enabling when it isn't, remains defiantly disabled. In device manager it says it's working fine with no resource conflicts. It doesn't make any difference which driver I install (inc. windows default). I reinstalled windows 7 a couple of days ago so it is still very 'clean'. I avoided AVG, Avast etc etc and went with your advice of MSE. All was fine for about 48 hours whilst browsing a web page and then without warning: "you have no network connections" (or words to that effect). It's been like that ever since? This happens every time I re-install windows 7! I've run SFC utility but no problems found with the system integrity. I've repeatedly installed and uninstalled the device driver (with reboot) which makes no difference at all. Any suggestions please?

Back on LAN temporarily!

I can't see it being the hardware as it always works fine initially after a windows reinstallation, but isn't long before it breaks down yet again!!

Tried windows diagnostic/repair utility which reports that my network adapter has a problem; but as the device manager simultaneously reports that it is 'working fine' [contradictory or what?], I now suspect a windows 7 problem rather than anything to do with the Tenda hardware/software?

Booting into safety without the firewall enabled makes no difference as does with removing the wireless drivers prior to entering safety. System restore makes no difference either!
My System SpecsSystem Spec
21 Mar 2014   #15

Windows 7 Professional x64
Check the BIOS

I was having an issue where The wireless card was disabled when pressing fn +f5. Device manager indicated the wireless was active and enabled.
Checking the BIOS indicated that the wireless adapter was set to off. Turning it on fixed the issue.
My System SpecsSystem Spec

 Windows wont let me enable wifi adaptor

Thread Tools

Similar help and support threads
Thread Forum
Enable wireless adaptor
So I just got a brand new laptop, a Dell Inspiron. I turned it on, started adjusting properties to suit me, and tried to connect to my internet connection. In the process I wanted to disconnect from my internet, but nstead I pressed disable. Now I can't figure out at all how to enable the thing...
Network & Sharing
can't enable new network adaptor
I just installed this product USB Dual High Gain Antenna Wireless N Wifi Adaptor USB Dual High Gain Antenna Wireless N Wi-Fi Adapter (eBay item 170608181616 end time 25-Jul-11 14:23:40 AEST) : Computers Soon as I plugged it in, my Win 7 (64) machine instantly identified it and installed the...
Network & Sharing
Wifi Adaptor is installed/enabled but Windows can't detect networks
I got a Dell E6220 with Windows 7 32bits. Our System Admin pushed the new A/V upgrade from Symantec 11 to Symantec 12 and that broke all the network connectivities including Ethernet and Wifi. I was able to run CleanWipe couple time and get rid of all the Symantec crap and checked the registry...
Network & Sharing
RNX-EasyN1 Wifi Adaptor wont work.
Alright so I have a laptop however I am unable to use its current wifi card for my wifi reciever booster I am making. So I needed a usb connector. I got the RNX-EasyN1. When I first got it I installed the driver off the disk. However I was still unable to get the device to detect any networks or...
Hardware & Devices
Cannot enable network adaptor on HP dm1-3100sa
I have an HP Pavilion DM1-3100sa laptop. AFAIK, it's pretty much the British/European version of the American DM1z, and is more or less identical. I installed a pair of VPN clients on it: Hamachi and Watchguard Mobile VPN 10.10. I noticed that the wireless connection started to behave...
Network & Sharing
Auto Enable Atheros 5007EG Wireless Adaptor
Hi, I have spent ages looking through posts on here and haven't been able to find exactly what Ive been looking for. However, as people on here clearly know exactly what they are talking about, I thought Id ask for your help ;) I have a FS Amilo Li1718. Until this week, when I started my...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:53.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App