Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: High CPU load when copying files over network

20 Jul 2009   #1

XP & W7
High CPU load when copying files over network


I've just installed the Win7 RC on my lab-pc. It's a 2,4GHz Celeron, 1GB DDR-RAM, everything installend on some old 160GB PATA-HDD. Two hi-speed USB Keys are used for ReadyBoost (love that feature).

Everything works like a charm, except the file transfer from my WXP machine.

I mount the SMB share (which is on my WXP) from the W7 machine and start to copy some big files. Transfer speed is ~1MB/sec on 10MBit, ~5MB/sec on 100MBit and ~11MB/sec on 1GBit. When I start file transfer the CPU load pops up to 50% while 10MBit is active, for 100 and 1000MBit it jumps to 100% and stays there until the transfer is over.

Since I read about IRQ issues I tried some NICs. An onboard SiS-900, an RTL8139 based PCI card and an Intel Pro 1000/MT Desktop adapter. I thought that - at last - the Intel NIC should stop my problems as it comes with IRQ moderation and TCP/UDP checksum offload.

None of these 3 NICs solved my problem.

All these NICs run on the driver W7 has found for them. None of the vendors had a special driver for me.

What I tried to do in addition:

- disable W7 firewall
- disable IPv6
- disable QoS
- tried another CAT5e cable
- restart the switch (Netgear GS108)
- hit the whole machine

Note of the above worked.

I just hope you just have an idea left for me. Just ask if I missed out some details.

My System SpecsSystem Spec
22 Jul 2009   #2

XP & W7

Update: I just found & installed the new Intel Driver V14.2. Didn't help either
My System SpecsSystem Spec

 High CPU load when copying files over network

Thread Tools

Similar help and support threads
Thread Forum
Problem copying any files on home network
Hi all! I have no issues accessing my home network. I can get to and traverse all shares on my network. I can open and view Doc's, Video's and images. But when I try to copy or move something, anything to a network share, it just sits on "Calculating" I ran the troubleshooter, it found no issues....
Network & Sharing
Issues copying files across the network...
I have windows 7 pro 64 bit running on my box. One of the devices on my network is a media reader and a local drive connected to it. Whenever I try to transfer large files (350 mb and above) the transfer speed never displays and the copy animation runs until I get an error message telling me that...
Network & Sharing
BSOD when copying files via wired network
Hi I'm having this blue screen problem on my desktop after I updated to Windows 7 SP1. I always get a BSOD(0x0000007F - UNEXPECTED_KERNEL_MODE_TRAP) every time I copy files from my laptop via wired network. The dump file is attached, can somebody take a look and give advise? Thanks a lot.
BSOD Help and Support
Copying files over Win 7 network keeps stalling?
Hi folks, I already posted about slow network copying speeds but have discovered that's not the issue. The actual issue is that copying keeps stalling. It'll copy files for 5-10 seconds at a good speed and then it just stops for maybe 30s - 1m? It repeatedly does this which makes it look like...
Network & Sharing
High CPU usage while copying file over network
Hi, for some reasons, while copying a 13 gb file over the network (accessed from \\servername\e$\ to my C drive, the CPU usage is going close to 100%. When I look at task manager, I see System using more than 30% of the CPU, SMC.EXE is using between 15% and 18%... Does anyone have an idea...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:21.
Twitter Facebook Google+