Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: FTP Problem

30 Jan 2009   #11

Windows 7 Build 7000; Vista Ultimate

All very strange, isn't it? Hard to see a clear pattern...

FYI, I tried two 3rd-party tools: FileZilla did not work; it was able to find and open the FTP site and send my login name. After receiving a "login name OK" message, it tried to send the password -- and that's when it failed because the password was not recognized. It's defined in FileZilla absolutely correctly, so dunno why this happens. This is likely the same place that connections from IE or Win Explorer are also failing?

Then I tried FTP Voyager as has been suggested earlier. Worked perfectly the first time, and no trouble since.

My System SpecsSystem Spec
31 Jan 2009   #12

Windows 7 Build 7000

I was trying to access my FTP-server via Windows Explorer, but I always get the following error-message:
An error occurred opening that folder on the FTP Server. Make sure you have permission to access that folder.
The handle is invalid.
Since it is my own FTP-server, I know that my login-details are correct. It works fine in both Firefox and Internet Explorer, but not Windows Explorer. I've tried with login-names not containing any special characters, and has only lower-case letters.

Below you can find the logs from my FTP-server when using Internet Explorer (which works), and Windows Explorer (which does not work). I've manually replaced the user-name and my IP in the logs with "<Username>" and "<IP>".

--- Windows Explorer: ---
(000020) 31.01.2009 22:30:36 - (not logged in) (<IP>) > connected to ip :
(000020) 31.01.2009 22:30:36 - (not logged in) (<IP>) > sending welcome message.
(000020) 31.01.2009 22:30:36 - (not logged in) (<IP>) > 220 My FTP
(000020) 31.01.2009 22:30:36 - (not logged in) (<IP>) > USER Username
(000020) 31.01.2009 22:30:36 - (not logged in) (<IP>) > 331 Password required for <Username>.
(000020) 31.01.2009 22:30:36 - (not logged in) (<IP>) > PASS ********
(000020) 31.01.2009 22:30:36 - <Username> (<IP>) > logged in.
(000020) 31.01.2009 22:30:36 - <Username> (<IP>) > 230 User <Username> logged in.
(000020) 31.01.2009 22:30:36 - <Username> (<IP>) > OPTS utf8 on
(000020) 31.01.2009 22:30:36 - <Username> (<IP>) > 500 Unknown command.
(000020) 31.01.2009 22:30:36 - <Username> (<IP>) > PWD 
(000020) 31.01.2009 22:30:36 - <Username> (<IP>) > 257 "/" is current directory.
(000020) 31.01.2009 22:30:36 - <Username> (<IP>) > CWD /
(000020) 31.01.2009 22:30:36 - <Username> (<IP>) > asked to change directory : 'F:\SHARED\ -> F:\SHARED\' --> Access allowed.
(000020) 31.01.2009 22:30:36 - <Username> (<IP>) > 250 CWD command successful. "/" is current directory.
(000020) 31.01.2009 22:30:36 - <Username> (<IP>) > disconnected. (00:00:00)
--- Internet Explorer: ---
(000039) 31.01.2009 22:44:59 - (not logged in) (<IP>) > connected to ip :
(000039) 31.01.2009 22:44:59 - (not logged in) (<IP>) > sending welcome message.
(000039) 31.01.2009 22:44:59 - (not logged in) (<IP>) > 220 My FTP
(000039) 31.01.2009 22:44:59 - (not logged in) (<IP>) > USER anonymous
(000039) 31.01.2009 22:44:59 - (not logged in) (<IP>) > 331 Password required for anonymous.
(000039) 31.01.2009 22:44:59 - (not logged in) (<IP>) > PASS ********
(000039) 31.01.2009 22:44:59 - (not logged in) (<IP>) > 530 Login or Password incorrect.
(000039) 31.01.2009 22:44:59 - (not logged in) (<IP>) > disconnected.
(000040) 31.01.2009 22:45:06 - (not logged in) (<IP>) > connected to ip :
(000040) 31.01.2009 22:45:06 - (not logged in) (<IP>) > sending welcome message.
(000040) 31.01.2009 22:45:06 - (not logged in) (<IP>) > 220 My FTP
(000040) 31.01.2009 22:45:06 - (not logged in) (<IP>) > USER <Username> 
(000040) 31.01.2009 22:45:06 - (not logged in) (<IP>) > 331 Password required for <Username>.
(000040) 31.01.2009 22:45:06 - (not logged in) (<IP>) > PASS ********
(000040) 31.01.2009 22:45:06 - <Username> (<IP>) > logged in.
(000040) 31.01.2009 22:45:06 - <Username> (<IP>) > 230 User <Username> logged in.
(000040) 31.01.2009 22:45:06 - <Username> (<IP>) > CWD /
(000040) 31.01.2009 22:45:06 - <Username> (<IP>) > asked to change directory : 'F:\SHARED\ -> F:\SHARED\' --> Access allowed.
(000040) 31.01.2009 22:45:06 - <Username> (<IP>) > 250 CWD command successful. "/" is current directory.
(000040) 31.01.2009 22:45:06 - <Username> (<IP>) > TYPE A
(000040) 31.01.2009 22:45:06 - <Username> (<IP>) > 200 Type set to A.
(000040) 31.01.2009 22:45:06 - <Username> (<IP>) > PASV 
(000040) 31.01.2009 22:45:06 - <Username> (<IP>) > 227 Entering Passive Mode (192,168,0,10,212,234)
(000040) 31.01.2009 22:45:06 - <Username> (<IP>) > LIST 
(000040) 31.01.2009 22:45:06 - <Username> (<IP>) > 150 Data connection accepted from <IP>:64825; transfer starting.
(000040) 31.01.2009 22:45:06 - <Username> (<IP>) > 226 Transfer ok
I also tried accessing . Same issues there. Works fine in Internet Explorer, but gives "Invalid Handle" when using Windows Explorer.

Edit: Googled some more and found that this is a known bug which will be fixed in a future build.
My System SpecsSystem Spec
11 Aug 2009   #13

Windows 7 Ultimate x64 Build 7100 (RC)

Quote   Quote: Originally Posted by ZaroXen View Post
Edit: Googled some more and found that this is a known bug which will be fixed in a future build.
Source: FTP
Is there a known workaround to remove the error? Your link doesn't mention any.

BTW. I get this on one machine and not the other. Both are running Build 7100 (RC).
My System SpecsSystem Spec

11 Aug 2009   #14


Better to use a FTP client program,like filezilla!
My System SpecsSystem Spec
12 Oct 2009   #15

Windows 7 Professional 64-bit

I open windows Explorer -> Browse to Computer -> click on Map Network Drive

In the map network drive window click on the link to "Connect to a Web site that you can use to store your documents and pictures"

Followed through the wizard.

Entered the ftp site address without any of the credentials. I then unchecked the "Log on anonymously" checkbox

I then entered my username, was prompted for the password - selected save password.

It then shows up in Windows Explorer as a File Folder.

I hope this helps.
My System SpecsSystem Spec
29 Oct 2009   #16

Windows 7
Found the dreamweaver Fix!!

So, what i did after trying the Test Connection after a billion attempts. I just kept hitting the next button until the site showed up in the right folder in Dreamweaver. From there I told it to GET the site.. and BOOM! the exact reason why windows 7 was blocking my FTP access popped up as blocked by my firewall .. Would you like to allow this program to access your ftp server?... Why yes I would!.. Site is now downloading onto my comp!

Worked for me.. Good luck to all!
My System SpecsSystem Spec
23 Jul 2011   #17

Windows 7 64 bit

The "fixes"mentioned earlier did not work for me.

Here's my problem. I have an HTPC set up in the living room. I used to be able to FTP videos and such to it by opening explorer and in the address bar typing"ftp://usernameassword@ipaddress" Then all the network shares on the htpc would show up and I could transfer files.

Now it won't connect. I get the error about it not being typed correctly or I don't have permission. I've been using MSE antivrus and windows firewall without making any changes to either since I installed windows 7 on all my PC's.
I've tried Filezilla and it doesn't work either. Connection times out.
I ran troubleshooter>view all> incoming connections. It says that more than one device is performing NAT. This might be related to my problem.

Has anyone got a fix that works for me? Is anyone else experiencing this problem as well?
My System SpecsSystem Spec

 FTP Problem

Thread Tools

Similar help and support threads
Thread Forum
Intel Rapid Storage Technology problem : Empty port problem
Windows 7 Home Premium, 64 bit Gateway Laptop NV55C (I would upgrade ut currently not working so a major hardware upgrade is gonna have to wait :( I've got the latest SATA AHCI Driver for my system according to Gateway. As for the latest Intel RST software/drivers, I have version on...
Hardware & Devices
Blurry Text problem, EDID and registry editing problem on an AMD card.
EDIT:I have found a solution, using a DVI to HDMI cable on an amd card will fix this problem, this thread can now die, hopefully someone else will find it if they have this problem. Basically, i know what the problem is, but not how to rectify it. My tv (Sceptre X235BV-FHD, a rebranded sony...
Graphic Cards
Laptop Windows 7 Problem/Software/Hardware? Keyboard problem
Okay, right now I'm currently trying to find out whats wrong with a keyboard that is on a laptop, after the computer starts there are some script errors, I don't know exactly what they are but I ran combo fix without safe mode and restarted the scripts went away...and it started working after...
Hardware & Devices
Moving windows/icons down problem!! Move right/left/up - no problem
New system i7 3930K CPU Sabertooth X79 Mortherboard GeForce GTX690 GPU Intel 520 series SSD 32GB RAM Dell U2711 27" Monitor Win 7 Pro
General Discussion
Cute Html problem and Video full screen problem
Hi I recently made a mistake and I did a full HP system restore and lost alot of my programs and have had to reinstall them. Some programs are there still but just seem messed up somewhat, like my Cute Html editor program. Suddenly, where there used to be the tabs you clicked on that would...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:45.
Twitter Facebook Google+