Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Homegroup Functionality Is Broken

19 Mar 2010   #21

Windows 7 Ult x64(x2), HomePrem x32(x4), Server 08 (+VM), 08 R2 (VM) , SuSe 11.2 (VM), XP 32 (VM)

Quote   Quote: Originally Posted by Duke79 View Post
And it workes like a charm. The folder was invis indeed. When i deleted i went back to services and all the services needed were running again. I was able to leave homegroup and create a new.

Thinking about setting it to a workgroup now, since i read here somewhere that the transfer speeds between workstations might increase then.

Thanks for the help.
glad i could help...

My System SpecsSystem Spec
20 Jan 2011   #22

Windows 7 x64

Hello there,

just found this discussion when seeking around for solution for the same problem.
Unfortunatelly all listed solutions don't apply to my problem. I can't start PNRP Machine Name Publication Service because Peer Networking Identity Manager couldnot be started. If I try to start this manually, I get Error 5: Access was denied

If I look to properties it is started under Local Service credentials. I'm aware to switch to local user account because of possibly losing LS password.
C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking folder doesnot exist,

If I attempt to create home network, I get the progress window lasting forever, no errors in event log during this action.

Any one can find a solution?
My System SpecsSystem Spec
03 Apr 2012   #23

Windows 7 Home Premium 64bit

I had the exact same issue. Finally solved it by changing the 'Startup Type' for Homegroup Listener from Manual to Automatic.

Go to Start Menu>Services
Scroll down to find HomeGroup Listener
Double click on whatever is chosen under the Startup Type column and you change it that way.
My System SpecsSystem Spec

07 Jul 2012   #24

Windows 7 32bit

I had this problem as well and had all but given up. Tried all the solutions given to no avail until I manually restarted my upnphost in Services. It was stopped so I manually restarted it and then even though I wasn't able to manually restart p2psvc or p2pimsvc. I was able to use the homegroup troubleshooter and the pop-out network troubleshooter started by the homegroup one to start them.

Then I restarted my computer and was able to do all of the things related to homegroup.

I literally created this account just now to post this answer as I've had this problem for a LONG time now.

It was through the answers here and a quote from Shinmila H that I figured this out.

I'll post that quote for further reference here.

In order for the HomeGroup networking feature to be working, there are certain Windows services that need to be enabled and running. If you used a program to disable services or manually disabled them, it may be causing the problem.

The services that need to be turned on are listed below:

• DNS Client
• Function Discovery Provider Host
• Function Discovery Resource Publication
• Peer Networking Grouping
• HomeGroup Provider
• HomeGroup Listener
• SSDP Discovery
• UPnP Device Host
You can turn on the services by clicking on Start and typing in “services” and then clicking on Services.
In the Services dialog, double-click on the service and make sure the Startup type is set to Automatic and click Start to turn on the service.

Router Supports IPv6
This is pretty much not an issue anymore, but just for the sake of covering all bases, you need to make sure that your router can support IPv6 protocol. If not, Windows 7 cannot communicate with the other computers using HomeGroup. Any relatively new router will support it, so unless you have a really old router, you should be ok.

Run Network troubleshooter
This is to ensure if the connection failure is due to low network signal or no signal.

Using the Network troubleshooter in Windows 7
Using the Network troubleshooter in Windows 7

Try updating your network card driver to what is compatible with Windows 7 so that there is no conflict.

Check your manufacturer details from DirectX Diagnostic Tool:

1. Open the Direct X Diagnostic Tool. To do this, click Start, type dxdiag in the Start Search box, and then click dxdiag.exe in the Programs list.
2. Click the Display tab.
3. Under Device, look for Name and Manufacturer.
4. Click Exit.

Make a note of the manufacturer, visit the website and download the appropriate driver for your graphics card driver that is compatible with Windows 7.

Referral link for driver updates:

Update a driver for hardware that isn't working properly
Update a driver for hardware that isn't working properly

Shinmila H - Microsoft Support


1) Manually Restart upnphost under Services.
2) Use Homegroup Troubleshooter.
3) ???
4) Profit
5) Read the whole post.
My System SpecsSystem Spec
24 Nov 2013   #25

Windows 7 Home Premium x64

If these didn't work for anyone, as it happened to me, there is a final pro tip from some genius on Microsoft Answers :

I had a similar issue just recently and none of the fixes mentioned anywhere worked.
First thing was to figure out exactly what clicking "Leave the homegroup" does. I opened Process Monitor, added a filter to include results from explorer.exe (as that's the process that spawns the control panel window) then started capturing. Clicking on that link caused explorer.exe to create a new thread then destroy the thread with nothing in between, so I disabled the filters and saw that it was calling svchost.exe. svchost.exe then traversed the registry until it hit a snag. One registry key was giving an access denied error.
Instead of fiddling with permissions, I exported that key, deleted it, then re-added it, and lo and behold, no more access denied error. After this, I did the usual routine of stopping the three Peer* services, deleting the C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking folder, then restarting said processes. This time, clicking on Leave the homegroup worked as intended. With a few more tweaks (disabling and stopping the two HomeGroup services), any mention of HomeGroup in the navigation pane in Explorer was gone.
Ironically, starting the HomeGroup Listener service still gave me some about %%-2147023143. But nevertheless, I'd fixed my issue so all was well.
When in doubt, bust out Process Monitor.
My System SpecsSystem Spec
25 Nov 2013   #26

Win-7-Pro64bit 7-H-Prem-64bit

Actually this is a link which one of the posted solutions came from,
Can't start Peer Name Resolution Protocol
My System SpecsSystem Spec
25 Nov 2013   #27

Windows 7 Ult, Windows 8.1 Pro,

To fix this problem it's actually required to remove ALL FILES which reside in the PeerNetworking folder, not just the idstore.sst file, and you must do this for all machines that were connected to the Homegroup.

I know this because I've fixed the problem myself and just removing the idstore.sst file isn't enough to fix the problem in all cases.

This location > C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking won't be viewable unless you go into Folder Options at the Control Panel then click on the View tab, then set to "Show all hidden files and folders" which will allow you to see the AppData folder so you can get to the PeerNetworking folder.
My System SpecsSystem Spec

 Homegroup Functionality Is Broken

Thread Tools

Similar help and support threads
Thread Forum
Trouble with SSD Functionality
I just bought a new Samsung 830 Series 128 GB SSD. I have installed it into my desktop and I'm using a SATA III Cable to one of the two 6Gb/s SATA ports on my motherboard. When I booted up my computer, Win 7 went through the process of automatically updating the drivers, and "My device is ready for...
Hardware & Devices
Leave Windows 7 Homegroup, Cannot leave homegroup from broken computer
HI everyone, We finally have all computers in the house running widows 7 and would like to set up a homegroup. The problem is a homegroup was set up a few years ago on a laptop, and that laptop is no longer functioning (fried motherboard) as I understand the only way to delete the homegroup is...
Network & Sharing
Desktop functionality
Is there a way to sort a group of desktop icons? I want to sort the default and program icons while leaving user created folders alone.
General Discussion
Readyboost Functionality
I am little curious on readyboost functionality. Readyboost functions work fine. its cache around 3-4 GB data after an hour work. But only thing I have observe when I restart my Windows 7. The readyboot Cache Data build again from the beginning. Is it normal? **Monitoring using W7...
Performance & Maintenance
CCC limited functionality
So i finally installed the latest updates for my graphics card, although they are beta, and everything's up and running. However catalyst control center seems to be missing some tabs and doesnt allow me to change things like my screen reolution, refresh rate, or whether to center my display if im...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:22.
Twitter Facebook Google+