Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: win 7 vpn error

04 Aug 2011   #1

arch linux x64
win 7 vpn error

this is the first time i have tried to set up a vpn using only windows components.

i have made an incoming connection on the win7x64 Ultimate machine which is located on over the WAN (ie.. not local), and i made the outgoing vpn connection on my machine which is also a win7x64 Ult. machine.

i do have the same user login credentials on both machines.
i do have ipv6 turned off on both machines

on the outgoing machine
i have selected mschap v2, optional encryption, pptp,
unchecked automatically use windows login domain
obtain ip auto

on the incoming machine
on the router firewall i have enables pptp port 1720, and also have tried DMZ
windows firewall have tried allowing incoming on port 1720, and have tried firewall off

mainly im getting an error 720

My System SpecsSystem Spec
04 Aug 2011   #2

Windows 7 Ultimate x64

I have had this error with windows 7 from day one and I wish I could tell you how to get around it. I've tried everything as well just as you have stated still to no avail..I don't know but I would like a solution as well.
My System SpecsSystem Spec
05 Aug 2011   #3

Win7 & Win8 64bit

Hello both....

Try disabling IPV6 on both machines, see if it helps.
i do have ipv6 turned off on both machines
My System SpecsSystem Spec

05 Aug 2011   #4

arch linux x64

2xg, does that make sense, i already said i disabled the ipv6 on both, and you even quoted it, and im guessing after i made the topic seth saw that too. so what exactly did you mean by that? the error doesnt exactly have anything to do with ipv6 even so does it?

i thought i posted back though, i got it to work ONCE after disabling both router firewall, AND win firewall on incoming machine. in fact i know i posted back. what happened to that post, maybe got lost in cyberspace.

anyway, i will have to troubleshoot from here to see what firewall caused it. also, i had asked, WHAT PORTS do i need to enable for this PPTP, and VPN (ALL PORTS PLEASE), because 1720 alone isnt enough obviously.
My System SpecsSystem Spec
05 Aug 2011   #5

Win7 & Win8 64bit

oops...I do tend to read things in reverse sometimes, sorry....

Ports Needed for PPTP VPN
- TCP Port 1723
- UDP Port 500

Ports Needed for L2TP VPN
- TCP Port 1701
- UDP Port 500

Ports Needed for IPSec/ESP
- UDP Port 500

Also, try assigning Public DNS's.
My System SpecsSystem Spec
05 Aug 2011   #6

arch linux x64

lol, maybe it was that port 500 then. ill try enabling that. thanks much!
My System SpecsSystem Spec
08 Aug 2011   #7

arch linux x64

well, i have been connecting now and then. i went through the entire VPN architecture at m$ technet, and went through the PPTP, and L2TP tunnel methods as well.

i have written down the settings i have used. Most of them have already been mentioned, so i think the main problem is the internet pipe isnt very stable for this type of connection because i get alot of intermittent results. it makes me think that those who are having hard times connecting, may stumble across the correct settings as i did, but still have the connection drop during that trial run due to bad connectivity and never know that your settings were actually correct. for example, when i am connected, the ping returns from the client to the host are random at best, and this is the case almost everytime im connected. also, sometimes it just wont connect, but if i keep trying to reconnect using the same settings and give the host comptuer time to fully wake up and the network to fully -re-establish itself after it has a brain fart, then it will finally connect.

so dont forget to add a dash of persistence, and try connecting atlest 5 times on each settings that you do decide to try. It could take 5 to 10 minutes if your adjusting the networks hard, sometimes even the router needs to rebuild the routing table, and that takes a while too. dont hesitate to practice router restarts, as well as host and client pc restarts.

i also wanted to mention the thing that i think was the deal breaker for me that was the main problem to not get any connect at all, and once i found that setting the connection went from defunct, to semi-reliable. this setting was in the ipv4 properties of the host. once i set that bottom setting that says 'allow callers to specify their own ip' that got me connected. then i had to go and fix back all the other settings to troubleshoot, like turning up the encryptions to maximum(still worked), and turning off EAP, and CHAP(still worked) and turning on to 'include windows logon domain or account into' (still worked) so as long as your settings are laxed you should get a connection, but check that ipv4 properties on the vpn server host to make sure you fully explore all the variables in there.


client VPN connection properties:

display progress while connection
include windows logon domain
redial attempts 5
time between 10seconds
idle time before hanging up - never
redial if dropped
PPP settings-enable LCP extensions, Enable software compressions
PP2P tunneling protocol
maximum encryption,
ipv4,file and printer sharing, client for windows
include windows logon domain
and log on authentication

server VPN connection properties:
protocl settings - ipv4 (make sure and try to allow users to specify ip), file printer sharing, client for windows
set in your username for allowed users(i used administrator, and my username to be on the safe side)

router properties:
servers router - open ports 1723 tcp, 500 UDP, 4500 UDP

clients router - if filtering outgoing connections, then probably mostly

same as above - ports 1723 tcp, 500 UDP, 4500 UDP

windows firewall properties:

client - on - after enabling misc default rules, including PP2P-GRE headers

server - on - after enabling misc default rules, including PP2P-GRE headers


server software firewall - completely turn off the software firewall on the server machine, test connection.

server router - set ip of server machine to DMZ in router, test connetion.

host vpn settings - test various encryption options, such as 'Optional Encryption'
My System SpecsSystem Spec
08 Aug 2011   #8

Win7 & Win8 64bit

You've tried this too?
Also, try assigning Public DNS's.
My System SpecsSystem Spec
11 Aug 2011   #9

arch linux x64

hmm, i think i did.

i like to use and, but i think for sure i have those set in more than one place, such as at the initial phone usb adapter, and as long as i can route to that device then the device can also pick up the dns's which it will be needed on the next hop.

I did try it in the Networking settings of the outgoing VPN connection i set DNS to public DNS.

also, i did edit those settings in the router when i was messing with it for other reasons. i set them into the dns location of the WAN (, etc..).

i hope thats what your talkiing about.
My System SpecsSystem Spec

 win 7 vpn error

Thread Tools

Similar help and support threads
Thread Forum
Burnt out from error error error! Time to go back to Paper.
Hello there. I have been redirected here by jamanji, whom has been most helpful by the way. My PC crashed a little over a week ago. Rather than retype everything, I would like to give you the link to my post. I am not 'Tech' per se, but I would like to try and resolve my problem myself, To...
System Security
Error 41, Error 1001 and error 6008.
Hello there. Recently my computer have just randomly shutdown meanwhile i'm playing games like CS;GO, League of Legends. The screen will just turn black and it will start to make one hell of annoying noise untill it reboots. I've updated all my drivers. Tested my memory. Tested my RAM. Run a...
BSOD Help and Support
Error copying file: Data error (cyclic redundancy check). CRC Scan ?
Edit: Think my hard drive may be failing and was the cause of my file synchronizing crash. I use it mostly to stream music and video and access the hard drive a lot. Any advice thanks HDDStatus - Tool to check hard disk status, health and reliability Hey, I've been using GoodSync for the...
Backup and Restore
BSOD by ntoskrnl.exe, error d1, error 3b, error 1a
I've just install windows 7 home premium 64bit and got 4 times of BSOD. for the first time error code is 0x0000001a for the 2nd time error code is 0x0000003b for the 3rd time error code is 0x0000003b for the 4th time error code is 0x000000d1 I also attach minidump files and text files that...
BSOD Help and Support
Scan Error Error while Scan::0::LEAD Error: Twain source manager no
hi.... i have promblme , i do not know how to fix it.. i have kodak scnners i1220 plus i have RD Web Access the promblme is.. I have a system based on Oracle has been connted with one scanners( i connected with scanners) When i do a scan shows me this a message (Scan Error Error while...
Hardware & Devices
BSOD error.. Restarts, but power button stays on, graphics card error?
Hey guys, i want to thank you ahead of time for helping me. This BSOD is a pain in the butt. Intel Pentium 2.8GHZ RAM 3.5 32 bit OS Intel GG965 Express Chipset Family I have already reinstalled the operating system multiple times, i think its a faulty graphics card, but i want to be...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:14.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App