Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Error 0x80070522 (no solution?)

08 Aug 2011   #1

Windows 7 Home Premium 64-bit w/SP1
Error 0x80070522 (no solution?)

I'll describe the scenario under which my issue occured so that maybe it will by chance give someone an idea of what actually happened (because I don't understand it at all).

I networked my desktop and laptop computers the other day. I shared my entire hard disk on my laptop with my desktop. Now I know that's not recommended, but I've done it in the past without any issues, and I feel pretty secure having things confined to the walls of my home.

I was right in the middle of copying a file from my desktop over to my laptop in the root C directory, and I noticed it seemed to be taking much longer than usual to copy the file. Then with the progress bar halfway, it yields this error:

An unexpected error is keeping you from copying the file. If you continue to
receive this error, you can use the error code to search for help with this
Error 0x80070522: A required privilege is not held by the client.
So I went to the Documents shell folder and tried copying it there. I got the same problem.

I gave up and transferred the file to a flash drive and was going to copy it from there to my laptop, but surprisingly I got the same error. I finally tried copying the file to the desktop where it worked like a charm... but it wasn't where I WANTED it.

I restarted my computer and tried copying that file from the desktop to the root C directory, and I got the error again.

I'm not an expert on networking by any means, but I feel it's not at all normal for my computer to just suddenly disallow me to copy files into certain directories out of the blue. I have played with it a while and haven't had any problems copying/saving/deleting files in any other location I've tried -- it's just the root C directory and Documents folder. Thing is, I didn't even touch the permissions on anything.

I looked up my error online, found numerous sources:

“Error 0x80070522: A required privilege is not held by the - Microsoft Answers

Error 0x80070522: A required privilege is not held by the client - Microsoft Answers

There was also a post on these forums (somewhere... I can't seem to find it now) which had some REG files to download that would allow taking ownership of individual files. I tried that, and I tried the links above, and nothing works. I can disable UAC entirely and everything works, but when I turn it on, I am restricted from doing anything in the Documents and root C locations. I even tried a System Restore point from 2 days ago... didn't fix anything.

I compiled a list of my settings:

Local Disk (C Properties
-> Owner
-> -> Damian (DAMIAN\Damian)
-> Security
-> -> Everyone (everything checked)
-> -> SYSTEM (everything checked)
-> -> Damian (DAMIAN\Damian) (everything checked)
-> -> Administrators (DAMIAN\Administrators) (everything checked)
-> -> Advanced
-> -> -> Allow Damian (DAMIAN\Damian) Full control
-> -> -> Allow Everyone Full control
-> -> -> Allow SYSTEM Full control
-> -> -> Allow Administrators (DAMIAN\Administrators) Full control
-> -> -> Change Permissions...
-> -> -> -> Edit Damian (DAMIAN\Damian)
-> -> -> -> -> Allow Full control
-> -> -> -> -> Allow Traverse folder / execute file
-> -> -> -> -> Allow List folder / read data
-> -> -> -> -> Allow Read attributes
-> -> -> -> -> Allow Read extended attributes
-> -> -> -> -> Allow Create files / write data
-> -> -> -> -> Allow Create folders / append data
-> -> -> -> -> Allow Write attributes
-> -> -> -> -> Allow Write extended attributes
-> -> -> -> -> Allow Delete subfolders and files
-> -> -> -> -> Allow Delete
-> -> -> -> -> Allow Read permissions
-> -> -> -> -> Allow Change permissions
-> -> -> -> -> Allow Take ownership
Clearly I have full privileges, and yet Windows acts as if I don't. The account I'm using is Damian, and I am an administrator.

What the heck is going on here?

My System SpecsSystem Spec
08 Aug 2011   #2

Windows 7 Home Premium 64-bit w/SP1

Why was this moved to Network Sharing? This has nothing to do with Network Sharing, other than it first occured during a networking session... I'm not sharing anything right now, and I'm having problems changing files on "this" computer from "this" computer. There's no networking involved.
My System SpecsSystem Spec
16 Aug 2011   #3

Windows 7 Home Premium 64-bit w/SP1

This is still unresolved. Can anybody help me?
My System SpecsSystem Spec


 Error 0x80070522 (no solution?)

Thread Tools

Similar help and support threads
Thread Forum
Creating a new file in C: drive gives error 0x80070522
If I try to create a new file in C: drive, I get this error: Error 0x80070522: A required privilege is not held by client. I first noticed this error after doing a 'frugal' install of BackTrack 5R3 (Linux distribution) setup on C: using UNetbootin. I thought it must be preventing me from creating...
Hardware & Devices
driverpack solution 13 3.90 (script error)
i m trying to update drivers with driverpack solution 13 but it give me script error (an error has occurred in the script on this page). my os is win7 starter 32x.. plz help me:(
Installation & Setup
Hello, I am unable to create any file in C drive. If i try to create i am getting threat ID 0x80070522. I system is connected to the LAN. I have admin rights. Please help in this regard.
General Discussion
Installation Error Can't find solution.
Hey all, I have been trying to reinstall Windows 7, but I have some problems... (this is a repost of an old thread, same problem with an added trouble) I backed up everything i needed, and decided it was time to start with a clean OS. I tried reinstalling Win 7 Ultimate x64 (With the same...
Installation & Setup
Installation Error Can't find solution.
Ok, so during the week Win 7 Ultimate x64 got really buggy. ie - Internet explorer decided that it would open itself countless times before it froze my computer. Same would happen with Safari and endless amounts of tabs would open in Firefox. Sooo i backed up everything i needed, and decided it was...
Installation & Setup
Weird Error 0x80070522: A required privilege is not held by the client
I have a weird Error 0x80070522 error on one of my partition. Why is weird ? Well because I cannot save anything on the partition because I receive this error. However sometimes, randomly i can copy files on that partition after I receive the ''You need to provide system administrator privilege.......
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:23.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App