Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cisco AnyConnect VPN Client - Installation/Use Problems

12 Aug 2011   #1

Windows 7 Enterprise 64-bit
Cisco AnyConnect VPN Client - Installation/Use Problems

I've been suffering from Cisco AnyConnect VPN client problems for a couple of weeks.
I had been a successful user connecting to my company's VPN, for years, but then tried to use the Client to connect to a different VPN server at my university, for a one time use to get access to a research paper download.

Woe woe woe. Woe woe woe.

Never do that!

There are tight version bindings between the particular client and the particular server.
Once my installed client had talked to the university server, the client would no longer talk to the company. Deep modifications had taken inside applications data folders and the registry so that from then on it would make the university server the default, and fail to establish a connection when I tried to direct it to the company server. Even uninstalling and reinstalling the client would not break the binding to the university.

Eventually I had to go through the registry, item by item, delete every registry key that involved AnyConnect. Also, I had to track down AnyConnect applications folders. Once that was done, the client would once in a while talk to my company again.

Adding misery to the process is the awful web based installer for AnyConnect. Rather than being a simple .exe running the installer, the only way to successfully install AnyConnect is by invoking the web based installer which invokes the epitomes of reliability - ActiveX (after giving the VPN server key full trusted party status) and the Java Runtime plugin. This Cisco contraption fails to work for mysterious reasons 9 out of 10 times.

(Let me take this moment to editorialize about Cisco. Our company buys Cisco because we have some mysterious theory that it is more reliable than other brands, because it is Cisco. In fact it's my decision since I run the company! Well it's total bologna. Cisco equipment costs 3X to 5X its competitors (since it's Cisco), is fragile and buggy, requiring you pay that amount again with consultants (or in house staffing hours) to get it to work. Cisco support is ponderously slow and the support guys on the phone barely understand the equipment. I can recommend, from personal experience, in squandered money, time, that you avoid Cisco! It's like tying a boat anchor around your neck as you swim the channels of business, when you buy Cisco. I groan about the Bill Gates Windows cognitive tax - any job you try to do requires 20% overhead to fuss with some Windows crash, bug, etc. But Cisco totally outclasses that - the equipment requires 1000% overhead, and never works more than 80% of what it is supposed to do. I could go on but...)

So, anyway, having somehow damaged my prospects with the AnyConnect client I am relegated into some hell of trying to install it, with the error message about failure to create the Communications Depot (some sort of mysterious service).

My System SpecsSystem Spec
13 Aug 2011   #2

Windows 7 Home Premium 64bit

I also use Cisco AnyConnect VPN Client. :)
... although I have not had that error message.

After a little digging around in Google, I came across this:
How to Install, Configure and Use the Cisco AnyConnect VPN for Windows 7, Vista and XP - OIT Help Desk

The following quote is at the bottom of the page:

Known Issue

Windows Internet Connection Sharing (ICS) is not compatible with the VPN client. If you attempt to install, you will receive an error on the install that says "The vpn client agent was unable to create the interprocess communication depot." Turning off ICS and reinstalling will fix the error.
Also from here:
WiscVPN (Win) - Interprocess Communication Depot Error

The vpn client agent was unable to create the interprocess communication depot.

This error is caused by Internet Connection Sharing (ICS) being enabled. You can disable ICS in two ways:

Per Adapter:
  1. Click the Start button.
  2. Click on Control Panel.
  3. Click on View Network Status and Tasks
  4. Click on Change adapter settings
  5. Right-click the shared connection and choose Properties
  6. Click the Sharing tab
  7. Clear the Allow other network users to connect through this computer's Internet connection checkbox
  8. Click OK
System Wide:
  1. Click the Start button (Windows' orb)
  2. Type: services.msc and press ENTER
  3. Double-Click on Internet Connection Sharing (ICS)
  4. Change Startup Type to Disabled
  5. Reboot the computer
You can now try reinstalling the WiscVPN client again
Hope that helps, nyg.
My System SpecsSystem Spec
15 Aug 2011   #3

Windows 7 Enterprise 64-bit
Problem solved thank you.

Brilliant! Thank you. When I read this, I realized that indeed I had been messing around with Internet Connection Sharing, to help colleagues at a workshop without Internet, to connect via my broadband. It was the next day that I started to have trouble with AnyConnect, but I'd attributed it to trying to connect to the University VPN as well as business VPN.

I was doing connection sharing with some Intel "My Wifi" software that was on my laptop (maybe that came from Lenovo?), but the combination of that, the Verizon Broadband, and Lenovo's Access Connections, didn't allow that sharing to work. But when I gave up, Internet Connection Sharing must have been left enabled.

So just now, with your advice, I disabled the Internet Connection Sharing at the system level. (I didn't spot any "Network Status and Tasks" icon in control panel, that is mentioned your quote.) After this disabling, and rebooting, the VPN Client Installed perfectly. So problem looks solved.

As an aside, I did try to get in and debug this. I used procmon to log what was going on at a deep level. What I observed is that the Cisco installer contraption is very strange; it downloads the vpndownloader.exe somehow as an ActiveX control. If that fails, it seems to try to download it again and get the Java client to invoke it? All it looks like the Java app is doing is invoking a freshly downloaded vpndownloader. Pretty ugly software design, IMO, real Rube Goldberg stuff (thanks Cisco). I logged it trying both attempts and fail, using Procmon, but the log messages there and with the event log, didn't make sense.

Many hours wasted on this. I'll keep my fingers crossed that it's solved.
My System SpecsSystem Spec

16 Aug 2011   #4

Windows 7 Home Premium 64bit

Pleased to hear that, nyg. I feel 'quietly' confident that all will be well.
My System SpecsSystem Spec
04 Sep 2012   #5

Windows 7 Pro 32bit
At last, I've found you

I have been struggling about this issue, and by doing the suggested solution my problem has been resolved.

System Wide:
Click the Start button (Windows' orb)
Type: services.msc and press ENTER
Double-Click on Internet Connection Sharing (ICS)
Change Startup Type to Disabled
Reboot the computer
My System SpecsSystem Spec

 Cisco AnyConnect VPN Client - Installation/Use Problems

Thread Tools

Similar help and support threads
Thread Forum
Cannot install Cisco AnyConnect-problem with Windows Installer package
I am trying to upgrade my VPN software to Cisco AnyConnect but I cannot get the software to install on my laptop. The installation process seems to make a fair amount of progress, but then it stops and says: "There is a problem with this Windows Installer package. A program run as part of the...
IE Doesn't Work After Accessing PC Via Cisco AnyConnect
I have an end user who accesses their PC from home using Cisco AnyConnect. They remote in, work on some documents, and then disconnect. When they come in the next morning they're unable to access the Internet via IE and they're also unable to print. However, they're still able to access network...
Network & Sharing
Cisco AnyConnect diasbles internet upon exit on Windows 32bit pro
Hi, Please can someone shed some light for me, I've had to install Cisco Anyconnect VPN for all win7 laptops. All is fine in terms of users can access VPN and get on to our network. but once you quit VPN and disconnect. You cannot get internet access. I originally thought this was due to...
Network & Sharing
registry access through Cisco Anyconnect client
I have an application that works without issue through a Cisco Anyconnect client on XP and Vista, but not on Windows 7. It also works on Windows 7 when accessed locally (no Cisco Anyconnect client). When I try to use it on Windows 7 through the Cisco Anyconnect client, I get an error message...
General Discussion
Cisco VPN Client on 64-bit W7?
Hi, I'm fresh installing W7 and am considering going to 64 bit. My institution uses Cisco VPN Client for VPN access. I understand that there is no 64 bit version of the VPN client software. What to do? I've read that using XP Mode would work. I've also seen suggestions to use Shrew VPN client...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:55.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App