Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: can't connect wirelessly to home network

31 Aug 2011   #1
Phil S

windows 7
can't connect wirelessly to home network

Hello folks,

A new laptop: Acer Aspire 7551-3650
Router is Linksys Wireless-G WRT54G2 V1
OS is Windows 7 64-bit Home Premium
Network Adapter is Broadcom 802.11n
its driver is which Driver Whiz thinks is up to date

The issue is the laptop connects wirelessly in hotels, at my ISP's office, at airports etc, no problem - but will not connect to my home internet. It will connect to my home internet via cable plugged into the router.

I have 2 desktops at home, one plugged into the same router and one connecting wirelessly with no problem.

When I attempt to connect the laptop, it detects my linksys router with a strong signal, and accepts the system password to log in - but then I get the message that it cannot connect to linksys.

If I deliberately put in the wrong password it tells me so, so I know it is at least shaking hands with the router.

Can anyone suggest the kind of thing I should be looking at to fix this?

Thanks for your time.

My System SpecsSystem Spec
31 Aug 2011   #2

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86

Check the ip settings.
My System SpecsSystem Spec
31 Aug 2011   #3

Win7 H.Prem. 32bit+SP1

Hi Phil S, Welcome to Seven Forums.
Does your router have 'Access Control' my Netgear DGN2000 has. Also check your Firewall.
My System SpecsSystem Spec

31 Aug 2011   #4

Win7 & Win8 64bit


In addition to the other recommendations please remove all your wireless networks stored. Reconnect to your SSID, make sure that you type in the correct encryption.
Wireless Network - Remove

Please let us know.
My System SpecsSystem Spec
31 Aug 2011   #5
Phil S

windows 7

Thanks for your suggestions guys. I did as suggested, and bolded below my most promising lead.

I removed all stored network profiles and restarted a new one but same result.

I checked Windows Firewall, and I see the following two items:

Home or work (private) network - Connected
Public network - Not Connected

I'm not sure how to interpret what I am seeing here to be honest, but both items are preceeded by a red shield icon with a white X in it, which I believe is telling me the Firewall is inactive. I don't seem to be able to alter the Connected/Not Connected status. McAfee is installed but the trial period expired so I presume it's inactive.

I checked my IP settings using ipconfig and it tells me:
IPv4 Address =

whereas when I connect to my router, it shows 'Starting IP Address' =

I did the same process on my desktop and it shows

Perhaps this is the cause of my issue? I'll hold off on experimenting with a change in case I break something.

My subnet mask settings and default gateway settings are identical on both laptop and the router.

Finally, I thought of plugging in the wireless antenna I use for my desktop, to the laptop, and the laptop connects wirelessly through this.

Many thanks once again.
My System SpecsSystem Spec
01 Sep 2011   #6
Phil S

windows 7

After more research I am now doubting the bolded part of my last post suggests the solution. Would welcome any other ideas.
My System SpecsSystem Spec
01 Sep 2011   #7

Win7 & Win8 64bit

Please remove McAfee Trial it might be intervening with your wireless connection. Here's the Removal Tool.

Install MSE for protection.

Keep us posted please.
My System SpecsSystem Spec
02 Sep 2011   #8
Phil S

windows 7

Both steps done 2xg - thanks but no change in the situation.
My System SpecsSystem Spec
02 Sep 2011   #9

Win7 & Win8 64bit

Can you pls. post the ipconfig /all output for review?

Are you able to browse in Safe Mode with Networking? Restart your computer, tap F8 and select this option.
My System SpecsSystem Spec
03 Sep 2011   #10

windows 7 home premium 64bit
need to tweak advanced wireless parameters?

I had exactly the same problem with a linksys WAG54G v2. I reported the solution in a thread one week ago. I think that there is some problem with the old linksys firmware for g connections. I found that at 48Mbps it worked fine.

Problem with wi-fi connexion using D-Link dir-615

Good luck,
My System SpecsSystem Spec

 can't connect wirelessly to home network

Thread Tools

Similar help and support threads
Thread Forum
still looses connect/doesn't connect - win 7 wireless home network
She keeps loosing connection, then has to wait until it decides it can connect again. She would wait about five minutes and then click on something and would gain access. the ...
Network & Sharing
Network controller driver issue, cannot connect wirelessly
After being hit with a Trojan virus, I re-installed Windows 7 Premium 32-bit. However, I now cannot connect to my wireless network. In device manager, there is a yellow triangle and ! against network controller. I have no idea what network controller I have. Speccy can only identify a Marvell...
Can no longer connect to home computer over home network
I have a home desktop computer, and a work laptop. Over the years I've changed laptops and home computers, and have always been able to get network sharing working so I can transfer files between them by using \\<hostname> I've had my current setup for about 6 months now, and have been able to...
Network & Sharing
Can't connect to home network wirelessly?
Alright, I've had my laptop for about a year and its worked fine up until recently. A few weeks ago, the internet on it stopped working, but it works on our desktop, which uses XP. I can connect to other networks fine, it's only my home network. Whenever I tried to connect, it would load for a long...
Network & Sharing
XP VM does not connect wirelessly with home network or wirelessprinter
I'll start with the problem, and anyone ask and I'll fill in what information (drivers, programs, etc) are needed to round out the problem and hopefully we'll find a solution together! I have Windows 7 64-bit (Professional of course) and it was installed 2 years ago with the XP Virtual Machine...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App