Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unidentified Network, Clean Win7 install, tried several NICs

01 Sep 2011   #21

Windows 7 Ultimate SP1 64-Bit

I can't guarantee this fix will solve your problem, but I feel it's worth a try.

Click Start and type cmd in the Search field.

Right-click cmd and choose Run as Adminstrator to open the command prompt window.

Type these three commands and press Enter after each one in turn:

netsh int ip reset C:\netsh.log.txt

netsh wisock reset


The command prompt window will close.

Restart your computer and check your network is clear.

My System SpecsSystem Spec
01 Sep 2011   #22

Windows 7 Ultimate x64

I'm guessing you meant netsh int ip reset and winsock reset.
Anyway, I tried that, still didn't work. Same problem.
My System SpecsSystem Spec
01 Sep 2011   #23

Windows 10 Pro x64 x3, Ubuntu

I am wondering if the way that you are connecting is causing windows to disallow a "home" Network.

I cannot find definitive proof but I think that one of the requirements for a Home network is to be allocated an IP address in one of the private IP pools , (192.168.x.x or 10.x.x.x), rather than the direct ISP IPs you have.

there is no difference between the Home, Work or Public network type's ability to connect to the internet.

The difference in the network types is more to do with the Local access ....
  • Home gives full local Peer to Peer access and homegroup,
  • Work gives Full Peer to Peer and Client Server Access
  • Public gives no local access (designed for Public locations such as coffee shops where you do not wish to allow others access to your files

As your PCs are in a public range it may be that the system is assuming that you are in a public environment.

You could try to check that DNS is operating - ping an external address, eg Microsoft or google and check that the reply shows an IP address. If you do not get an IP retuned, try using a public alternative DNS server ( ), and see if this improves things
My System SpecsSystem Spec

01 Sep 2011   #24

Windows 7 Ultimate x64

But as I said, my old computer was connected the exact same way and another computer on the network is also connected the exact same way
My System SpecsSystem Spec
01 Sep 2011   #25

Windows 10 Pro x64 x3, Ubuntu

Strange, you seem to have everything covered ....

if the gateway on the non-working windows 7 machine is the same as a working win7 machine it should work.

The cable is OK as you can ping locally so that's not an issue (one of the main issues is mechanical connection in wired systems).

You have eliminated driver issues by the use of alternate NICs

You have reset the network stack

ISP can see your PC so external network is working.

Only thing I can think of is firewall .... glitch, are you on windows f/W or 3rd party f/W or Security Suite?

Can you ping external site by IP ? try []

BTW Homegroup is not a valid option in your network as HG is win7 only so would not allow access to MAC, you will need to use legacy Windows networking to allow access to MAC though HG will work between win7 systems assuming IPv6 is active and auto and the gateway supports IPv6
My System SpecsSystem Spec
01 Sep 2011   #26

Windows 7 Ultimate x64

I am on the built in Window FW, tried disabling it, did not work.
My System SpecsSystem Spec
01 Sep 2011   #27

Windows 10 Pro x64 x3, Ubuntu

Ok one last thing to check on the software that I can think of ....

the windsock reset works on two registry entries that should have full permissions for administrators group.


check the permissions on these allow the administrators to change them (the reset must be done as administrator).

full MS KB is at .....

How to reset Internet Protocol (TCP/IP)

My System SpecsSystem Spec
01 Sep 2011   #28

Windows 7 Ultimate x64

Okay, how do I check the permissions?
I'm guessing I open regedit, but what next? There's a system/currentcontrolset/services/tcpip(and dhcp)/parameters under HKEY_LOCAL_MACHINE, is that correct?
My System SpecsSystem Spec
01 Sep 2011   #29

Windows 10 Pro x64 x3, Ubuntu

Yes that's the right locations - to check permissions right click the key name and you should see a permissions entry at bottom of list, select this and check that administrators and System have Read and full control.

Should not be an issue on a new system but you never know.

Last thing on a mechanical side is to disable the on-board NIC in Bios, boot into windows and remove the drivers (choose option to remove all files if presented), re-boot you can then try your USB NIC without any chance of interference from the on-board NIC or drivers if they are faulty, you may even find that a complete clean like this will fix the issue if you then re-enable the NIC in BIOS and allow a driver re-install, (let windows look for the driver first)
My System SpecsSystem Spec
01 Sep 2011   #30

Windows 7 Ultimate x64

The permissions were full access for administrators on both the entrys.
Tried disabling the onboard nic in bios and connecting the usb-nic. Still the same problem. Unidentified network, no internet access.
My System SpecsSystem Spec

 Unidentified Network, Clean Win7 install, tried several NICs

Thread Tools

Similar help and support threads
Thread Forum
Win8 laptop, win7 clean install, network card driver issue
Hello ! First and foremost please be advised that I have done this before without issue. Toshiba Satellite laptop L855-S5383 Realtek network card As stated before, I have done this before. Though its a separate laptop, these two laptops are identicle 100%, I bought them both together at...
Network adapter not recognised after Win7 clean install
Hi, I decided to do a clean install of my Windows 7 Ultimate on my PC (not a brand model, but one that was assembled together in-store). While everything worked fine before the install (it was slow, hence the clean install), the installation went well except that the network adapter cannot be...
Network & Sharing
Fresh install of Win7 *unidentified network/no network access*
I've freshly installed Windows 7 Enterprise 64 bit on my system that previously had Ubuntu installed, and prior to ubuntu had win7 ultimate installed. With the fresh install of win7, I receive an unidentified network/no network access issue. Heres a list of things ive tried: - reset the...
Network & Sharing
Unidentified Network - No Network Access - Win7 64bit
For some time now my internet would be fine for 1hour after booting up my computer and then the network would then fail to be recognized. I have followed multiple tutorials on the internet, with countless suggestions, where other people have had the same problem. Some seem to fix the problem for a...
Network & Sharing
"Unidentified Network" after Fresh Install of Win7
So I recently installed Windows 7 x64, and suddenly my wireless connection is no longer working. It worked fine with the previous Vista 64-bit OS. I'm able to connect to a different router, and the internet works fine. However, I cannot connect to my Home router. Other laptops are able to connect...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:49.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App