Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Network Issue causing significant CPU/process utilization.

09 Sep 2011   #1

Windows 7 Home Premium 64-bit SP1
Network Issue causing significant CPU/process utilization.

Hello everyone. I just got my first Windows 7 PC and I am quite pleased with it. However, I have a nagging problem that I haven't been able to resolve myself.

My problem is that whenever my computer is connected to my home network and the internet via wireless G, something causes a process called "System" to continuously hog an average of 13% of my CPU, significant enough to catch my eye. The PID of the process is 4, and the description is "NT Kernel & System".

I have done hours of trial-and-error methods to resolve this, but to no avail. But I have narrowed down the culprit somewhat. All I have to do to stop the CPU usage is quite simply disconnect from my home WiFi. I do NOT have to disable the card itself (through Device Manager) to stop the load. I do not think this machine originally had this problem out of the box, and I'm not sure if some kind of update started causing it.

I'm not sure about this aspect, but this problem might have started two days ago when I applied some updates to my PC. I used software that came with my machine called HP Support Assistant to install updated drivers for the WiFi card, and a few other things. I thought to roll back the driver to the original one to try and fix the problem, only to find that there was no driver to roll back to, even though it had been updated! I thought this was strange, and figured it was a dead end.

There might be another symptom associated with this problem. If I disconnect from the network and then reconnect, the icon in my Start menu taskbar for networking shows a yellow exclamation point sign, in front of my bar meter, and it reads "No Internet Access". But even though it says this, I have no trouble browsing the web through my browser or connecting to the internet. This is mighty odd to me. Eventually, usually 30-60 minutes after I reconnect, the icon changes to the correct one, and doesn't read "No Internet Access" anymore.

I have had a similar problem like this one on my older, Vista 32 machine, which I was never able to resolve. I am somewhat familiar with programs like ProcessExplorer and ProcessMonitor to try and figure out what the problem might be. Sorry for the long post, but I thought I would try to be as specific as possible. Any help is greatly appreciated and eagerly anticipated! Thank you all kindly in advance.

My System SpecsSystem Spec
09 Sep 2011   #2

Windows 7 Ultimate 64Bit (SP 1)


I wouldn't worry about the CPU usage, as the system process will undertake a lot of processes when your PC is idle.

As for your network issue, try updating the driver from here:

My System SpecsSystem Spec
11 Sep 2011   #3

Windows 7 Home Premium 64-bit SP1

Hi UKMedia, and thank you for your response. I understand what you said, but I still worry about the CPU usage, because it doesn't happen all the time. So this leads me to believe it is not a normal idling behavior. Let me explain.

If the computer is coming out of standby, I do not have this problem. However, if I disconnect and then reconnect to my network, the problem happens again. Also, no matter what state the computer is coming out of, whenever it connects for the first time, Windows displays "No Internet Access", even though I have no trouble connecting to the internet through my browser. When I go into Network and Sharing Center and click the problem red "X", Windows tries to detect the network issue, and the "X" quickly disappears, as if Windows says, "Oh, it looks like I can connect to the internet after all! Huh!".

I think I have narrowed this issue down to the driver. I managed to reload an older driver, and the CPU never spikes like it does with the newer driver. However, Windows still has the "No Internet Access" problem, even with the older driver. This conflict is a problem, because I wish to use the newer driver because of its added features, but the older driver does not hog the CPU for any odd reason.

I feel like this is a problem with the order some drivers load when you boot Windows. I think this because it doesn't seem to have this problem coming right out of a standby state. But I don't understand why a simple disconnect and reconnect, with no disabling whatsoever, causes the problem again. Maybe I should keep my eye out for a newer driver sometime in the future. But any further help will be swell as well! And I don't want to give up! My WiFi card is a Broadcom, if that helps at all. Thanks again.

*EDIT* - Scratch that it doesn't happen after coming out of standby, because it does. My mistake. Sorry.
My System SpecsSystem Spec

18 Sep 2011   #4

Windows 7 Home Premium 64-bit SP1

I just wanted to let everyone know that I've solved this issue so I can close this thread. This is how I did it.

I have an Epson printer on my network via WiFi, and installing the proper drivers on my Windows 7 machine for that printer fixed the problem. Apparently, the computer was constantly pinging the printer or something, and that's what was causing the CPU usage. I think it had to do with the memory card slot on the printer itself, because a feature of the printer is that you can access that card slot over the WiFi network. So if anyone else out there is having a problem like the one I described, I advise you to install all networked printer drivers and software for all of the printers you have on your network. Install all software and drivers for all the networked devices that you have on your network, for that matter. That might work for anyone else out there with a problem like mine.

I didn't install the printer stuff yet on my Vista machine, but I plan to soon, and I'll bet that will fix the problem on that machine too. Thanks for your time.
My System SpecsSystem Spec
18 Sep 2011   #5

Windows 7 Home Premium 64-bit SP1

Sorry everyone. I just realized while I was posting my last message that the problem is still NOT solved. Now, I feel very down. Ugh. *sigh*
My System SpecsSystem Spec

 Network Issue causing significant CPU/process utilization.

Thread Tools

Similar help and support threads
Thread Forum
How do increase my network utilization-W7 Home Professional x64
How do increase my network utilization By: Qosmio X505 Q894 Part# PQX33U-051025 Realtek RTL819SE Wireless LAN 802.11n PCI-E-NIC Busy Network Adapter Is less than 15% Using: 6.387.776 Capacity: 54.000.000 Virtual RAM: 8GB Windows 7 x64 Home Professional If I RUN:
Network & Sharing
BSOD caused by GPU? Causing significant problems
Hello, I have had issues since I initially received my computer in 2009 with BSOD caused by conflicts between NVidia's driver and win7. In the past, I have successfully been able to find a fix. After the last update round (from Windows), things went awry. I have been dealing with this for...
BSOD Help and Support
Significant Issue with CrossFire to be Aware of
Figured I should make a thread about this issue in this forum as well in case you guys aren't aware of it. Long story short: Basically, it appears that the actual output frames (not the frames "rendered") by cards in CrossFire on more GPU demanding games as apposed to CPU demanding/limiting...
Graphic Cards
Task Manager not showing memory utilization per process
Hi guys, As the title says, my Task Manager is not reporting the memory utilization for any running processes. Here is a screenshot that describes best the problem I'm having. If anyone has a solution to my problem, please let me know. Windows 7 Home...
General Discussion
Copy process uses 100% cpu utilization
Need some help here. Trying to copy files from one external HD to another using Windows Explorer. The moment the copy process is started - the CPU hits 100% and the whole system becomes sluggish. When I click on cancel - the system does not restore CPU utilization (it's still 100%) and have to...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:41.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App