Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Missing MSAFD Netbios entries

20 Oct 2011   #1
ComputerJoe

windows 7 home premium 32bit
 
 
Missing MSAFD Netbios entries

I have run Malware Bytes, Superantispyware, TDSSkiller and have found no infections and this machine had Norton 360 on it but it seems non-functional now (no system tray icon).

I get an IP from the router, I can ping the router and other external IP's (yahoo.com) but can not browse to either the IP's or a URL. I followed a MS winsock2 corruption KB (811259) advise and found that 6 entries are not in Msinfo32-components-network-protocol. Those being the MSAFD NetBIOS entries.

I ran Hijack This and it called out missing files under O23: BUT I ran it on a brand new (good) win7 machine and it listed missing files under the same O23: entry. And all the entries listed are in the appropriate folders...go figure.

I'm at a loss where to go after doing the netsh winsock reset
---------------------------------------------------------------
I have run the Norton Removal tool so that is out of the picture.
IE shows "waiting for response" but nothing comes.
Chrome likewise cannot browse.


My System SpecsSystem Spec
.
20 Oct 2011   #2
ComputerJoe

windows 7 home premium 32bit
 
 

I have been forging ahead and now I don't seem to be able to get an IP from the wired connection anymore but the wireless is working just fine. I only have one wireless router, go figure. Gonna try removing the NIC from device manager and re-installing.
My System SpecsSystem Spec
Reply

 Missing MSAFD Netbios entries




Thread Tools




Similar help and support threads
Thread Forum
Missing Registry entries
Hello, Upon Right clicking the Desktop the upcoming contex menu doesn't list the "NEW" option, neither able to create a new foder option in file menu. As a solution I was advised to set a new value in HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers\ but three entries are...
Performance & Maintenance
Netbios over TCP not working (Home group)
Hello, Im trying to configure a Home Group between a desktop W7 64 Ultimate and a laptop W7 64 Home Premium. Reading the forums and MS instructions didnt do, so I did an ipconfig /all on both. In the desktop Netbios is not active, but client for MS network is checked in the adaptor, file...
Network & Sharing
HJT shows many "file missing" entries
Hi. Just got a new Windows 7-64 machine from Cyberpower, so there is no junk or shovelware installed. In addition to the 240 GB SSD system drive, there are two 2 TB data drives configured as RAID 1. Since I got the machine, it's been locking up, hanging, crashing, and video disappears. My...
BSOD Help and Support
NetBIOS over TCP/IP Disabled and cannot enable
I'm having this issue where in the advanced WINS settings for the Network connections I have enabled the NetBIOS over TCP, but if I run the network information through the command prompt it states that it is disabled. I am also trying to mount shares on my network and I get the error message that...
Network & Sharing
MSE, restarts before login, missing event log entries
Hi, I'm quite consternated and I'd love to hear your opinions on this. The story: I'm experiencing strange restarts but not random, I can routinely replicate it. After a boot IF I leave the logon screen alone (i.e. without logging in), the system restarts itself almost like automatically...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:56.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App