Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: iPhone network location doesn't save when disconnected

21 Oct 2011   #1

Windows 7 Pro x64
iPhone network location doesn't save when disconnected

Hi guys.

I have an iPhone 4 which has internet tethering. I can either connect this via the USB cable or wirelessly via my intel 6300N wifi card.

When I connect to my laptop via USB cable, the 'Set Network Location' box comes up, which I select Home Network. It is simply named 'Network', but I then go in and change 'Network' to 'iPhone'. This then shows up in the Network and Sharing Centre as iPhone on a Home Network. This works perfectly, is super fast and when I'm finished, I disconnect the USB and shut down.

When I next turn on my laptop and connect my iPhone internet tether via USB cable, I am once again asked to ''Select a location for the 'Network' network''. Windows 7 netwkr and Sharing centre isn't recognising the same iPhone is connected and asks me to set up a home network again.

I've gone into 'Merge or delete network locations' and the original 'iPhone home network' is set up (not in use) as well as the new 'Network' location that it's asking me to set up. If I merge the second 'Network' and original 'iPhone network', this removes the second network and I'm left with the 'iPhone Home network (in use).

If I disconnect the iPhone and reconnect, it asks me each time to select a network location for the 'network' network. If I don't merge them, I end up with Network 2, Network 3, Network 4 etc all the while still having the original iPhone network not in use as well as any other not merged or deleted.

Can somebody please assist? Why won't it recognise the same iPhone as being connected and selecting the iphone home network that I set up and why does it keep asking me to create a new one whenever I connect?

This never happened before, with my laptop previously recognising the iPhone home network I originally created ages ago. There has been no significant updates or changes that I'm aware of, except that I updated my iPhone software, bt this has been done in the past numerous times with previous iPhone updates and hasn't happened before.

I have a Virgin wireless broadband usb modem, which the system recognises each time I connect it. It's only the iPhone connection that's not saving.
The iPhone network is 'unmanaged' but so is the Virgin Broadband USB.

I have a Pioneer Dreambook P170HMx running Windows 7pro x64. If there's any other details you need, I'm happy to supply them.

All I want is my system to save the network configuration and recognise when I connect the iPhone tethering that it's an already created iPhone Home Network.

Many thanks in advance.

Kind regards, Rob.

My System SpecsSystem Spec
23 Oct 2011   #2

Windows 7 profesional

The problem may be renaming your network 'network' to 'iphone'. Try deleting all your network locations that are related to the iphone, reboot your computer and iphone then try connecting them. Also try connecting wirelessly and see what happens.
My System SpecsSystem Spec
24 Oct 2011   #3

Windows 7 Pro x64

Hi jhansen965.

Connecting wirelessly through my 6300N wifi card always remains as iPhone, as it's been set up via the radio as such.

But, if I don't use my wifi car, bypass it and connect directly to my laptop via the USB cable, this is when it happens. Even if I don't rename the 'network' to 'iPhone', every time I do connect, a new network is created, respectively named 'network, network 1, network 2, network 3' etc etc. if I don't merge or delete them, I'd have a numerous amount of numbered networks for the exact same iPhone I am connecting.

In any event, I've completed what you suggested, I've deleted all existing network profiles and rebooted my laptop. When I connected my iPhone, a new 'network' was created. I then disconnected the USB cable and reconnected it and again a new network 'network 1' was created.

I have no idea why this is happening or why it's only recently decided to do this to me.

Hopefully I can find some generous wizard who has had this experienced and also had this fixed.

Many thanks in advance.

Cheers, Rob
My System SpecsSystem Spec

28 Oct 2011   #4

Windows 7 Ultimate 32bit
Hi Robst76

I'm experiencing the same problem with USB connect (wifi ok), right after upgrading to ios5 - sorry I can't help, just want to add my experiencing the same problem. Hopefully someone has another idea as to a fix.
thank you,
My System SpecsSystem Spec
29 Oct 2011   #5

Windows 7 Pro x64
Re: iOS5 installation

Thanks for replying. At least someone else has the same issue I am having.

This seems to have occurred at the time I installed iOS 5 so it's not a coincidence. This must be happening to all other iPhone users who use Internet tethering and have updated their iPhones to iOS 5.

If somebody comes up with a fix for this, can you please reply to this thread to help us all out.

Many thanks in advance.

Cheers, Rob
My System SpecsSystem Spec
01 Nov 2011   #6

Windows 7 32bit

I'd really like to know if there's a solution to this as well.

It doesn't seem to be DHCP related, nor just disconnecting and reconnecting. For me its either long periods of being disconnected or restarting the computer that releases the iPhones network location :\

I have iOS5, iPhone 4 and Windows 7. And yeah, its only started happening since I upgraded to iOS5 as far as I can remember.
My System SpecsSystem Spec
02 Nov 2011   #7

W7 x64
Same problem...


I have the same problem too and it started when I install the iOS 5 on my iPhone.

Does anyone has a solution?


My System SpecsSystem Spec
05 Nov 2011   #8

Windows 7 x64

Greetings everyone!

the same issue here, exactly after iOS 5 upgrade.

any workaround?

My System SpecsSystem Spec
11 Nov 2011   #9

Win 7 32bit
Same here

Same thing here. Definitely iOS5 is where it started.

I use tetheing a lot too so it is really annoying.

Hope we find a solution soon
My System SpecsSystem Spec
15 Nov 2011   #10

Windows 7 Professional 64bit

Same problem here...
My System SpecsSystem Spec

 iPhone network location doesn't save when disconnected

Thread Tools

Similar help and support threads
Thread Forum
Network link is disconnected
Hello , the problem is this: While surfing the web browser, downloading files or other network activity all okay when I go online game ( CS:GO , League of Legends , World of Tanks) ) I start to lost packets ,after that just (Connection problem)and i need to reconnect or restart my ethernet adapter,...
Network & Sharing
Saving to a library location that is NOT the default save location
OK, I've googled and searched for this as much as I can. I'm a new Windows 7 user. I have a library (Documents) with three folders included. Call them folders A, B, and C. I understand how to set the default save location. Let's say I've set it to Folder A. Now, I want to save a file in *Folder B*...
General Discussion
Setting default save location to last save folder
Is there any way to set the default save location folder for downloads in IE8 to the last folder that the same file type was saved in? It makes no sense to default to a single folder and have to browse through to the desired folder for every single download, so I assume there has to be an option...
General Discussion
Network indicator disconnected
Hi, I have a Windows 7 Enterprise. a few days ago my network indicator started to act funny. it always shows it's disconnected although I'm connected and online. It doesn't matter if it's wired or wireless connection , every connection shows disconnected. I've attached the graphic...
Network & Sharing
I get disconnected from network
This is the story. I upgraded to Win 7 from Vista on two computers and in one of them the network kept getting disconnected. So I got a new network adapter from the compatible list and tried. It kept happening. It worked fine for a while and then it just lost the network. The computer was also...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:58.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App