Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Homegroup Setup O.K. - now Computer won't Sleep

28 Oct 2011   #11
Dave Atkin

Windows 7 Ultimate x64

Have you done any BIOS updates?

Sleep and hibernation: frequently asked questions

It says that there can be a setting in the BIOS for sleep states.


My System SpecsSystem Spec
28 Oct 2011   #12

win 7 X64 Ultimate SP1
Wake on Lan (WOL)

I'll post you a link for definition of WOL.

Wake-on-LAN - Wikipedia, the free encyclopedia

If you are not waking your computers via the network you should not need WOL. Therefore you can disable it on your adapters. By waking I mean if you are at one rig and you want to access files on the other rig and it is in "sleep" you have to send a WOL signal to access it. If they are both awake you don't need the WOL signal. Never the less a path forward for you would to be get all the settings correct so that your rigs will sleep. Then if you want wake on lan you can find the correct setting for that.

Also Dave's idea to check the bios is appropriate. You will probably find power settings relating the the different sleep states such as S1, S2, S3 etc.
My System SpecsSystem Spec
28 Oct 2011   #13

Win7 Pro 64-bit sp1

Thanks you guys. I'm not sure if I should disable WOL right now. For the purposes of simplifying things maybe I should. But it would be nice to have that functionality.

I updated my BIOS months ago to the latest for the board. All went well and I was able to Sleep for months afterward. I disabled Hibernation soon after the first POST.

In the BIOS I've always run S1 and never had an issue. I will double-check everything to make sure.

I did Clear CMOS recently. I had updated the RealTek Network Adapter and was getting this annoying "Press Shift+F10 to configure" message during POST. Once I cleared CMOS it went away.. But I reset all the power options to my normal setup.

My "normal setup" in the BIOS includes "Wake up Event by" and the choices are BIOS or OS. I've always had it set to BIOS. Could that be causing the issue? Should it be set to the OS?

I'm looking thru the BIOS now - on the workstation - and I see one more thing that may be pertinent: the "Resume S3..." choices. There are 5 in total:

Resume S3 By USB Device - Enabled
Resume S3/S5 By PS/2 Keyboard - disabled
Resume S3/S5 By PS/2 Mouse - disabled
Resume By PCI-E Device - disabled
Resume By RTC Alarm - disabled

Those settings have always allowed me to Sleep prior to setting up the Homegroup. Strange how there's no mention of S1... but like I say they've always worked before.

Thanks again for the links and for your help - I appreciate it very much.
My System SpecsSystem Spec

29 Oct 2011   #14

Win7 Pro 64-bit sp1

Update: Still won't Sleep

I disabled the adapters I'm not using.
I disabled Shutdown Wake-On-LAN, Pattern Match and Magic Packet.

sure wish I could figure this out...
My System SpecsSystem Spec
29 Oct 2011   #15

win 7 X64 Ultimate SP1
Off the Wall

I don't see what kind of mouse you are using. If it is a wireless laser mouse If you have a strong desk light it could be inhibiting sleep mode. Just trying to help.
My System SpecsSystem Spec
29 Oct 2011   #16

Win7 Pro 64-bit sp1

Thanks HH - no suggestion is a bad one. However, the workstation used to Sleep just fine before I setup the Homegroup.

I have a feeling the solution is somewhere in the Power Plan Options.

POWERCFG (from the CLI) has excellent diagnostic tools but at this point I've learned everything I can from them. Unfortunately I don't have the expertise to fully evaluate all of the results. The ones I do understand haven't help me pinpoint the solution.

Anyway, thanks for replying and if you think of something else please don't hesitate to post it. I welcome any advice on this problem, and I'm grateful to you all for taking the time to help.

ps - if anyone knows POWERCFG I would really like to ask you a couple questions. Thanks!
My System SpecsSystem Spec
29 Oct 2011   #17

win 7 X64 Ultimate SP1

While you are contemplating your next move, run sfc /scannow at an elevated command prompt to see if your have any corrupted files.

I was about to suggest powercfg at an elevated command prompt but you posted you have done that?

One trick i have seen work is to set something to default and let it save then change things to what you want. In other words set your current power plan by clicking "set to default" then reboot. and try to get it to sleep.
My System SpecsSystem Spec
29 Oct 2011   #18

win 7 X64 Ultimate SP1

At an elevated command prompt what does "powercfg -LastWake" return?
What does powercfg -waketimers return?

Good thread:

Stopped Sleeping.. powercfg report included

run at elevated command prompt:
powercfg -energy -output %userprofile%\desktop\energy_report.html

That should put a report on your desktop for us to read.
My System SpecsSystem Spec
30 Oct 2011   #19

Win7 Pro 64-bit sp1

Thanks again H -

I've run the powercfg commands again -

lastwake reported "USB Composite Device" and that's my mouse/keyboard - as expected

-devicequery wake_armed reported the Logitech keyboard/mouse - again, as expected

the -energy report listed 14 "errors" but none of them appear related to preventing Standby.

NVIDIA released another driver for my GTX 470 so I'll update that now...otherwise, I don't know what else I can do besides what you suggested, going back to a default Power Profile, deleting the Homegroup and starting over.

I've run the sfc utility and no problems were reported.

One question - do you enable S1 or S3 in your BIOS? I always heard S3 was unstable and that most users preferred using S1.

Thanks again for your help!
My System SpecsSystem Spec
30 Oct 2011   #20

Windows 7 Ultimate x64 SP1

S3 is the preferred sleep state. That's what should be enabled in BIOS if you want to use hibernation and sleep.
My System SpecsSystem Spec

 Homegroup Setup O.K. - now Computer won't Sleep

Thread Tools

Similar help and support threads
Thread Forum
This computer can't connect to a homegroup. Homegroup is not ready yet
This homegroup issue is giving me a headache. I've been trying to fix it for a day and a half now on this website and others. I have a PC connected via Ethernet cable and a laptop connected wirelessly. I am trying to join a homegroup I created today on the laptop. However, I previously (years...
Network & Sharing
Unable to join homegroup, homegroup creating computer is no more
The computer that originally created the homegroup on my network is no more. It seems that because of this that my new computer is unavailable to join the homegroup that already exists. Other computers that were part of the homegroup before the "host" computer died are still part of the homegroup...
Network & Sharing
Homegroup encountered an error / This computer cannot join a homegroup
I get a "Homegroup encountered an error" message when I try to join my laptop and desktop to a homegroup. It does not matter which one sets it up and which one tries to join. It errors in either direction. I have tried leaving and creating, no use. The desktop is wired to a Belkin 300N router and...
Network & Sharing
how to setup homegroup
hi! i have a problem here.. i would like to share printers and files using windows 7 homegroup function. i just bought a wireless router..but when i checked the network and sharing center i noticed that my computer is connected to network 5 and my laptop is connected to could i fix...
Network & Sharing
Can't setup Homegroup
When i was using Beta and RC, i just follow the on screen instructions and easily set up a home network. I just upgraded to RTM, and now homegroup won't let me create. When i click create home group, and check some boxes, i get an error saying "windows cannot set up homegroup on this...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:56.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App