Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Wireless Adapter not found, yet its working properly in Device Manager

27 Oct 2011   #1

Windows 7 Home Premium 64 bit
Wireless Adapter not found, yet its working properly in Device Manager

I recently moved my computer away from my router to a different room. So I bought myself a wireless adapter, a D-Link DWA-160 wireless adapter. I installed the drivers with the CD and followed the instructions. At the end of the installation it gave me this: I have re-installed many times trying different methods, but nothing seems to work.

In device manager it shows that the device is installed and working properly. Yet it does not make it actually work. The light on the adapter will not flash like it does for my laptop (tested). And I am unable to even run the Wireless Connection Manager from D-Link, i just double click and nothing happens. Here is another screenshot with more information:

So what exactly is the problem? If anyone can help me out I will owe you big time and appreciate it to no end, thank you!

My System SpecsSystem Spec
27 Oct 2011   #2

Windows 7 Home Premium 64 bit

When i type IP config I get:

Windows IP Configuration

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . . . . . . . . . .: Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter isatap.
Media State . . . . . . . . . . . . . . . . . . . .: Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Local Area Connection* 9:
Media State . . . . . . . . . . . . . . . . . . . .: Media disconnected
Connection-specific DNS Suffix . :
My System SpecsSystem Spec
27 Oct 2011   #3

Win7 & Win8 64bit

Hi Umberto,

Since you are using a wireless manager, make sure that WLAN Auto Config Service is disabled. To do this, click on start and type services, on the top click on Service, then locate the WLAN Auto config, disable it.

Have you tried plugging it to another USB Port? If there are any Devices other than mouse and keyboard plugged in to your computer, unplug them for now. USB devices can cause conflicts.

Try disabling your Anti-Virus or Security Software, then uninstall the device driver again, this time do it in Safe Mode with Networking by restarting your computer then tap F8 then select this option.

An update will be appreciated.
My System SpecsSystem Spec


 Wireless Adapter not found, yet its working properly in Device Manager

Thread Tools

Similar help and support threads
Thread Forum
Device manager on my laptop can't detect my wireless adapter
So I reinstalled Windows on my laptop last night using the Samsung recovery disc that came with it because I recently had problems getting it to start. But now that I did that the device manager on the computer can't detect either my wireless or ethernet adapters. I don't know how to fix this...
Wireless Network Adapter Says it's Working Properly But It's Not
Last night my wireless adapter (Atheros AR5007EG Wireless Network Adapter) stopped working. In the properties it says it is working properly, however, it will not find a single wireless network to connect to, only the big red X over the icon in the system tray. My wife's laptop which is 5 feet from...
Network & Sharing
Display Adapter not showing up under device manager/AMD not working +
Hi, I've been trying to figure out how to fix this for about two days now. I've uninstalled everything AMD/ATI (multiple times) and tried to reinstall my graphics driver using AMD Catalyst. It always says that my computer "does not contain a proper graphics adapter." I've used Driver Sweeper to...
Graphic Cards
Desktop Windows Manager Session Manager not working properly
Hello So basically my windows Aero theme is not working. I can change to different themes and they change the background and sounds but I cannot change the color of my windows color. When I click on the "Window Color" from the Personalization option in Task Manager it does not give me the...
Wireless Network Adapter not working properly
Yesterday I bought a new desktop and I decided I wanted wireless, so I bought a TP-Link TLWN851ND wireless PCI adapter. After installing all the drivers I had internet access for an hour or so but then the download speed gradually went to 0 and I lost internet access, this morning I turned on the...
Network & Sharing
DVD (not working) not found in Device manager, 1 USB port not working
I have a HP dv6910us Pavilion and the DVD is not listed in Device Manager. DVD Tray opens and light comes on but does not play DVD. 1st USB port on left side gets - USB Device Not Recognized.One under it works and one on the right side works. OS Windows7 Ultimate. It is running kind of screwy so...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:05.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App