Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: no ethernet controller, no internet connection

19 Aug 2009   #41

Windows Vista

I have similar problem related to the issue, "The Realtek Network Controller was not found. IF Deep Sleep Mode is enabled Please Plug the Cable" after I was trying to 'repair, modify, uninstall & reinstall' realtek8111B network adapter driver but still my computer can't connect to the Internet. I already tried the driver directly downloaded from and also (I'm using S-series m/b from Gigabyte: GA-P31-DS3L), but the result still the same ("The Realtek Network Controller was not found. IF Deep Sleep Mode is enabled Please Plug the Cable"). I was also looking for the term "Deep Sleep Mode" from Windows "Help & Support", and I didn't found anything about the term. What da heaven "Deep Sleep Mode" is? Maybe only God know... but I'm just more ordinary than the ordinary human :)

When I was opened the Device Manager, I even didn't found the words of "Network Adapters", except when the "Show hidden devices" was marked. And when I click twice on it (on the hidden "Network Adapters"); it only displays WAN Miniport (IP), WAN Miniport (IPv6), WAN Miniport (L2TP), WAN Miniport (PPPoE), WAN Miniport (PPTP), RAS Async Adapter. What da heaven "WAN Miniport(s)" and "RAS Async Adapter" are? Maybe only God know... and I'm still just more ordinary than the ordinary human :))

I thought maybe somebody (= "ordinary brothers"), had changed the BIOS setting and 'sub-conciously' disabled the "Onboard LAN Boot ROM". Then I check the BIOS and I even didn't found "Onboard LAN Boot ROM" on my BIOS. So, I upgrade my BIOS with the latest release via .... the new BIOS work fine.... but I still didn't found where "Onboard LAN Boot ROM" is. It's should be located between "SMART LAN [Press Enter]" and "Onboard Serial Port 1 [3F8/IRQ4]" on the BIOS "Integrated Peripherals" display.

This problem get me frustated, because I have to get more intimate with my computer for one entire day, and it even didn't my type.... we never know each other before we are in the same roof.

I plan to install a new LAN card on motherboard, but how can I disabled the Onboard LAN while it's not appears on my BIOS setting? Should I buy and just install it? Will it works? Coz I'm not sure....

Thanks in advance.
( Khutbah Dajjal )

My System SpecsSystem Spec
09 Jun 2010   #42

Windows Vista Ultimate 64, Win Server 2k3 Enterprise, XP SP 2
RE: dajjal's Realtek Deep Sleep Mode issue


I have exactly that problem, same Realtek's nic running on Win Vista 64 Ultimate .... no way to wake NIC up ... and no way to make windows restore/reinstall/redetect it! I tried even reinstalling OS (I tried Vista 64, XP SP 2 and even Win 7 Ultimate! NO card at all, perhaps it dissappeared ... erased from mb's surface lol) And tell me, haven't u solved it yet? I'm just about to buy a new MB because I can't awake NIC ... it should be a hardware problem, since everytime i try to reinstall driver, i get that annoying msg of "If deep sleep mode blah blah..." (btw, its an Intel MB, model DB41RQ and it has given me a LOT of problems, not only with VISTA 64 but with other OS' ... usb issues, a pci express crash when i tried to install a nvidia 9500gt, etc etc ... a piece of crap!). OF COURSE bios' option for onboard's lan adapter is set to enabled....

Luis Rodriguez
Monterrey, NL
My System SpecsSystem Spec
17 Jun 2010   #43

Windows 7 Professional

Same here. I had no problems at all with my network adapter and suddenly just dissapeared from my system.

I tried everything, uninstalling and then installing again but also I've got the message: "The Realtek Network Controller was not found. IF Deep Sleep Mode is enabled Please Plug the Cable". Then I checked the BIOS, etc., but nothing yet...

I use Windows 7 Professional
Motherboard: ASUS M4A79XTD EVO, wich allegedly has a Realtek 8112L LAN Chipset.

The LAN cable port usually had this green and orange lights, now is just the orange one that is on. And in the Device Manager there's no Realtek or Marvell Network Adapter or something familiar in the list. (By the way only if I set "View -> Show Hidden Devices" is the only way I can see the Network Adapters in the Device Manager list...) Just a lot of WAN miniport and stuff like that.
My System SpecsSystem Spec

20 Aug 2010   #44


So, is ""The Realtek Network Controller was not found. IF Deep Sleep Mode is enabled Please Plug the Cable" problem solved by ANYone ??

and btw moderators, can u make this thread unsolved, cause it isnt solved ...
My System SpecsSystem Spec
21 Aug 2010   #45


After pluging the active lan cable to lan port install the lan driver and then update os through microsoft will receive the patch of lan driver from vender REALTEK.
My System SpecsSystem Spec
21 Aug 2010   #46


problem is that driver can't be installed
My System SpecsSystem Spec
28 Aug 2010   #47


ok I registered just to help out found this fix while researching for someone else---

the fix is to dance around, stick out the tongue, pat your head and rub your stomach all the same time

ok ok...maybe just this
turn the computer off, unplug it, take out the RAM, MOBO battery, wait a few mins and put it all back in;

seen where all you had to do was shut down the computer and unplug it, wait a bit (lots of beers and dancing) then it is recognized.

Hope this solves it for you all as well!!
My System SpecsSystem Spec
28 Aug 2010   #48


No, it doesn't waited for half hour
My System SpecsSystem Spec
28 Aug 2010   #49

xp other person is actively going through the same thing with some more steps than that....will get back if that works for them or not

sorry to hear that didn't work 'cause several people it did

the problem I am talking about is with the same message and there is no network adapter in the device manager
My System SpecsSystem Spec
29 Aug 2010   #50



ok a few things (still haven't seen reply back from other person w/ same trbl) but lets just verify some basics first. Another problem I came across with this is Intel Management Engine Interface

What motherboard and computer model do you have?
Did you ensure the LAN is enabled in the BIOS?
Do you have an active ethernet cable plugged in?

I keep seeing where the fix I posted does work for some. You may also try just clearing the CMOS with a reset button/jumper, go into BIOS and use optimized and ensure onboard LAN is enabled.

If after doing all the steps by unplugging power cable, removing memory and battery, and the ethernet/lan cable is plugged in upon rebooting it might be the MEI missing drivers but I need to research that more.

Give me some history/information and will try and help get you going :)

The other thing is if the Network card IS seen in the device manager -- disable “Allow the computer to turn off this device to save power” and "Green Ethernet".
My System SpecsSystem Spec

 no ethernet controller, no internet connection

Thread Tools

Similar help and support threads
Thread Forum
Ethernet connection to internet stops every night between 8pm & 1am
I have a strange problem that has me stumped, over the last month my ethernet connection to the internet drops every night between 8pm and 1pm, it either stops completely or works for a few seconds and then disconnects or I get a connection so slow that it's unusable. Other devices connected...
Network & Sharing
No Internet Connection/Ethernet Port Lights are not working
Hello, My gaming tower is showing no network connection and I cannot connect to the internet at all. I have tested my ethernet wires and internet connection on my laptop, they are working fine. My lights in my ethernet plugin are not coming on at all on the towerr. I read that by using the CMD...
Network & Sharing
USB internet connection works, Ethernet internet connection does not
OK. I'm trying to switch from wireless to a faster(?) ethernet cable based internet access. I use a Dell Optiplex 755, 32 bit OS, Windows 7. I'm the utilizing Comcast high speed internet supplier, a LinkSys E4200 wireless router, a LinkSys WUMC710 (wireless-ac universal media connector; with...
Network & Sharing
Bridge internet connection over ethernet from wifi
My desktop is connected to a wifi network and I need to bridge to another via ethernet. I have started by selecting each network and I bridge the 2 connections, creating a bridge, but the other computer still doesn't have internet connection. Is this possible (I would think so) and if so, what...
Network & Sharing
unable to connect to internet or find connection, ethernet, please help!
i installed windows 7 beta version 7057 today with 7048 which i had before and 7057 i am having a problem connecting to the internet (or finding a connection at all) the desktop computer is dual booted with xp, and is hooked up via ethernet to my router if i boot into xp, internet works...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:36.
Twitter Facebook