WG111 OS doesn't recognize driver

Page 2 of 2 FirstFirst 12

  1. Posts : 3
    Win7/XP
       #11

    Still get an error message after making changes to .inf


    WinSevenUser,

    I recently upgraded my WinXp x86 to Win7 x64 ultm and as above, I came across this post in hopes of getting my Wg111v1 to work with Win7 like it did under WinXp. After reading through your instructions, saving, rebooting, disabling signed driver enforcement, and then loading the modified driver I get a code-10 error (see attached).

    The driver will show under network adapters but with the little yellow triangle.

    Any other suggestions? Thanks
    WG111 OS doesn't recognize driver Attached Files
      My Computer


  2. Posts : 1
    Windows 7 Ultimate 64bit
       #12

    WinSevenUser said:
    I was also unable to find a solution to using the Netgear WG111v1 USB WiFi adapter with Windows 7 64-bit on the web. I eventually managed to get this working and thought I ought to post the details here.

    The WG111v1 uses the PRISM-GT from Conexant that is also used in the Thomson Speedstep ST121g. I downloaded the 64-bit Vista driver available for this from here:This is the link to the download itself:I unzipped rather than ran the executable. There is a .inf file for the driver that needs to be edited under this path:
    ST121g_VistaSetup_v0.1\STHIWv\SpeedTouch_121g\Drivers\PRISMA02.inf
    Search and replace:
    1. VID_06B9&PID_0121 with VID_0846&PID_4220 (lines 30,39)
    2. VID_1435&PID_0427 with VID_0846&PID_4240 (lines 31,40)
    3. VID_09AA&PID_1000 with VID_0846&PID_4220 (line 75)
    4. VID_0915&PID_2000 with VID_0846&PID_4240 (line 110)

    I obtained the replacement values from "netwg111.inf" included in the "wg111_2_1.zip" 32-bit driver downloaded from Netgear which contains similar entries to "PRISMA02.inf".

    After selecting update driver in device manager properties select "Browse my computer for driver software", then "Let me pick from a list of device drivers on my computer", then "Have Disk...", and select the edited PRISMA02.inf file.

    The driver is not digitally signed and whilst I did hit F8 on the first reboot and disabled the signed driver check, the driver still works for me on shutdown/reboot without having needed to do this again. If this doesn't work for you, you may need to look into disabling signed driver enforcement, though the only method I could find to achieve this involved running in a test mode.

    Note that my WG111 has "WG111V2" in the FCC ID, but is actually a WG111v1. It has NETGEAR in blue on a label as shown for the WG111v1 on the Netgear support page unlike the solid silver plastic appearance of WG111v2 and WG111v3 on this page. I initially tried the Netgear WG111v2 driver but the install froze and even when it looked as though I had been able to manually install the driver it could not be enabled.
    I have just registered just to say THANK YOU.
    Worked on Win7 x64 and connects using WPA2 security (I'm using it right now!!), with lots of extra possible settings on the driver property page (on device manager) - I don't really find a use for them.

    I wonder if there is a newer driver from Conexant for this....

    Thanks again!!!!

    Edit: I have attached the modified drivers for anyone to use
    WG111 OS doesn't recognize driver Attached Files
    Last edited by dith; 16 Mar 2011 at 16:36. Reason: attached modified drivers
      My Computer


  3. Posts : 7
    win7
       #13

    drivers found for win7/vista 32 and 64bit


    hi, looked at all this already and didnt work so here's where i found all the drivers in one small folder which is about 350KB.

    Netgear WG111v2 Windows 7 Driver | wEinstein Solutions

    has quick install instructions for windows 7 32 and windows 7 64 bit also vista drivers and took me 1 minute once i downloaded the drivers. such a relief for the non technical minded thanks!

    thoughts id share it with you guys :)
      My Computer


  4. Posts : 1
    W7 HP 32
       #14

    INF edit


    Worked for me too. Brilliant post! Thanks.
      My Computer


  5. Posts : 1
    Windows 7 Ultimate x64
       #15

    thank you WinSevenUser


    You make me feel this world amazing
      My Computer


  6. Posts : 1
    windows 7 32
       #16

    Thanks WinSevenUser!

    I joined just to thank you.

    The search and replace was not exactly as you wrote but I was able to figure it out.

    You are a genius.
      My Computer


  7. Posts : 1
    Windows 7 Ultimate x64
       #17

    WinSevenUser, BRILLIANT! I appreciate your help, I spent an hour or so looking for drivers from the vendor and other posts and luckily found your post. I used 7zip to open the archive and edited the file in a few seconds and then following your directions to manually load the usb device was in business again! Thank you!

    The Zenshooter
      My Computer


  8. Posts : 1
    Windows 7
       #18

    Hey! If anyone else is having problems with this, just know that you don't have to do all that technical mumbo jumbo or MISTAKENLY PURCHASE DRIVERS ALREADY AVAILABLE VIA THE DEVICE ITSELF! When it automatically installs the software, it will register as another wireless connection (if you have one already that's failing like mine.) The wireless icon should automatically appear, and you should be able to use it straight away, as proved by this site: Windows 7 Automatically Installs Some NETGEAR Adapters Hopefully none of you made the mistake of buying the drivers off of the site that one guy listed above...I'm already seeking that money back.
      My Computer


  9. Posts : 1
    Win7 Ultimate 32
       #19

    I, too, registered just to say thank you! I'm stuck without wired access and just this old adapter and your step by step worked exactly as you said it would on the first try on my Vista Business SP2 64bit machine. You're the FREAKING man, man! Awesome!
      My Computer


 
Page 2 of 2 FirstFirst 12

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 23:42.
Find Us