Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Limited connectivity, DHCP Client not starting

22 Mar 2012   #11

Windows 7 Home Premium 64bit

I know this is an old thread, but the original poster has the exact same issue as I am experiencing. I am desperate to find out how to fix the issue for my laptop.

My System SpecsSystem Spec
17 Jul 2012   #12

Windows 7

I second to above comment. Thanks for the post, the key is to make sure all the permission is inherited to all the subkeys. It wasted me quick a bit of time finally get there. I read the original post about setting the Permissions.

I still have the problem not able to start the Diagnostics Policy Service! Same access denied problem!! One thing at a time. My machine was working fine and all the sudden, problem appear and couldn't do System Restore either.
My System SpecsSystem Spec
09 Feb 2015   #13

Windows 7 64 bit professional edition
solved but needed extra steps

I was facing same problem. Even after following all the above steps still I was not able to connect to internet.

After giving administrator rights to "Local service" and "Network service" now the problem is resolved at my end.

My System SpecsSystem Spec

22 Apr 2015   #14

Windows 7 Enerprise x64

Hi All

As for one of the previous messages, the dhcp client and tcpip service need to start loged on as Local Service, so the permission need to be set up correctly. I found on different PC that these services have read permissions for "Network Service" and "Local Service" in registry. After applying pemissions however the DHCP client still screamed "Access denied" so I had to setup full access to them for "Network Service" and "Local Service". I found it painful to apply all of these to every sub-key. But you using "subinacl.exe" command makes it easy. You need to run these commands:

subinacl.exe /subkeyreg "HKEY_LOCAL_MACHINE\system\CurrentControlSet\services\dhcp" /grant="Local Service"

subinacl.exe /subkeyreg "HKEY_LOCAL_MACHINE\system\CurrentControlSet\services\tcpip" /grant="Local Service"

subinacl.exe /subkeyreg "HKEY_LOCAL_MACHINE\system\CurrentControlSet\services\dhcp" /grant="Network Service"


subinacl.exe /subkeyreg "HKEY_LOCAL_MACHINE\system\CurrentControlSet\services\dhcp" /grant="Network Service"

You can get subinacl.exe here:

Download SubInACL (SubInACL.exe) from Official Microsoft Download Center

It is Microsoft piece of software.

Good luck:)
My System SpecsSystem Spec
24 May 2016   #15

Windows 7 Home Premium 64 bit
Same problem solved.

For my problem, I'm on Windows 10 btw, the DHCP Client would not run, giving me an error 1079 about dependencies not running. To fix this issue, go to services, find DHCP Client, right-click on it and click on properties. Then once the dialogue box opens, go to Log On box at the top, and click on This Account. For the username type NT Authority\LocalService. Just like that type it in, and leave the password boxes blank, then click apply and ok. After doing so my computer connected to the internet. If you have any other important services not running repeat these steps for all non-running services if they will not start on their own.
My System SpecsSystem Spec

 Limited connectivity, DHCP Client not starting

Thread Tools

Similar help and support threads
Thread Forum
limited network connectivity - DHCP and DNS servers not responding
I have two laptops, L1 and L2. Recently, L2 stopped connecting to the internet via my Linksys wireless router. However, L1 can still connect just fine via the same router. L1 runs winXP SP3, L2 runs win7 Home Premium x64 SP1. Usually when L1 or L2 stops connecting, I turn off the wireless cards on...
Network & Sharing
Event 1001 Dhcp client
I've just connected a new PC to my ADSL modem and I get the above error in the event log. Also stating "Your computer was not assigned an address from the network (by the DHCP Server) for the Network Card with network address 0x00etc..... The following error occurred: 0x79. Your computer will...
Network & Sharing
DHCP-Client Error causes Crash
Hello again! I've encountered a new problem that I'm having trouble fixing if you need me to do the zip and all that let me know and I'll work on it but it's pretty specific to this. Even so more info is good so let me know if you need it. :) The crashes occur while using FTP to transfer files...
BSOD Help and Support
Log Name: Microsoft-Windows-Dhcp-Client/Admin Source: Microsoft-Windows-Dhcp-Client Date: 09/08/2010 00:19:26 Event ID: 1003 Task Category: Address Configuration State Event Level: Warning Keywords: User: LOCAL SERVICE Computer: ...
Network & Sharing
Unable to get IP. No DHCP client
Reference this thread: Router: D-Link d-524 V4000 Ethernet: Nforce via mobo Gigabyte GM-A570SLIv2 I am having similar problems as with the linked thread. What happened with me was I needed to download...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:23.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App