Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Limited Access - wifi problem - occured after malware removal

25 Nov 2011   #1
mind5150

windows 7 professional
 
 
Limited Access - wifi problem - occured after malware removal

Hello all,

I have been having this "limited access" problem that prevents me from connecting to the internet. There is a "!" located on top of my signal bars in the icon tray and it says "limited access" under my wifi network.

This all occured during a malware removal process. It would seem the malware and viruses are gone but this problem still persists.

-All other computers and devices are still able to connect to the network.
-turned off router and turned back on.
-retyped network password.
-disconnected / reconnected.


Any help would be great, thank you all in advance.


My System SpecsSystem Spec
.
25 Nov 2011   #2
writhziden

Windows 7 Home Premium 64 Bit
 
 

Uninstall your wireless driver, reboot, let windows re-install it.

1. Go to Start Menu
2. Right click on My Computer
3. Click Manage
4. Click Device Manager from the list on the left
5. Click the + next to Network Adapters
6. Right click your Wireless Network Adapter
7. Click Uninstall
8. If a check box appears to delete the driver software for this device, check the box
9. Click OK
10. Restart your computer
11. Let Windows install the driver software
12. Find the newest driver software and install it from the Wireless Network Adapter's manufacturer site (if you need help with this, let us know)


Edit: Doing the above steps will require you to set up your wireless network on the computer affected. You will need your encryption key(s).
My System SpecsSystem Spec
25 Nov 2011   #3
mind5150

windows 7 professional
 
 

Tried going to

start menu > my computer > manage

but got this error message instead:

Windows cannot find 'C:\program data\microsoft\windows\start menu programs\ administrative tools\computer\management.lnk:
make sure you typed to name correctly and then try again

So i manually went to control panel > networks > manage wireless networks

deleted all the networks saved, tried to reconnect and was prompted to type in my network password again.

Still same problem persists. What should i do now?
My System SpecsSystem Spec
.

25 Nov 2011   #4
writhziden

Windows 7 Home Premium 64 Bit
 
 

All you did was delete the wireless networks; you need to uninstall the driver. To do so, try Control Panel->Hardware and Sound->Under Devices and Printers select Device Manager, then do steps 5 through 12 above.
My System SpecsSystem Spec
25 Nov 2011   #5
mind5150

windows 7 professional
 
 

I went to

control panel >device manager > network adapters

but i dont know which one to delete, my choices were:

bluetooth device
Broadcom 802.11n network adapter
Intel 825746 gigabit
Intel 825746 gigabit (2)

my router is a netgear N600 WNDR3700
My System SpecsSystem Spec
25 Nov 2011   #6
writhziden

Windows 7 Home Premium 64 Bit
 
 

Broadcom 802.11n network adapter is the wireless card.
My System SpecsSystem Spec
25 Nov 2011   #7
mind5150

windows 7 professional
 
 

Ok i apologize if im being difficult, but which one should i delete? Whats the next step
My System SpecsSystem Spec
25 Nov 2011   #8
writhziden

Windows 7 Home Premium 64 Bit
 
 

6. Right click Broadcom 802.11n network adapter
7. Click Uninstall
8. If a check box appears to delete the driver software for this device, check the box
9. Click OK
10. Restart your computer
11. Let Windows install the driver software
12. Find the newest driver software and install it from the Wireless Network Adapter's manufacturer site (if you need help with this, let us know)
My System SpecsSystem Spec
25 Nov 2011   #9
mind5150

windows 7 professional
 
 

Uninstalled the broadcam and restarted the computer...windows went to automatically install it, however during the process a window came up saying:

Searching preconfigured driver folder

with an icon going in circles as if it was telling me to wait, however it never stopped so i clicked on close...afterwards went back into network adapters and found broadcom was there.

Still same problem persists...i tried to put the netgear router cd into the computer and run the setup and it said that my ethernet was disabled or not installed, and that i should enable ethernet or install ethernet adapter...

any other ideas? Thanks in advance thus far writhziden
My System SpecsSystem Spec
25 Nov 2011   #10
writhziden

Windows 7 Home Premium 64 Bit
 
 

Quote   Quote: Originally Posted by mind5150 View Post
Uninstalled the broadcam and restarted the computer...windows went to automatically install it, however during the process a window came up saying:

Searching preconfigured driver folder

with an icon going in circles as if it was telling me to wait, however it never stopped so i clicked on close...afterwards went back into network adapters and found broadcom was there.

Still same problem persists...i tried to put the netgear router cd into the computer and run the setup and it said that my ethernet was disabled or not installed, and that i should enable ethernet or install ethernet adapter...

any other ideas? Thanks in advance thus far writhziden
What did you use to remove the virus you removed?
My System SpecsSystem Spec
Reply

 Limited Access - wifi problem - occured after malware removal




Thread Tools




Similar help and support threads
Thread Forum
WiFi Limited Access problem
I have an Acer Aspire E1-571G, running Win7 x64, I haven't used the WiFi for a week or two, and 2 days ago when I wanted to connect to a familiar wireless network, it says "connecting to the network is taking longer than usual" then I get "Limited access" and eventually it doesn't connect. I...
Network & Sharing
limited access to the WiFi & problem with driver of wireless network
Hello everyone, since last 3 days WiFi is not working on my laptop. The troubleshoot shows that it can't fix the problem automatically and that there is problem with driver of local area connection adapter and driver of wireless network connection adapter. Please help me out.
Drivers
Issue with Wifi after Malware removal.
Hello, Now at first, I was hesitant on joining the site, because I was sure there'd be a valid solution, but there isn't. I seemed to have, pardon me, but 'screwed myself over.' I was following the advice of an earlier post dealing with this problem. Seeing as it worked fine up until I used...
Network & Sharing
"Limited access" WiFi connectivity after virus removal, registry edit.
I'm trying to fix my girlfriend's Windows 7 laptop after she had a virus/malware infection. I'm pretty sure we've successfully cleared the virus (an updated/full scan with Malwarebyte's Anti-Malware in safe mode comes up clean). However, we have had no Internet access since the infection. The...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:32.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App