Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Problem With VPN on Windows 7!!!

07 Aug 2009   #1

Windows 7
Problem With VPN on Windows 7!!!

Hi everyone! I just installed Windows 7 today. I installed everything and came to make a VPN account on Windows 7!

I got through all steps, it even shows me the "Verifying Username and password" message but just after that it goes to other things that i have NO IDEA what they are! I had never seen them on XP! and i think the problem is with that! It shows a message as connecting using WAN miniport (SSTP) , using WAN miniport (PPTP) and using WAN miniport (L2TP)!!!!

Guys please help me if you have ANY idea what might be wrong with it! Thank you so much!

My System SpecsSystem Spec
08 Aug 2009   #2

Windows 7 RC

Could you be more specific? "Other things" is unhelpful.

I have VPN and it's flawless.

What you do is go to network and sharing, create new connection, then choose VPN. After it asks you for user/pass/IP and whatever that is, there's a box that said "Don't connect now, just create". Check it.

Once the connection has been done, go to properties and make sure everything is in place. Make sure redial is set up, that IPV6 is set up (or unbound), that IPv4 is set up, that clients are in place. Make sure that the correct negotiations are in place. E.g., if you are on an L2TP and you attempt to connect on PTP (default), it hangs for a very, very long time. Note that by default L2TP is based on security hardware, not shared key, you need to set that up as well. Also, make sure you know what a remote gateway is, or, at least, try to find out what it was supposed to be like. VPN adds routing to your network by default.

Once you are sure all is in place, _then_ attempt connection.

If you are unsuccessful, write down whatever it complains about and post an informed follow-up post, you might be eligible for qualified help then. Just because you kick it doesn't mean it will work, IP tunneling is quite complex.
My System SpecsSystem Spec
08 Aug 2009   #3

Windows 7

Thanks for the reply. Well, I exactly got what you mean in your post. Actually, I'm a computer repairer but i had never ever faced this issue.

I just did as you mentioned. Everything's in place. But there's a new thing i see in Windows 7 VPN which is "Allow these protocols" Under Security tab. I've put some images of the VPN connecting steps. I created the VPN connection just the way you mentioned. I didn't make any changes in the settings just to make sure it's original.

Here we go :

I attempt to connect .


2. then .

The next step should be "registering your computer on the network" but it is....


and then ,


and at last ,


And That's it... It doesn't get connected! I'm not using a PPPOE connection, So I'm just directly connected to internet from my ADSL modem with Username and password written on the Admin of modem. Not LAN, ADSL is connected with USB to my PC.

By the way, these are my VPN account information, See if you can get connected. The problem might be with my ISP.

Username: fora1

Password : freevpn1245

Host1 :

Host2 :

P.S. If you've got it working , let me know please, also if there's any settings that i don't know about, I can let you connect to my computer with "Teamviewer" To fix it , If you don't mind... Because i really need to get this working!

Again, Thanks for your help!
My System SpecsSystem Spec

08 Aug 2009   #4

Windows 7 RC

You shouldn't be posting info :)

Anyway, the message Windows plays at the end is pretty self-explanatory. That is, the tunnel failed because it couldn't negotiate a security tunnel. Possible issues might be:

* L2TP needs a pre-shared key you were supposed to know. If you didn't set it, it will fail. If you never had it before, then you're probably not on L2TP, however, it's possible such details are lost.

In the security tab, I have:

Type: L2TP (I have that). I have an additional settings button that allows me to tell it not to attempt certificate but a pre-shared key.

Data encryption: Optional (connect even if unsecured). That should probably be on.

Allow these protocols is check and all 3 are allowed, including PAP (unsecured).

Then there's the networking tab where I have MS Client, MS Server and IPv4 (v6 is unbound)

Your issue seems to be that none of the protocols were OK, meaning that

* it's either L2TP and you don't have the pre-shared key (you need to get it)

* it's PPTP (not pppoe!), and most likely it's a firewall or route (it uses additional ports, I think it's 1723 TCP) that blocks it (thus the negotiation)

* it's SSTP (Secure Sockets) and it's also most likely a firewall. It uses port 445 and most firewalls hide that port out of ... well I don't know, they just like that.

If you are 100% sure that you weren't supposed to know a pre-shared key (it's a string password), then it's not L2TP. In which case, my money would be on a firewall interference.

---------------------- EDIT

I decided to give it a go.

Internet hinted that that VPN type is PPTP, so I set it at that.

Note that moving it from outo jumped encryption to "required", which is bad.

I moved it to optional and allowed PAP ans MSCHAP (both unencrypted). After the warning, some IP modifications to now allow the remote gateway access (that will dump all my current connections). And there we go, I'm online, I have


Attached Images
Problem With VPN on Windows 7!!!-001.png Problem With VPN on Windows 7!!!-002.png Problem With VPN on Windows 7!!!-003.png 
My System SpecsSystem Spec

 Problem With VPN on Windows 7!!!

Thread Tools

Similar help and support threads
Thread Forum
Printer problem needs guru. Looks like Windows not Brother problem.
Windows 7 Professional Haven't had the need to use my printer in a couple of weeks, so I don't know when the problem started. It is a Brother HL-2270DW that has been problem free. There are tests that can be tried using the printer itself and it says it has a good connection and should be...
General Discussion
Laptop Windows 7 Problem/Software/Hardware? Keyboard problem
Okay, right now I'm currently trying to find out whats wrong with a keyboard that is on a laptop, after the computer starts there are some script errors, I don't know exactly what they are but I ran combo fix without safe mode and restarted the scripts went away...and it started working after...
Hardware & Devices
Moving windows/icons down problem!! Move right/left/up - no problem
New system i7 3930K CPU Sabertooth X79 Mortherboard GeForce GTX690 GPU Intel 520 series SSD 32GB RAM Dell U2711 27" Monitor Win 7 Pro
General Discussion
Windows 7 Not genuine Problem. And 404 error (security?) Problem.
Hi, ive had both of these problems for about two weeks and have tried to fix it myself. No luck at all. Dont no of their connected. Help on how to fix it would be greatly appreciated.
BSOD Help and Support
Windows Media Player Problem - Sound/skipping problem.
Oh look, another windows media player problem, lol. Well, it's something really weird, at first i thought it was just my computer being all slow or the file was messed up, No matter what movie or format i play it makes this weird screeching noise. It also lags pretty bad. I tried the scans, i did...
Music, Pictures & Video

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:00.
Twitter Facebook Google+