Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't use WinRM - Access Denied?

26 Nov 2011   #1

Windows 7 Ultimate Edition
Can't use WinRM - Access Denied?

Hello Everyone

I cannot get WinRM quickconfig to work on my Win7 Ultimate Machine in a workgroup environment (im trying to work with powershell remoting):

  • I am logged in as Administrator with a none blank password
  • I have run cmd.exe as administrator (right-click Run As Administrator)
  • Set Registry: [HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\LocalAccountTokenFilterPolicy] and set to 1
  • Set Sharing and Security Model for local accounts to: Classic in secpol.msc
  • Set everything to Allow in gpedit.msc for WinRM in Windows Components
  • Disabled UAC
Im still getting:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\Swatto>winrm quickconfig
WinRM already is set up to receive requests on this machine.
Message = Access is denied.

Error number: -2147024891 0x80070005
Access is denied.

Anyone have other suggestions please?

Thanks for any help

My System SpecsSystem Spec
26 Nov 2011   #2

Windows 7 Ultimate Edition

My System SpecsSystem Spec
07 May 2012   #3

Windows 7

I see this post is aging and with no answer, but this may work: try setting a password on the Administrator account. That has solved a winRM error for me before.

It also fills a wide open security gap . . .
My System SpecsSystem Spec

09 Nov 2015   #4

Windows 7 Profession 32bit

Thank you so much, this worked for me, after looking for about two hours for the oslution!
My System SpecsSystem Spec

 Can't use WinRM - Access Denied?

Thread Tools

Similar help and support threads
Thread Forum
i can't access gpedit.msc ACCESS IS DENIED
i can't access gpedit.msc ACCESS IS DENIED pls help me
General Discussion
Import Pictures to NAS "Access Denied" Error Though User Has Access
Hi, All. I've got an interesting situation that I'm hoping can be resolved. I built a server using FreeNAS 8.2 to store family pictures, videos, music, and Windows backups. In my home we have Windows 7 Home Premium 64bit and Windows 7 Professional 64bit. The server is setup with 3 Windows (CIFS)...
Network & Sharing
Can access Vista shares from XP but not from Windows 7 (access denied)
Hi, everyone, I'm mostly a Linux guy these days, so I'm no longer clued up about even simple Windows issues. Bear with me. :D I have one PC running Vista (home basic), one running XP (professional) and one running Windows 7 (home basic). There is a printer connected to the Vista box, which is...
Network & Sharing
"Access denied:" How to overcome denied access to a folder
I'd like to put a .cmd file in my c:\Documents and Settings\All Users\Start Menu\Programs\Startup directory, but \Documents and Settings has a lock on it and tells me "Access denied" when I click on it. Is this a job for "Take Ownership" or is there another way? The instructions for "Take...
General Discussion
Log On - Access Denied
Hi All! Here is my short story. When Windows comes back from sleep mode and I'm trying to log on - it says "Access denied" under the account icon. Account is not password protected. The same thing happen when I'm trying to log on after Windows was locked. I can't give you screenshot, but...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:48.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App