Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Megaupload won't load in any browser

29 Nov 2011   #1
DamnedMedo

indows 7 Home Premium 64bit
 
 
Megaupload won't load in any browser

megaupload went down yasterday and couldn't open it

i tried to ping the site in cmd and it didn't work so i changed the dns to google puplic dns (8.8.8.8) and now i can ping the site in cmd but when i open it in browser i get (Network Error (dns_server_failure))

so i'll be really thankful if someone could help me



My System SpecsSystem Spec
.
29 Nov 2011   #2
Ztruker

Windows 10 Pro X64
 
 

My System SpecsSystem Spec
30 Nov 2011   #3
DamnedMedo

indows 7 Home Premium 64bit
 
 

so we have to wait for two days
My System SpecsSystem Spec
.

Reply

 Megaupload won't load in any browser




Thread Tools




Similar help and support threads
Thread Forum
Facebook won't load in any browser. Does anyone know why?
...and could possibly help me? Basically, I have no problem logging in on the main page. Everything is displayed perfectly fine. But as soon as I login, all I see is the top of the page and nothing on My Timeline loads up at all. I try clicking on multiple things within the site and nothing...
Browsers & Mail
Can't load my work site in any browser, all other sites load fine.
I have always worked in Chrome. My work page won't load anymore, as of last week. I tried it in Internet Explorer, and then tried FireFox. Chrome and Internet Explorer both say the problem is with the site, not with my computer or my firewall. FireFox says the site may be busy and can't be...
Browsers & Mail
Websites do not load in any browser
I'm working on my mother's desktop computer. Suddenly a few days ago, all browsers stopped working. IE has "This page cannot be displayed" , Chrome says webpage not available. No websites pull up. I have tried: Booting in safe mode with networking, still doesn't work Reset IE back to...
Browsers & Mail
Some webpages load and others do not regardless of browser
Some web pages load perfectly (like this one sevenforums.com) while others do not (harborfreight.com). The ones that don't work either timeout or load without images (see attached). I've run CCleaner, tried running a cmd prompt (sfc scannow), rebooted the router (Netgear R6300v1) and still no dice....
Browsers & Mail
Browser Load Test
Hi All, get it here Stopwatch
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:21.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App