Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can connect to wireless network but not internet

30 Nov 2011   #11

windows 7 home premium 64bit

I'll get to the Realtek download and uninstall COMODO tomorrow. My work load says bye for now and tomorrow is another day. Thanks for your help and I'll be back.

My System SpecsSystem Spec
01 Dec 2011   #12

windows 7 home premium 64bit

I uninstalled COMODO and followed your instr. I also updated drivers. Wireless is on. There is no change. Still cannot connect to internet.
My System SpecsSystem Spec
01 Dec 2011   #13

7 Ultimate x64 SP1

You may need to hard reset your wireless router or else force the router to "reset" some parameters in the Admin GUI. Don't know why, but we sometimes have this problem with ours as well (a Netgear). I have to enter the admin GUI of the router (in my case - typically for ISP modems) and then tinker around in there and it will start letting me access the net again after a few things are refreshed. When it happens to me, it also says I'm connected but it still returns 404 errors on pages.

Another thing that I personally know can cause this is if the ISP's servers are being messed with, or the computer didn't get the new lease for the DNS. This is more common than the previous, and there's NOTHING you can do about it until the ISP resends that certificate/credential/lease to your modem.
My System SpecsSystem Spec

01 Dec 2011   #14

Win7 & Win8 64bit

I wonder if there's enough DHCP Scope that's assigned from the Router. Maybe there's a Mac filtering? Who has access to the router or controls the setting?

Also, can you try connecting to any Wi-Fi, even to unsecured connection, are you able to connect?
My System SpecsSystem Spec
01 Dec 2011   #15

windows 7 home premium 64bit

This is a combo reply and additional info to both 2xg & EvilOzzmess.

As mentioned earlier I uninstalled COMODO, but I do have it installed on the Vista machine and (it's still there) have had it since purchase and it does not effect it. I still connect.

Re: Mac filtering and controls and settings and my personal access to the router: I access my neighbor's router (from my place of business) with the password given me. I still have access with Vista so the password is valid. I have no control over what he does but I know the password works. I also do not try to log in both machines at the same time to avoid conflict. I will disconnect either as necessary to experiment.

Re: other connections: I have a combination wireless & wired network at home that we have as many as 6 pc's connected at one time. I can connect there with no problem. However I have not tried another unsecured network. I have a source to do that but would have to set up guest access on Cisco.
My System SpecsSystem Spec
01 Dec 2011   #16

Win7 & Win8 64bit

It will be great if you can try connecting to another Wi Fi connections and if you succeed something is up with the router setting that you are trying to connect to.
My System SpecsSystem Spec
02 Dec 2011   #17

windows 7 home premium 64bit

I'll set up a guest account on another wireless router that I do have access to and try to connect there. It'll be a day or 2 though before I have a chance.

I connect fine at home with wireless but it's not a guest account. I'll reply again once I've tried another location as a guest. Thanks
My System SpecsSystem Spec
03 Dec 2011   #18

Windows 7 Home Premium 64bit

I recently had a similar issue that turned out to be a DNS issue. I could ping my router but not sites ( I could however ping

I typically got resolution by:
Start->run-> "cmd"

My System SpecsSystem Spec
07 Dec 2011   #19

windows 7 home premium 64bit

I finally got a chance to try another location totally separate from my home or business. The business location on a shared connection as a guest is still a problem. At the new location I was able to connect as the home user and also as a guest user on an account I created with no problem.

When connecting at the new location my laptop wireless indicator still says no internet access once I've connected to the router. However, if I open a browser I get the Cisco Guest Password window. The password works fine and I'm in. Doing the same procedure at the trouble location I can remember the Vista machine doing the same. When I opened the browser the password window appeared. With the Windows 7 machine, when I open the browser, I get a window that says The connection was reset. Regardless of what I've tried the password window never shows. What would be the difference between the machines that the one will not allow the browser to continue with the guest password window?

Either way, I can connect elsewhere but not where I want to.
My System SpecsSystem Spec
04 Aug 2012   #20

windows 7 home 64bit
dhcp Toshiba not connecting

I know this is an old post, perhaps the following could help someone to connect using dhcp.
At one time dhcp worked on the Toshiba when one day "poof!" stopped working.

I did quite a few things on a Toshiba L755 laptop trying to restore automatic dhcp connections.
installed drivers, deleted drivers, reset tcp/ip using netsh, changed registry using microsoft fixits, changed registry manually, ipconfig/flushdns, removed anti-virus, checked for malware, rootkits and other unfriendlies, Unchecked ipv6 and misc ipv6 settings per techs suggestions. The only way I could connect was to manually type in network ip info for the wireless nic.

The list continues. But that is not why I'm posting.

I had almost given up and was resigned to the strange thought that even when all my other computers did not have any problems connecting to my wireless "n" router, the Toshiba L755 could not obtain a dhcp lease. Until I came across a website with instructions on clearing ipv6 "neighbors" and "destinationcache".

I was using ipv4 and doing the above makes no sense, At least to me. Well, I had nothing to use so I followed the instructions to clear and remove.

Opened up a cmd shell and typed the following:

first command was
netsh interface ipv6 show neighbors

next was:
netsh interface ipv6 delete neighbors

second command was:
netsh interface ipv6 show destinationcache

next was:
netsh interface ipv6 delete destinationcache

I removed the static ip I had set in the wireless nic and reconnected with a big sigh. Didn't expect anything since it was ipv6 and I'm using ipv4.

To my surprise, it connected for the first time since losing the ability to obtain a dhcp lease.
4 reboots later it was still working.

So, did doing the above fix it? I don't know. My dogs like typing on the computer and perhaps, just perhaps they entered in some registry settings which made it work, when I wasn't looking.

Or it's all just a coincidence. Either way, if you were just as frustrated as me, it can't hurt to try. If it doesn't work, well, on to the next possible solution.
My System SpecsSystem Spec

 Can connect to wireless network but not internet

Thread Tools

Similar help and support threads
Thread Forum
still looses connect/doesn't connect - win 7 wireless home network
She keeps loosing connection, then has to wait until it decides it can connect again. She would wait about five minutes and then click on something and would gain access. the ...
Network & Sharing
Can't connect to the wireless network
Hi, I'm having a problem with my wireless network connections. Everything were working fine until this morning when I found out that my internet connections were suddenly disconnected. I tried everything, even to recover the system but still no luck. My wireless adapter (Intel Wifi Link 5300...
Network & Sharing
Wireless network works but LAN cannot connect to internet
iPhones, iPad and laptop can all connect through the wireless router but our desktop PC cannot. When diagnosing the problem I get the message "Your computer appears to be correctly configured but the device or resource (DNS server) is not responding" . In addition to other similar threads I've...
Network & Sharing
Can't Connect to Wireless Network
I have a new laptop from my school district. When at school, I am connected to our network through a docking station. When I brought it home and tried to connect to my wireless network, it doesn't give me the option to put in my network key. It shows my wireless network but when i click connect it...
Network & Sharing
Win 7 Won't Connect To My Wireless Network, Mac OS Does
Neither my Win7 desktop nor my Macbook (running Win7) can connect to my wireless network. They see it - 5 bars - and try to connect, then say they can't and offer to start a troubleshooter, which is then unable to find the cause of the problem. When the Macbook is booted into Mac OS (10.6) is...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:02.
Twitter Facebook Google+