Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "Access Is Denied" When trying to add wireless network

16 Aug 2009   #11
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by ClericX View Post
Firewall = None, Windows Firewall is also disabled.
Antivirus = AVG 8.5, Windows Defender is disabled.
I tried it without a password many times before and yet again now, but I cannot add a network regardless of if it has a password or not, I always get access denied.

Any ideas?

(As a side note, I don't know if this has anything to do with it but whenever AVG tries to update, it always gets a "General Error" and will not tell me any more than that. I have to go to C:\Program Files\AVG\AVG8\ and run avgupd.exe for it to update.

OH, and whenever I try to delete temporary update files through the option in AVG's tools menu, I get another access denied error, " Deleting temporary update files has failed. Access is denied." Why are my applications giving me these messages?? I am a fully priveleged administrator user and UAC is set to the lowest level to never alert me or block stuff.)
CX

Have you had this problem since the clean install? I would go into enevt viewer (type eventvwr in search) and see if there are any errors relating to the problem. Also since AVG is giving you general errors I would try dis-abling it to test (or un-installing and re-installing it since its giving you general errors) it.



Ken


My System SpecsSystem Spec
.
16 Aug 2009   #12
zay

Windows 7 Ultimate
 
 

Hope I did not miss anything, but did you by chance set up your wireless network for MAC filtering? Router type and model? Also, can you post screen shots of your wireless configuration pages.
My System SpecsSystem Spec
16 Aug 2009   #13
ClericX

Windows 7 Build 7600 RTM
 
 

Quote   Quote: Originally Posted by squonksc View Post
You say you have tried without password, but have you also disabled password on your wireless router?
Yes, tried that, still access denied. If I get it before it even tries to connect, how would that help.

Quote   Quote: Originally Posted by squonksc View Post
Are you sure you are connecting to the right network? and not your neighbors?
Yes, I'm sure. Trust me, I am.

Quote   Quote: Originally Posted by squonksc View Post
Also check in the router under advanced wireless, that restricted access is off.
Restricted access only allows preset mac addresses.
No, restricted access is not on. See, if I try to connect, I can successfully connect to the network and I'm on it right now, but my problem is it does not SAVE the network configuration even when I tick "Automatically connect to this network" or whatever.

By default, Windows stores all wireless networks you connect to, for some reason, mine isn't and that is a big problem for me.
My System SpecsSystem Spec
.

16 Aug 2009   #14
ClericX

Windows 7 Build 7600 RTM
 
 

Quote   Quote: Originally Posted by zigzag3143 View Post
CX

Have you had this problem since the clean install? I would go into enevt viewer (type eventvwr in search) and see if there are any errors relating to the problem. Also since AVG is giving you general errors I would try dis-abling it to test (or un-installing and re-installing it since its giving you general errors) it.



Ken
No, the general errors did not occur since the clean install, at some point they just started occuring later on.

As for event viewer, when I try to launch it I get this error:
"Event Log service is unavailable. Verify that the service is running."

When I check services.msc as well as msconfig, both do not even show an "Event Log" service.

As for uninstalling AVG, this is a process which is annoying because it requires many reboots including after uninstall as well as after reinstall, and I would like to avoid this if possible.

Quote   Quote: Originally Posted by zay View Post
Hope I did not miss anything, but did you by chance set up your wireless network for MAC filtering? Router type and model? Also, can you post screen shots of your wireless configuration pages.
I know this is not a problem relating to my modem/router because I can connect to the network OK, but this is a Windows problem since I get access denied when trying to Save a networks configuration into my Windows list of preferred networks, which have nothing in them and access denied every time I try to add.

EDIT: omg, AVG's problem was a file permissions problem. I had to go into the C:\ProgramData and set user permissions for the avg8 folder, I had to delete all user and permission data and set it so my user, administrator, and all other administrators had full access to the files/folders inside, and the general error is gone and i can delete temp files as well as update fine. maybe this wireless problem also has to do with file permissions in the Windows folder somewhere? Anyone know which files handle that stuff?
My System SpecsSystem Spec
16 Aug 2009   #15
SquonkSC

Win7 Build 7600 x86
 
 

Quote   Quote: Originally Posted by ClericX View Post
Yes, tried that, still access denied. If I get it before it even tries to connect, how would that help.
The access is denied at network level not at user permission level, so you don't have to look for problems in user permissions. That is a whole different matter.

Quote:
No, restricted access is not on. See, if I try to connect, I can successfully connect to the network and I'm on it right now, but my problem is it does not SAVE the network configuration even when I tick "Automatically connect to this network" or whatever.
You never told us you could connect. I read all again and you never mention a successful connection.

So now we know your problem is keeping the network settings.

I have to think about it for a bit, and get back to you.
My System SpecsSystem Spec
16 Aug 2009   #16
ClericX

Windows 7 Build 7600 RTM
 
 

Yes, my problem is keeping the network settings, not connection in general, the connection is fine.
My System SpecsSystem Spec
16 Aug 2009   #17
SquonkSC

Win7 Build 7600 x86
 
 

Quote   Quote: Originally Posted by ClericX View Post
Yes, my problem is keeping the network settings, not connection in general, the connection is fine.
Do you have fixed IP or auto?

Could you provide us with a screenshot of IPCONFIG/ALL at the command prompt?

And a screenshot of your networkdetails.

Like this one:

Attachment 23482

And this one:

Attachment 23483

thanks
My System SpecsSystem Spec
16 Aug 2009   #18
ClericX

Windows 7 Build 7600 RTM
 
 

i believe these settings are not only really only related to connectivity, but also can reveal some personal information about your computer, but anyways, this information should not help in solving my problem.

my connectivity with my router etc is fine, i can connect and use internet like normal.

the only issue i have is not related to my connection, but to windows itself denying me access to store wireless networks which I have connected to, even though I can connect to them and use them normally, it does not store them. This is a problem in my windows install and not my router or config, other xp computers on my network store the network info fine, it's just this win 7 install.

I think my permissions are messed up, so I am going to try resetting the file/folder permissions to my whole computer and all files / folders to allow for all administrators to have all access, as well as my user and the administrator user.
My System SpecsSystem Spec
16 Aug 2009   #19
SquonkSC

Win7 Build 7600 x86
 
 

Quote   Quote: Originally Posted by ClericX View Post
i believe these settings are not only really only related to connectivity, but also can reveal some personal information about your computer, but anyways, this information should not help in solving my problem.

my connectivity with my router etc is fine, i can connect and use internet like normal.

the only issue i have is not related to my connection, but to windows itself denying me access to store wireless networks which I have connected to, even though I can connect to them and use them normally, it does not store them. This is a problem in my windows install and not my router or config, other xp computers on my network store the network info fine, it's just this win 7 install.

I think my permissions are messed up, so I am going to try resetting the file/folder permissions to my whole computer and all files / folders to allow for all administrators to have all access, as well as my user and the administrator user.

If you know what the cause is, why ask others to help?

Well, it's your call.

Good luck.
My System SpecsSystem Spec
16 Aug 2009   #20
ClericX

Windows 7 Build 7600 RTM
 
 

The thing is I don't know what the cause is, that's what I'm trying to figure out. I'm just guessing it's file/folder permissions seeing as the AVG access denied problem was resolved by changing file/folder permissions.

In any case, thank you for all your effort to help, and if this does not work then I am once again out of ideas and I suppose I would try just about anything else...

EDIT: Nope, file/folder permissions did not help..
My System SpecsSystem Spec
Reply

 "Access Is Denied" When trying to add wireless network




Thread Tools




Similar help and support threads
Thread Forum
"access denied" when using "assoc" and "ftype" from cmdline?
I tried to associate the file extension .txt to a new editor program with the well known cmdline programs ASSOC and FTYPE. No, assigning them through WinExplorer menu does not work. But this is another problem which should not discussed here. When I type now one of the following...
General Discussion
Wireless Network shows "Limited Access"
Hello, I have a Dell Vostro 1720 with Intel WiFi Link 5300 AGN. Yesterday, my wireless network at home stopped working. In Wireless Network Connections, it says "Limited access". I'm not sending or receiving any packets, but my wireless connection is strong. When I troubleshoot the problem, it...
Network & Sharing
BSOD = "Limited Access" on wireless network
A few days ago I booted up my HP Pavilion dv4-2049wm laptop. Windows update needed to reboot, due to my postponing it for a few days, so I let it reboot and I started getting blue screens. After a few restarts (getting the BSOD every time), I booted into the last known good configuration. It...
BSOD Help and Support
"Access Denied" to network share once moved to 7..but works on XP
We have a number of users that have lost access to the network share My Documents where everything they create is redirected and stored on a Sunfire server with the data on NFS volume. We are a Xen virtual shop running Server 2003. We've just built a Server 2008 that we are going to promote to...
Network & Sharing
"Access is denied" - "Unable to display current owner"
Hi, I just tried to install the latest iTunes update, but keep getting an error when it tries to access the C:\Program Files\iPod folder. When I try to access the iPod folder directly through Windows Explorer, I get "Access is denied". The same happens when logged in with the system...
Network & Sharing
Windows 7 Ultimate 64 bit "limited access" Wireless Network Connection
I just did a clean install on my windows 7 ultimate 32 bit computer to 64 bit. At first, my wireless internet was working fine, but it suddenly dropped to "limited access". I'm using a Linksys WUSB100 ver. 2 wireless network USB adapter. I've already tried downloading the latest driver for windows...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:40.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App