Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Dropped connections with USB WIFI card (ALFA AWUS036H), how to fix?

15 Jan 2012   #1

Windows 7 Home Premium X86 SP1
Dropped connections with USB WIFI card (ALFA AWUS036H), how to fix?

Hi, Like the title says... I've been having connectivity problems. I am using Windows 7 Home premium SP1 (x86). I can connect fine and after a (seemingly random) amount of time the connection will drop (at least according to windows). I can also easily reconnect without a problem, but it will not pick back up the connection automatically, which is a problem because I use programs that need to access the internet and Often leave large files to download while I'm sleeping or not home. So If I'm not sitting at my computer to manually reconnect, then whatever i'm trying to accomplish doesn't get done.

I'm using the ALFA AWUS036H USB wifi adapter. I had previously been running windows XP and this same thing would happen (though, much less often) but when it happened in XP it would automatically reconnect in a few seconds. I downloaded the drivers from ALFA's website incase the ones on disk were not up to date, and I tried both of them (they have a "normal" and "power control driver" option) and the problem remains. Also, I've never used an external wifi adapter before so I'm not sure if its supposed to work this way, but there are 2 "signal strength meters" in the system tray the standard windows one that you can click on and see available networks or go to windows "network and sharing center" and then there is the ALFA one that you can click on and it takes you to the ALFA wireless LAN utility, where you can also get a list of available networks.

If anyone knows how to fix this, I would really really appreciate the help. also below I'm going to post step by step of whats going on with pics so its pefectly clear.


According to windows there is a problem with the connection, however according to the ALFA wireless LAN utility, the connection is fine (green bars means good connection, red bars means no connection)

When clicking on the Windows "signal strength indicator" in the system tray, it shows 1 of 2 different problems (notice the differences that I've highlighted with red boxes). No matter which one happens I can NOT access the internet.

Despite the "problems" shown above, the ALFA wireless LAN utility shows that its still connected (while windows is showing a connection problem)

To reconnect I switch to the "profile" tab (which is just a list of neworks that i've previously connected to) and double click on the network. In this case it will be Enotria Public.... the same one that (according to the ALFA wireless LAN utility) I'm already connected too

After clicking on the network, the ALFA wireless LAN utility "signal indicator" in the system tray will briefly turn red (signaling NO connection) while it "reconnects". Then it will turn back to green, and Windows network manager/signal indicator (whatever you call it) will proceed to reconnect as well. After this happens, all is good and I'm reconnected and can access the internet.

And here is Windows showing everything is all good....

And here is ALFA wireless LAN utility showing everything is all good....

One last thing that really throws me off. As you can see in pics above the ALFA wireless LAN utility is always connected, and it never drops the connection but even so, the internet will not work when Windows drops the connection. However, When reconnecting I can access the internet BEFORE Windows reconnects. (I still have to reconnect as described above, but after I do so I can access the internet before windows FINISHES reconnecting) The tab shown in this picture was a web page that I loaded BEFORE Windows ever reconnected, and it is a page that I have NEVER viewed before, so its not just loading it from cache.

My System SpecsSystem Spec
15 Jan 2012   #2

Win7 & Win8 64bit

Welcome to Seven Forums,

If you have not done this yet, please remove all wireless profiles stored in your computer.
Easy Way to Delete Wireless Network Profile in Windows 7
Re add your SSID (wireless network) that you're trying to connect to with the correct encryption.

Have you updated your Wi-Fi adapter's driver to the latest by downloading it from the manufacturer's site?

If none of the above suggestions worked please install and run Xirrus Wi-Fi Inspector from one of your wireless computers. Double click the Xirrus Icon on your Desktop, Tap the Printscreen key on your keyboard, open up Paint then choose Edit from the Menu and select Paste, then SAVE it. Upload and attached the file here.
My System SpecsSystem Spec
17 Jan 2012   #3

Windows 7 Home Premium X86 SP1

Someone from another forum said I should have replied .... lol.

I've been a little busy and didn't have time to do it yesterday, but I really do appreciate your replies and any help you can give.

I tried deleting profiles, didn't help.

I Did download latest drivers from website (although I think they are the same version I have on disk) As stated in OP, there were to different drivers for windows OS's "normal/FCC" or "power control/EC" I tried them both, didn't help.

I got Xirrus....

My System SpecsSystem Spec


 Dropped connections with USB WIFI card (ALFA AWUS036H), how to fix?

Thread Tools

Similar help and support threads
Thread Forum
Alfa network awus036H : no networks available
Hi guys, I tryed to run the afla in my compter,i installed more than 20 drivers from the CD, "" "" and other websites but i got the same problem everytime ( no networks found ) . i'm using win7 Ultimate 64bits Chipset : realtek RTL8187L here's some screenshots that can...
Network & Sharing
[HELP]Alfa awus036h Problems[HELP]
Hey guys Two days ago i got the alfa and i havnt simpily been able to get it to work, i've tried drivers from the alfa website, the realtek website and so on... strange part is that its not shown in device manager when plugged in and the lan utilitys that are installed from the drivers open then...
Alfa AWUS036H 1000mW
Does anyone have the problem with this device? Same REALTEK 8187L chip, i can install, the windows recognize it... but it doesnt detect any network. Tried with Vista, the device works perfectly...
Linksys and alfa awus036h with windows 7 64 bit
i have a usb alfa awus036h when i install the driver from for windows 7 windows 7 intall it and when i click on the wifi connection bottom right it say no connection, someone know the problem ? If i intall on windows 7 32bit i work perfectly. on windows 7 64 bit nothing work. ...
Network & Sharing
alfa awus036h (RTL8187L) win 7 64 bit driver.
hi... has any of you have had any luck finding RTL8187L driver for win 7 64 bit.. i have a ALFA AWUS036h wireless adapter that uses a (RTL8187L) chipset but it doesnt work for 64 bit.. it would only work on 32 bit win 7.. HELP PLEASE!!!!

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:46.
Twitter Facebook Google+