Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Laptop can no longer access shared printer/files on home network

19 Jan 2012   #1

Win7 Professional 64
Laptop can no longer access shared printer/files on home network

Printer plugged into Win7 box - how to print from remote XP machine? describes an original difficulty I had getting remote computers (laptops and desktops) to print to a USB printer connected to my Windows 7 box. Read far enough and you'll see that I solved that problem using Networking issue - Win7 printer, XP remote machines

Fast forward 13 or so months. Since that time I have replaced the printer, I've had a motherboard and processor issue with my box (since fixed), and no interruption of things working as they should. My printer - Canon ip4800 series - is USB hardwired to my Windows 7 computer, and the other home computers - two Windows 7 laptops, an XP box, and an XP netbook - can print to the printer, and view files on my Win7 machine, over our wireless home network. And that's been constant through the changes described.

Then yesterday, for no known reason, my daughter's Win7 laptop stopped being able to print. She'd send jobs to the correct printer, but they'd just queue up, with the queue visible from her machine, but not when I looked at the printer from my machine (that is looking at the print queue from her machine shows the jobs, but looking at it from mine shows no jobs).

Nothing I did would result in stuff from her machine, from any application, to go to the printer.

I finally deleted the printer from her machine, figuring I'd just add it back.


When I try adding a printer to the laptop, it doesn't find the printer on the list of available printers. When I try adding it by typing the name - \\mywin7\canon ip4800 series - that fails.

When I look at "network" from her laptop, my computer shows up, but if I click on it, Windows says it can't connect.

When I type ping her_computer from a DOS box, it can't find it - but when I type ping any_other_computer it finds those.

Her laptop can get on the internet from our home wireless network. All the other computers in the house - Win7 and XP - can access shared files on my PC, and more importantly, print across the network to my USB printer.

NO IDEA what changed. The laptop in question had printed a few days ago.

Please, patiently and precisely, guide me through stuff to check on my PC and her laptop, to get this working again. I've been through the network and sharing center on my PC and the settings are correct.

Again, as it is right now, my printer is not defined on her laptop.

Final, cro-magnon-level question here: If I did a system restore on her laptop, back to a point when it had been able to print, might that fix things? Yes, I know, better means exist.

My System SpecsSystem Spec
19 Jan 2012   #2

Win7 & Win8 64bit


First thind I'd suggest to you anyway. Please note that anything that you have installed and windows updates will be affected. Files will remain untouched.
If I did a system restore on her laptop, back to a point when it had been able to print, might that fix things?
Please give us an update.
My System SpecsSystem Spec
21 Jan 2012   #3

Win7 Professional 64

Okay, totally maddening.

I did try the system restore. Good news was that I had my printer icon again visible on the laptop. Bad news is the same problem is there: I can "print" but nothing actually prints. The queue on her machine just fills up with stuff and they don't print.

When I look at the queue from her machine, the title in the queue Window says:
Canon iP4800 series on mywin7 - offline

Why is this? The printer is online, as evidenced that I can print to it from my own computer, and from other remote computers.

Before I did the system restore, my computer (called mywin7 here) was visible when I clicked "Network" on her laptop. But clicking on the icon for mywin7 would give me an error
Error code 0x80070035
The network path was not found.

From a dos prompt on her computer, I can ping mine successfully.

What's going on here? More importantly, how do I fix it?
My System SpecsSystem Spec

21 Jan 2012   #4

Win7 & Win8 64bit

The error code is a symptom of a firewall blocking. If you are using a Security or Firewall software, disable the firewall feature for now. If you're using a Windows built-in Firewall make sure that file and printer is allowed.
My System SpecsSystem Spec
21 Jan 2012   #5

Win7 Professional 64

I completely disabled my Windows firewall and this did not fix the problem. Other Win7 and XP computers in my house and on the same network can print to this printer - so could the laptop in question, until some time in the past couple weeks.

Neither my computer, nor the laptop in question, has ever had a Norton product on it. That's a frequently cited issue in matters like this, but it doesn't apply here.

A selective boot from msconfig, with none of the services loaded, also failed to fix this.

I am going to try to see if I can divine something from the event viewer on the laptop.
My System SpecsSystem Spec
21 Jan 2012   #6

Win7 Professional 64
Please look at continuation of thread

Just to emphasize that the problem appears to be network-related, and not printer related, I have moved the issue to It's not the printer, it's the network (Error code 0x80070035)

I'll welcome a solution anywhere, but hoping that will attract an idea that works.
My System SpecsSystem Spec
11 Dec 2014   #7

Win7 Professional 64

Almost three full years after it began, this issue is solved. I had never paid anyone to clean a machine of malware, but after increasingly bizarre behavior from the computer, I brought it in to the shop, and whatever they cleaned out restored the networking functionality. Marking as solved!
My System SpecsSystem Spec

 Laptop can no longer access shared printer/files on home network

Thread Tools

Similar help and support threads
Thread Forum
Cannot Access Shared Drive From An PC On Home Network
I have three computers in my home, my primary desktop PC, a second desktop PC, and a laptop PC connected to my TV downstairs via a HDMI cable. All computers are running Windows 7 Professional Service Pack 1. The primary computer is using an Ethernet connection to the internet. The other two...
Network & Sharing
Unable to access Shared folders on Laptop and laptops on same network
This is K. Mohan Rajesh Iam using a Dell Inspiron N5110 laptop with Windows 7 Home Premium x64 bit. iam unable to access shared folders on my laptop and laptops connected in same wireless network Please suggest me in getting out of this issue My Email :
Network & Sharing
Laptop connected to home network, no internet access
I have 1 wired home computer, 1 laptop that connects wirelessly through the home network, and several ipods (kids) thay also connect wirelessly. Today my laptop says its connected to the home network but no internet access. I tried reseting the modem and router but no success. I try to troubleshoot...
Network & Sharing
Can't access PC's shared files from Laptop
Hi, I just bought a laptop yesterday and I'm trying to fit it into an already existing home network(wireless not wired). Everything work except the Laptop can't see my PC's files or folders even though I turned off all firewalls and Antivirus software and shared the folders manually and shared...
Network & Sharing
Access to shared files, printer etc via wireless
Hi, I guess this issue has been posted before but I am experiencing some trouble trying to connect from wireless. Here are the details: Windows 7 professional on Dell laptop Windows XP professional on Dell desktop (has shared folders & printer) Netgear Router WGR614
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:04.
Twitter Facebook Google+