Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: "Map Network Drive" menu item missing after hasty registry edit.

08 Feb 2012   #1

Windows 7 Ultimate x64
"Map Network Drive" menu item missing after hasty registry edit.

Was attempting to get rid of some ghosted network drives which no longer exist - I'd tried everything until I came upon this thread:

How do I REMOVE a Network Drive [and the horse it rode in on]

I scrolled to the bottom and saw the registry edit. I went to my own registry, and though I did not see a folder in that location named "Mountpoint key" I did have one called "MountPoints2" inside which I found entries for all of the old, now-nonexistent drives I had been accessing over the network. So, rather stupidly, thinking these were causing the problem, deleted any entry that had an old drive name in it (there were 5 of them). I left the default entry in there:

After doing that and restarting, the old ghost drives were indeed gone from my Computer window, but I discovered when attempting to re-map the new ones that when going to the Tools menu to "Map Network Drive..." that the menu item was missing:

I can still access drives over the network thru the Network panel on the left side of the window.

System Restore was not engaged, so no going back to a previous restore point.

Thanks for any advice, help or insight you can provide.

My System SpecsSystem Spec
09 Feb 2012   #2

Windows 7 Ultimate x64

I managed to fix this with a bit more research. Got the menu item to appear again, this time with another regedit:


I set "NoNetConnectDisconnect" to a value of zero, and rebooted, and it was fine after that.

Not sure how or why, but after this incident I have properly engaged System Restore.
My System SpecsSystem Spec
09 Feb 2012   #3

Windows 10 Pro X64

Now enable System Restore and install ERUNT then these kinds of problems are easy to solve (not as much fun perhaps but easy).
My System SpecsSystem Spec


 "Map Network Drive" menu item missing after hasty registry edit.

Thread Tools

Similar help and support threads
Thread Forum
"Edit With Gimp" Context Menu Missing
Hi ! :D There was a picture file format context menu (for .jpg, .png etc) "Edit With Gimp . Today I have had an image restoration , and after that the menu is missing . I have restored that image many times previously, but I have never missed it . I have tried the tutorial...
Music, Pictures & Video
Context menu item "Format" missing on my DVD RW drive
I am running Win 7/SP1. I have a Sony Blu-Ray Burner BWU-500S. When I right click on the drive I no longer have a format option in the context menu. Does anyone know how I can restore/recreate the format item? I just recently did a clean install of Win 7 & have been in the process of reloading all...
Hardware & Devices
How to add a "Copy Shortcut text" context menu item
I modify and clean up the start menu entries on all my machines, and it's an irritation having to construct shortcuts to a program file that you are looking at in Explorer by- Highlight and copy the folder address from Explorer address bar Paste into the target shortcut address Manually...
Getting rid of "extract..." context menu item in windows 7
I installed 7-zip to handle compressed files which makes the windows 7 build in one redundant. But I can't seem to get rid of the "extract..." context menu entry. It only appears when right click dragging. What are the required registry modifications? Thanks.
My Bios Boot Order Menu Has An Item Called "Ubuntu"
Hi Guys, I recently tried to install Linux Ubuntu but it didin't work well. So I deleted all the partitions and made a clean windows 7 install. Everything works just fine. Before the windows installation there was a weird bootloader starts at first. Here's the picture. After I installed windows...
Installation & Setup
"Limited access" WiFi connectivity after virus removal, registry edit.
I'm trying to fix my girlfriend's Windows 7 laptop after she had a virus/malware infection. I'm pretty sure we've successfully cleared the virus (an updated/full scan with Malwarebyte's Anti-Malware in safe mode comes up clean). However, we have had no Internet access since the infection. The...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:28.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App