Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't connect to wifi - driving me nuts!

09 Feb 2012   #1

Windows 7
Can't connect to wifi - driving me nuts!

Until yesterday morning I had a good wifi signal. We are in France and run on Nordnet Satellite Internet.
However, now I have an exclamation mark on signal bar and no internet access. We are on Nordnet Satellite and I am running WIndows 7 on a Sony Vaio laptop.
It is not the router as my husband's laptop is working fine with no connection problems. I can connect to internet by using cable but not wifi which is very inconvenient as I have to keep bringing the computer downstairs.
Have done diagnostic check and error is: Windows cannot connect with the device or resource (primary DNS server)
Computer also trying to connect by cellular profile (which is the O2 dongle that I use when I go to the UK). I keep getting the O2 box up asking me if I want to connect which it did (without the dongle inserted) but although it will bring up Google it won't connect to anything.
I'm not very technical but have done the obvious things like system restore and checking the adaptor settings in Network and Sharing but just can't figure out what the problem is. If I try to set up a new connection it just keeps referring back to the cellular profile which is presumably for O2?
Can anyone shed any light on this - would really appreciate any help!

My System SpecsSystem Spec
09 Feb 2012   #2

Windows 7 Ultimate SP1 64-Bit

Hello Sally, welcome to Windows Seven Forums.

Have a look at this possible solution: Can't communicate with Primary DNS Server - Microsoft Answers
My System SpecsSystem Spec
09 Feb 2012   #3

Windows 7

Hi Sea Vixen (nice user name!)
Tried option 1 but on the 'fix it yourself' option I put in all the command prompts but it failed as says I am not administration (which I am).

Second option
Method 2.
Step 1.
1. Connect to your router (by typing or in the address bar) and log in. Check your user manual or documentation if you do not know the log-in credentials.
2. Make sure you are in the Setup -> Basic Setup category.
3. Scroll down until you see 'DHCP Server' - if it is disabled, select 'Enable'.
4. Enable DHCP If you want, you can change the number that the DHCP IP assigning starts. (this is optional)
5. Use the DNS servers provided to you by your ISP. There are many DNS servers out there. It's best to use your ISP's if possible.
6. Scroll down and click 'Save Settings'.

Tried to do this but not quite sure if I am doing it right as when I put the number into the address bar (which I assume is where the www web address goes) it just brought up a list of websites!

Can you tell me if I'm doing something wrong?
My System SpecsSystem Spec

09 Feb 2012   #4

windows 7 home premium 64bit

are you putting the numbers as in doing a google search? you want to put the numbers at the very top of the page up where the back arrows are if your using internet explorer 9. You will see etc etc in he address bar as you are looking at this forum page you need to type the ip address for the router in that area
My System SpecsSystem Spec
09 Feb 2012   #5


Many laptops have a small switch or an Fn key touch to disable WiFi...

Have you accidentally disabled your WiFi adapter?

C'est tout fait possible, non?

Check there's no arrow, exclamation mark, or triangle beside your WiFi adapter in Device Manager...
My System SpecsSystem Spec
09 Feb 2012   #6

Windows 7 Ultimate SP1 64-Bit

Do check Qdos's suggestions first, as we often forget the simple things when trying to help out.

Failing that, try option 1 again, but before you open the command prompt window, right-click cmd and choose Run as Adminstrator, which will give you full elevated privileges.
My System SpecsSystem Spec

 Can't connect to wifi - driving me nuts!

Thread Tools

Similar help and support threads
Thread Forum
UAC Driving Me Nuts!
Hello- I just updated my Opera browser. Now when I click on the icon in the task bar to open, I get the User Account Control pop up. It just started doing it, and it annoys me greatly. Can anyone please explain to me why this is happening and how to correct it?
General Discussion
USB Problem. Driving me nuts!
It may be coincidental, but I bought a memory stick off ebay which turned out to be fake. Since that time, I found that every time I turn on my Acer Aspire laptop it will not recognize anything (stick, drive, camera, ipod etc.) plugged into the USB ports or a card in the memory card socket. No...
Hardware & Devices
This is driving me nuts :(
Just done a fresh installation of 7 Ultimate, updated all the drivers to current ones. Problem is as soon as I listen to music and run a program or download anything from the Net the computer becomes totally un-responsive, mouse jitters & freezes, music jitters and drops in and out and sounds...
General Discussion
Driving me nuts !!!!!!!!!!!!!!!
Hi all am not sure what is going on my pc is a new build i have been having lots of bsod and just locking up completely i just did a new install all drivers are up to date memory timings are right . i am now running on one stick it has not lock up on me until now this morning went to start my...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:09.
Twitter Facebook Google+