samba share is not accessible from Windows 7 client...

Page 1 of 2 12 LastLast

  1. Posts : 6
    Windows 7 enterprise x64
       #1

    samba share is not accessible from Windows 7 client...


    Hello,

    I'm trying to map a network drive from my windows client running Windows 7 Enterprise. The folder is a Samba share on a linux (Fedora core 13) server. When I attempt to map the drive using the folder \\10.1.1.131\earth, I get the message via a dialog box:

    Y:\ is not accessible
    an unexpected network error occurred

    From the explorer window, it appears like the drive got mapped (green line is on) but when I click it on, I get the same message as above.

    I can map the Samba share just fine on machines running Vista Home premium and XP professional but I can't get it to work on my Windows 7 box. I'm figuring that the problem is on the Windows side and not on the Linux side since I can map the drive on other machines using different Windows OS.

    I've tried all the suggestions of setting the various network security and network access options in the policy editor and nothing seems to work.

    If anyone can offer any suggestions or help, it would be most appreciated...:)

    Thanks!
      My Computer


  2. Posts : 471
    W7 Professional x64
       #2

    Might I point you towards this thread? Simpler than proposing you try the different solutions suggested there, one by one. :)
      My Computer


  3. Posts : 6
    Windows 7 enterprise x64
    Thread Starter
       #3

    Unfortunately I tried the suggestions that were given in the thread to no avail. The problem still remains...
    What I haven't done is capture data packets using wireshark. Perhaps that is my only recourse at this point try to understand why I can't access the share...

    I forgot to mention that the Linux server is using Samba 3.5...
      My Computer


  4. Posts : 471
    W7 Professional x64
       #4

    Is there any security set on the samba share? Perhaps require a password for authentication, and see if that helps? I'm afraid my knowledge of samba is somewhat limited, but I'll still see what I can do towards assisting you. :)
      My Computer


  5. Posts : 6
    Windows 7 enterprise x64
    Thread Starter
       #5

    WebMattR,

    Thanks for the feedback and help.

    The share itself is defined in the smb.conf file on the Linux server as follows...

    [earth]
    comment = earth database
    path = /media/sdb1
    read only = no
    guest ok = yes

    The security settings in the Standalone Server Options in the smb.conf file are set to

    security = share

    I'm really quite surprised that this problem isn't more pervasive than it is with Windows 7 and Samba shares...
      My Computer


  6. Posts : 471
    W7 Professional x64
       #6

    Can you require authentication to the server, and try authenticating? I have this feeling that your W7 machine doesn't know how to authenticate.
      My Computer


  7. Posts : 6
    Windows 7 enterprise x64
    Thread Starter
       #7

    Is this a change in the policy to require authentication in the W7 client? If so, which policy do I need to change?

    Why does W7 require authentication when I don't need to do this for XP or Vista? What is it that makes W7 different from XP or Vista when accessing Samba shares? I don't have any problem getting at my share with XP or Vista.

    The whole thing is rather frustrating...
      My Computer


  8. Posts : 471
    W7 Professional x64
       #8

    They changed the way security works rather massively between each rendition of the OS (XP, Vista, and 7).
    Have you seen this? My mind thinks the issue is elsewhere, but maybe this is the real trick.
    http://www.stat.tamu.edu/how_to/samba_7.pdf
      My Computer


  9. Posts : 6
    Windows 7 enterprise x64
    Thread Starter
       #9

    Unfortunately I've already tried what the provided link suggests and it still doesn't allow me access.

    Like I mentioned in my original post, Windows appears to map the drive ok but it won't allow me access. If I issue the command from a windows command prompt:

    net use Y: \\10.1.1.131\earth

    It tells me the command completed successfully and the drive shows up in the Windows explorer. If I click on the drive Y:, I get the message:

    Y:\ is not accessible
    An unexpected network error occurred

    The frustration continues...
      My Computer


  10. Posts : 6
    Windows 7 enterprise x64
    Thread Starter
       #10

    Ok...after much pain and searching, I finally found the policy that was not letting me have access to my Samba share on my Linux server from my W7 client. I could map network drive but I couldn't access it (see previous posts above...).

    In the Local Group Policy Editor, go to:

    Local Computer Policy->Computer Configuration->Windows Settings->Security Settings->Local Policies->Security Options

    Find the policy:

    Microsoft network client: Digitally sign communications (always)

    If this is enabled, change it to Disabled. Be sure and restart your machine for the change to take effect! Pressing the "Apply" button in the Policy Editor after the change is made is not sufficient...

    Once I did this, I was able to access my Samba share.

    Hopefully this will help someone else who runs into the same irritating problem.

    Thanks to those who attempted to help me out.

    Regards...
    Last edited by S2LR; 13 Feb 2012 at 16:55.
      My Computer


 
Page 1 of 2 12 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:42.
Find Us