Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: IP protocol disappeared

23 Feb 2012   #1

Win7 Home Premium 64-bit
IP protocol disappeared

I am trying to fix a Samsung laptop for a friend. She admits to having 'fiddled' with the networking applets in Control Panel with the result that neither LAN nor Wi-fi functions any more.

I have noticed that I am unable to use the GUI to access IPv4 Properties because the button is greyed out. Also greyed out is Uninstall. The only button available is Install. I have tried that, but after rebooting the situation appears to be the same.

I have tried using the command prompt as Administrator and using NETSH to uninstall IP, install it, reset it etc, rebooting every time but without any noticeable change afterwards. Also tried NETSH WINSOCK RESET after the above.

I have also tried the above in recovery mode with networking enabled. Again, no change!

Unfortunately, the model does not have a CD drive. However, it has USB ports. Fortunately, I do have a generic 32-bit Win 7 Home Premium CD - which is the operating system installed on the PC. So I could copy the CD in one way or another to an external USB drive and work from that if necessary. If I knew what I had to do!

There is a lot of valuable data on the PC and I don't want to be responsible for losing it. Of course, I could try backing it all up but she has saved stuff all over the place and I am bound to miss something! Yes, I could copy the entire disk ...... I know!! But we would still have to find and retrieve the data later.

So I would much prefer to fix this seemingly simple problem in situ, rather than reinstall Windows in a way that would wipe the disks of data.

Any help or enlightenment would be much appreciated!

My System SpecsSystem Spec
23 Feb 2012   #2
Dave Atkin

Windows 7 Ultimate x64


Firstly take a backup with Windows 7 Backup and Restore. Its never worth risking data.

Then download the latest network driver from the Samsung website and run the installer (If you cant get on the web then download it from another PC and use a USB drive to transfer to the laptop). You may have to install IP Protocol again and restart.

If this doesnt fix the problem then go into computer manager and un-install the Network adaptor. To do this, right click Computer and select manage. On the left hand side select Device manage, find network adaptors and right click on your adaptor, select un-install. It should vanish from the list. Once its disappeared right click within device manager and select Scan for hardware chanages. It will detect the network driver an automatically install it.

Also check the event logs to see if there are any errors relating to IP or the network adaptor. (This is also on the left hand side of Computer manager).

Let me know how you get on.

My System SpecsSystem Spec
28 Feb 2012   #3

Win7 Home Premium 64-bit

Very many thanks for your suggestions.

For precision, the computer model is Samsung NP-X420-JA02IT Nov 2009 and the hardware is LAN: Realtek PCIe FE Family controller Wi-Fi: Atheros AR9285 Wireless Network Adapter and Microsoft Virtual WiFi Miniport Adapter #2

I have downloaded and, and I have installed them - restarting the system afterwards.

This did not overcome the problems I am having.

I repeated the steps that I have described in my initial posting regarding disinstalling/reinstalling IP.

No improvement.

I uninstalled the LAN and WLAN adapters as you suggested, and after a reboot they reappeared. However, there was no change to the symptoms that I am experiencing.

Again I repeated the steps that I have described in my initial posting regarding disinstalling/reinstalling IP.

No change.

In event viewer there is a critical error (404) with RPC originating from the task scheduler every couple of minutes. Also there is a repeating system error (7024) originating from the service control manager. Other errors reported are with DistributedCom, Bits-Client, Dhcp-client, and DHCPv6-Client.

I should also say that on this type of ‘netbook’ PC there is a partition (D) which is used for system purposes including backup. On this computer it is full and there are regular warnings to this effect. My friend has often ‘randomly’ deleted files in this partition in an attempt to silence these warnings, to no lasting avail! Some of the errors in the log might relate to this.
My System SpecsSystem Spec

28 Feb 2012   #4

Windows 7 Professional 64 bit

Try updating the drivers in device mangler instead of removing them. Windows will sometimes reload a driver even if it's not the best driver for the hardware.

It sounds like your friend has pretty much borked her netbook though, so a reinstall is probably going to be your only solution.

Have her back up her stuff, under your supervision if you want, so that she understands it's her responsibility and not yours.

Best of luck with it.
My System SpecsSystem Spec
01 Mar 2012   #5

Win7 Home Premium 64-bit

I tried updating the drivers, but it didn't fix the problem.

So I tried an upgrade install using an ISO file of generic Windows 7 Home Premium 32-bit.

However, her installed version is Italian but the only ISO I can find is the English version - and it won't install for that reason!

Having looked on the internet I can find a language pack for Italian but it is claimed only to work with Windows 7 Enterprise.

What now? Maybe I should move to a different forum for this problem?
My System SpecsSystem Spec

 IP protocol disappeared

Thread Tools

Similar help and support threads
Thread Forum
Resetting Winsock Protocol
Ever since I got my 7 Pro x86 laptop in Dec 09 I've experienced periodic loss of Internet connectivity, usually a couple of times a month. My computer is connected to an external modem provided by AT&T, no router, no home network. The modem has been tested by two different AT&T repair centers and...
Network & Sharing
Winsock Protocol
Hi there, Earlier today, I tried to uncheck a specific item using Autoruns, and this error message came up: Winsock Protocol Providers cannot be disabled. Is there a possible way to fix that? Cheers!
General Discussion
ipx protocol and renegade
So i am running vista but the vista forums are dead and also my friend is having this issue with windows 7. Basically since windows vista and 7 do not support ipx protocol we cant play lan games together on command and conquer renegade... im pretty sure my friend can with xp mode but being vista...
Alpha Protocol
Hi, my first post and i want your help. (Tried but dat sucks!!!) When I had Win Xp Alpha Protocol worked nice without any errors but when installed W7 AP too it wont run i mean i get message with Dont Send all driver is istalled...
Alpha Protocol PC is out...
This is a Role Playing Game and I don't do many of those, last RPG I played was KotOR... does it play similarly like an FPS game? According to Gamespot Alpha Protocol for PC - Alpha Protocol PC Game - Alpha Protocol Computer Game

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:33.
Twitter Facebook Google+