Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: "no operation can be performed while it has its media disconnected" (:

28 Feb 2012   #1

Windows 7 64-bit
"no operation can be performed while it has its media disconnected" (:


Not sure if im in the right Forum Room here.. but here is a shot lol Im sort of new to this forum stuff so patience is appreciated. (:

First off, I am trying to set up a password on my Linksys router to secure my internet connection. But, I cannot access my IP address on my Acer computer. I have tried everything for the router (master reset.. reboot.. etc..)-- cannot update fimware wo accessing the ip address website thingyy--- but uhmm.

I went to Start and typed in CMD. Then tried to reset my IP address on my computer so that it may connect to the router. It states the following: "no operation can be performed while it has its media disconnected". Any suggestions? At a total loss now. And I also use a separate modem from Comcast. Would that affect this? Or should I be in a different forum LOL Thanks a bunch.

My System SpecsSystem Spec
28 Feb 2012   #2

Windows 7 professional 64 bit

The physical connection does not seem to be proper. Your computer is not able to recognize the router. Do the power drain. Unplug the physical connections (cables) and re plug them back. It should work..............
My System SpecsSystem Spec
28 Feb 2012   #3

Windows 7 64-bit

Thanks for replying! I did try to unplug and replug everything back in. I just had an extra Ethernet cord going from the router to my laptop. I also tried to reboot the laptop.. no avail..
My System SpecsSystem Spec

29 Sep 2012   #4

windows 7 home premium 32 bit
media disconnected

good morning,

I have a Belkin router model F5D8636-AVL; a gigabyte motherboard with a Realtek Family RTL 8168/8111 PCI-E gigabit ethernet NIC, and a Belkin stick N300 to connect to the internet. Dual boot computer win 7 (primary) and win XP (secondary)
I tried about everything I can, got latest win 7 driver, uninstalled and reinstalled, checked the system files (which are OK) - Both Belkin as Realtek are said to be working properly. The problem solver indicates "there might be a problem with the driver of the wireless connection 9 adaptor"
I have this same media disconnected problem. Finally I read somewhere on the forum to look for hidden hardware. When I did this, I got quite a list. Now this PC is a dual boot, internet works on XP, but not on 7 (trying to update a driver something went wrong ). The ipconfig is a bit like everywhere - media disconnected. I have been reading on this forum 6 days and searched for a solution. Now out of this list, I think a few of these may be not valid, but which ones?
the list in attachment (sorry can't put the image here)
Can anyone please tell me what is wrong here?
I can give more information if needed.
many regards and thanks,

Attached Thumbnails
"no operation can be performed while it has its media disconnected" (:-hardware-configuration-w7.png  
My System SpecsSystem Spec

 "no operation can be performed while it has its media disconnected" (:

Thread Tools

Similar help and support threads
Thread Forum
Copying calendar items "operation failed an object could not be found"
I am trying to merge several years' worth of calendar items into a single new PST file for archiving, but when I try to copy many of my calendar items I get this error: "Outlook cannot copy the items. The attempted operation failed. An object could not be found" Using advice elsewhere I tried...
Microsoft Office
Performed System Cleanup-Rebooted system Continuous loop "Cleaning Up"
Hello all, Helping a friend on their Laptop PC, Sony Vaio, Model: PCG 61813L (2 yrs old). OS = Win7 Home Premium. Having the following problems: Maintenance has never been performed: I performed a system cleanup, removing old files. Completed a defrag using the installed Windows Defrag...
Performance & Maintenance
Homefront "You have been disconnected from steam" error
Whenever i try to access the homefront multiplayer it wont work. once i click on multiplayer in the title it pops up as a screen that says "you have been disconnected from steam" i tried everything from getting a new router(my old one was 6 years old and barely works) to reinstalling the game but...
"Media Disconnected" can't get my ip address...
I've been having problems using xbox live and went to look to see if the ip address was correct in my settings. Well, when I went to look for my computers ip address, when I am wirelessly connected, this is what I got: Microsoft Windows Copyright (c) 2009 Microsoft Corporation. All rights...
Network & Sharing
Wireless tray icon stays as "disconnected"
Hi, I've just upgraded to windows 7 from vista and i'm having a really annoying issue, the tray icon that shows my connection to my wireless network constantly shows up with a red "X" over it. I'm connected to the network fine and i know this even by clicking the icon and then right clicking on the...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:35.
Twitter Facebook Google+