Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't play a game over the net when UAC is enabled.

28 Feb 2012   #1

Windows 7 Enterprise x64 SP1 Version 6.1 Build 7601
Can't play a game over the net when UAC is enabled.

Ok, I'm lost indeed
I Have a game to play online which I run using a script (*.bat).
sometimes I host a game and sometimes I don't...
(by the way, I hope this isn't illegal wright? )

now I've been setting up everything in windows firewall, inbount and outbound rules for that program and all that security stuff.
now here are two scenarios where, one works and another unfotunately does not:

First scenario:
-I log in as admin into windows
-windows has UAC disabled
-I run a script
-I play the game online

Second scenario :
-I log in as admin into windows
-windows has UAC enabled
-I run a script as Administrator
-I can't play a game online cos it can't find any server

as you see in these two scenario only UAC on/off is difference.
How do I fix that issuse by keeping UAC enabled?
Can you give me some

Kind regards!

My System SpecsSystem Spec
28 Feb 2012   #2
Dave Atkin

Windows 7 Ultimate x64


Does it happen if your UAC is on the lowest level?

My System SpecsSystem Spec
28 Feb 2012   #3

Windows 7 Enterprise x64 SP1 Version 6.1 Build 7601

Hi Dave,
No, if UAC is on the lowest level then it works just fine, that is, UAC is disabled on lowest level.
On any other level (UAC enabled) it won't work cos I'll have to run script as Administrator, but no matter, runing a script as Admin or not that doesn't change anything.

You know, I don't wanna disable UAC and thus restart my comp each time to be able plaing a game.

Any idea so I can try it, thanks :)
My System SpecsSystem Spec


 Can't play a game over the net when UAC is enabled.

Thread Tools

Similar help and support threads
Thread Forum
Plug and Play is enabled, but devices do not recognize that it is on.
Okay so basically some programs and devices started acting a bit goofy about a month ago, it was small stuff and I didn't really care. Now my Wacom Bamboo Create Tablet stops working, as well as my printer/scanner (Canon MP490). This was too much so I tried finding the problem, so I head to my...
Hardware & Devices
Trying to play a game - Flash.ocx is missing - Game wont launch
The title pretty much sums everything up. I downloaded a game called R.O.D.E Online, its a free mmorpg I installed the game, everything went well. When I tried to launch the game nothing happens, after clicking on the launcher a few times I get an error message that says this: Program...
How can I change my game icons that I click to play the game?
My icons were crap when I installed the game and want to change them, but it says the picture has to be an icon. How do I do this?
CRASH when try to play a game with STEREO 3D enabled
Hi all. I'm new to the forums,so sorry if anything is wrong. I just bought a brand new computer,just to play with 3d vision glasses,but I'm having problems to play. After a fresh install of Win7 64 bits,I installed the latest Nvidia drivers for my graphics card and 3d vision. If i try...
Graphic Cards
Can't play LAN games when internet is enabled
I'll try keep this as simple as possible. Basically we have a two-machine LAN (all fully working, both show up in the network browser, no internet connection sharing is enabled, file sharing fully working, pingable etc with static IP addresses), and when we start one machine running a LAN game...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 14:33.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App