Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cannot enable wireless connection

04 Mar 2012   #1

Windows 7 Ultimate x64
Cannot enable wireless connection

I'm running Windows 7 Ultimate 64-bit on a custom built PC. I have a Zonet 1642D wireles card that I had used fine for almost a year.

For about the past two weeks my internet would suddenly drop about once a day and it would say there were no wireless connections available. I would have to restart my computer and then everything would be fine.

Well on Friday it happened and I got fed up, so I uninstalled the wireless card and reinstalled, and now I can't enable the wireless connection at all in the Network Connections menu. It will say "Enabling..." and then "Enabled" but it doesn't actually enable.

I run the diagnostic tool on the Network Adapter and I get the message "There might be a problem with the driver for the Wireless Network Connection adapter." In the detailed information "Windows couldn't automatically bind the IP protocol stack to the network adapter". I've tried reinstalling the driver, I've downloaded the driver from the Zonet website, and I've tried rolling back drivers. I've tried a system restore to when it did work, and I'm getting nothing. Anyone have any ideas? Would greatly appreciate any input, and thank you in advance.

My System SpecsSystem Spec
27 Nov 2013   #2

Windows 7 Home Premium 64bit

I found a solution, and it involves temporarily bridging the wireless and lan connections (then unbridging). See Technopaideia: Frustrating but ultimately successful fix for Internet connectivity
My System SpecsSystem Spec

 Cannot enable wireless connection

Thread Tools

Similar help and support threads
Thread Forum
Disable LAN connection for specific user/enable wireless only
Hi all, I'm setting up a computer for public access to a local site (repository). There are two accounts: 1.admin account: running a virtual machine as server for the local site. I need access to LAN through wired ethernet in this account 2.public account: the account for the users to...
Network & Sharing
Wireless Connection Speed limited to 54mb/s on Wireless-N equipment
I have a new dual band wireless-AC router (Linksys EA6300) and just installed an Intel AC 7260 wireless card in my laptop. The wireless network I am connected to indicates that it is a 802.11n connection, but in the Wireless Network Connection Status it only shows a connection speed of 54mb/s. ...
Network & Sharing
Can't enable Wireless WOL!
Hi! I'm trying to configure my Win 7 Pro machine to wake from sleep when I attempt to connect through RDP from my work machine. My home computer is connected through a Belkin N+ USB Wireless adapter (can't physically connect to router through ethernet due to house layout). When I go to the...
Network & Sharing
Wireless network connection lost internet connection
Hi everyone, I work in an office where we have a main desktop computer which is connected to the internet via a Time Warner modem. The modem is connected by cable to a netgear wireless router, and up until today there have been no problems connecting to the internet from the laptops that use the...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:24.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App