Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Microsoft ISATAP adapter

19 Mar 2012   #1

Windows 7 Home Premium 64-bit SP1A
Microsoft ISATAP adapter

For some reason, I had a Windows 7 64-bit upgrade fail. Now when I go to Device Manager, my wireless router shows 2-Gigabyte as enabled, but then under it I see the following yellow diamond with exclamation points on the following items:
Microsoft ISATAP Adapter
Microsoft IPv6 toIPv4
Microsoft Terleado

Also there is a message station that there is Code 10 error Device cannot start.

I went into Device Manager and looked at each of these, and the software says that they are working correctly. When I look at Roll Back Driver, it is grayed out, and I cannot do this. Also, when I try to get a new driver, everything seems to be blown away. I have had to go back & do a system restore to an earlier point to even get back to this point. Can anyone give me advice on how to correct these problems?? In advance, thank you for any help you can give me.


My System SpecsSystem Spec
20 Mar 2012   #2

Windows 7 Ult, Windows 8.1 Pro,

Between the failed upgrade and using a restore point I'm not so sure that your Op system is going to be useable any longer. What your seeing there is your network adaptor not the router which has it's own page.
A good system image would be the best way to go but you would need to create one before hand using the Windows 7 file recovery in the Control Panel.

I'd have to see a screen shot of your device manager with network adaptors expanded and with the "View" button set to "show hidden devices". It sounds like your network driver was corrupted so reinstalling it may help.

It might help to run some of the ipconfig commands in the link below, you need to type them into an elevated command prompt. Elevated Command Prompt
My System SpecsSystem Spec
20 Mar 2012   #3

Windows 7 Home Premium 64-bit SP1A
To Chev65

Thanks for your reply. However, I do not seem to have the ability to log on as Administrator. No where do I see that choice as Run as Administrator. I've tried every example that you had given, all without any results. I an truly "Butting my head against the brick wall in this case!". Any other suggestions will be helpful.

Thank you!


My System SpecsSystem Spec

20 Mar 2012   #4

Windows 7 Home Premium 64-bit SP1A
To: chev65

By the way, let me tell you about my system that I am having troubles on....

OS: MS Windows 7 Home Premium 64-bit SP1 ( upgraded over Vista 32-bitOS)
CPU: Intel Core 2 Quad Q6600 @ 2.40GHz (Kentsfield 65mn technology)
RAM: 4.00 GB Dual Channel DDR2@332MHz(5-5-5-15)
MOTHERBOARD: ACER G33t-AM (Socket 775)
GRAPHICS: Generic Westinghouse Non-PnP Monitor (1024x768@60Hz)
ATI Radeon HD 4300/4500 Series (XFX Pine Group)
HARD DRIVES: 977GB Seagate ST31000528AS (C Drive)
488 Hitachi HDT725050VLA380( D Drive)
Optical Drive: HL-DT-ST DVDRAM_GAS-H60N
AUDIO: Creative X-Fi Audio Processor (WDM)

Again, thanks for taking the time to reply to my post. I really appreaciate it!

My System SpecsSystem Spec
22 Mar 2012   #5

Windows 7 Ult, Windows 8.1 Pro,

If you disabled UAC it can cause this problem of no Admin. Enabling UAC might get it working again but I certainly don't have that problem with UAC. There are many similar complaints when I Google the problem, the links below might help.

I will show you how to find the 'Run as administrator' option. Administrative Privileges

Run as Administrator
My System SpecsSystem Spec

 Microsoft ISATAP adapter

Thread Tools

Similar help and support threads
Thread Forum
tunnel adapter isatap media disconnected after HDD recovery
Hi, I have just installed a new Hard disk and used the Win 7 Home premium recovery discs supplied by Acer. My wifi is functioning but my desktop is unable to connect. I have run the ipconfig /all (attached) and see the tunnel adapter isatap media disconnected message. Any help would be...
Network & Sharing
MS ISATAP Adapter,2,3 and Teredo Tunneling Pseudo Interface Need help
I finally got the Troubleshooter problem fixed. So I find that the MS ISATAP Adapter, Adapters 2 and 3 and the Teredo Tunneling Pseudo Interface are showing a code 10. I tried letting the machine install the drivers and all four failed. What do I do now to get new drivers? Would this have...
Network & Sharing
Microsoft ISATAP Adapter 5- code 31
So in my device manager, under Network Adapters my Isatap adapter 5 isn't working. I am getting a code 31 which states "This device is not working properly because Windows cannot load the drivers required for this device" I have tried updating the driver -It tells me I am up to date The option...
Network & Sharing
I have a problem regarding my MICROSOFT ISATAP x422 and MICROSOFT TEREDO TUNNELING ADAPTER. going to device manager there is a yellow mark on MICROSOFT ISATAP x422 and MICROSOFT TEREDO TUNNELING ADAPTER icon and i was wondering what was wrong. Please help me.
Hardware & Devices
Microsoft ISATAP Adapter windows 7 Ultimate
Dear All, I have a sony Vaio VPCZ and I'm having some problem with the Gobi 2000 installation, in the device manager under network I get a warning sign to the "Microsoft ISATAP Adapter" also the Qualcomm Gobi 2000 HS-USB Mobile Broadband Device 9225, and under modem the Qualcomm Gobi...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:02.
Twitter Facebook Google+