Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can not get Active Directory to work, error when I turn on win7 feat..

27 Mar 2012   #1

Windows 7
Can not get Active Directory to work, error when I turn on win7 feat..

I have downloaded admin tools for Windows 7, however, when I go to the "Turn Windows Features On or Off" (attached) I get an error message (attached). Also attached is my system information. I am basically needing AD Users and Computers and for the life of me can't figure it out. If anyone knows something I am doing wrong please help me.

Attached Thumbnails
Can not get Active Directory to work, error when I turn on win7 feat..-turn-off.png  
Attached Images
Can not get Active Directory to work, error when I turn on win7 feat..-error.png Can not get Active Directory to work, error when I turn on win7 feat..-system.png 
My System SpecsSystem Spec
27 Mar 2012   #2

Windows 7 Ultimate x64

Try reinstalling the RSAT. Run command prompt as an administrator and then enter the following to uninstall it:

wusa.exe /uninstall /kb:958830
Then go to: and download a new copy.

Make sure you are using the correct version (x86/x64). I have linked to the x64 because I saw from your screen shot that you're on a 64 bit machine.
My System SpecsSystem Spec
28 Mar 2012   #3

Windows 7

I followed what you said to do as well as:
To install the Administration Tools pack by using the Windows interface
  1. Download the Administration Tools package from the Microsoft Web site (Download: Remote Server Administration Tools for Windows 7 with SP1 - Microsoft Download Center - Download Details).
  2. Open the folder into which the package downloaded, double-click the package to unpack the files, and then start the Remote Server Administration Tools Setup Wizard.
    Note You must accept the License Terms and Limited Warranty to install Administration Tools.
  3. Complete all the steps that are required by the wizard, and then click Finish to exit the wizard when installation is completed.
  4. Click Start, click Control Panel, and then click Programs.
  5. In the Programs and Features area, click Turn Windows features on or off.
    If you are prompted by User Account Control to allow the Windows Features dialog box to open, click Continue.
  6. In the Windows Features dialog box, expand Remote Server Administration Tools.
  7. Select the remote management tools that you want to install, and then click OK.
Configure the Start menu to display the Administration Tools shortcut, if it is not already there.
  1. Right-click Start, and then click Properties.
  2. On the Start Menu tab, click Customize.
  3. In the Customize Start Menu dialog box, scroll down to System Administrative Tools, and then select Display on the All Programs menu and the Start menu. Click OK.
    Shortcuts for snap-ins installed by Remote Server Administration Tools for Windows 7 are added to the Administrative Tools list on the Start menu.

In the selection screen shot, the 2 yellow highlighted ones were already selected.

After I clicked OK....I got the came error message as before. And still no Users and computers.

Attached Images
Can not get Active Directory to work, error when I turn on win7 feat..-uninstall.png Can not get Active Directory to work, error when I turn on win7 feat..-selecting.png 
My System SpecsSystem Spec

17 Apr 2012   #4

Windows 7 Ultimate x64

That's odd, I'm not familiar with anything like this happening before. I would try a system restore to a time before you initially installed the RSAT, perhaps something was corrupted during the installation. If that doesn't work, try contacting Microsoft for update support which is free for genuine users. Or you could attempt to fix the issue by doing an upgrade installation over your existing copy of windows which will leave all of your files and programs intact. Of course you could always do a clean install but that may be overkill for what you're trying to do; then again if these tools are that important then it may be required. Good luck and keep us updated!
My System SpecsSystem Spec

 Can not get Active Directory to work, error when I turn on win7 feat..

Thread Tools

Similar help and support threads
Thread Forum
Active Directory - Log On To...
Hi Everyone, So in active directory I have Generic User accounts (e.g Security, Sales, Transport) as well as email accounts attached to them, Then I have user accounts (e.g John, Michael) and they have their personal email accounts attached to outlook but they will also both have the "SALES"...
General Discussion
Active Directory Domain Services unavailable - print error
HP 3015 All-in-One has worked fine for years, plugged into wife's PC. Yesterday it stopped communicating and the error message; "Active Directory Domain Services unavailable" is cryptic. This error is discussed in various internet fora but no solution found is pertinent to my problem. ...
Hardware & Devices
A really strange error with Active Directory Domain.
My customer has a small business with 2 x HP Proliant ML110 G6 servers installed ith VMware ESX 4.1. He has 7 Windows 7 64-bit workstations in a domain. He has a Windows 2003, 32-bit Domain Controller and 5 of the machines are in the domain. The other two are in a Workgroup and have DNS and...
General Discussion
active directory domain services is currently unavailable error
Purchased my Dell Studio 1749 laptop on Mon. and trying to add my printer/copier at my office. when I go to the print page in Word 2007 there is an Find Printer button. I've used this feature before to install printers. but, when I click on the button I get this error message - Active Directory...
Network & Sharing
The Active Directory Domain Services -error
Hi, I'm new to these forms, my name is Kcaz. Today I was trying to add wireless printers to my computer (Toshiba running Windows 7 64 bit). At home, I have one wireless printer (Cannon) which works fine. To install that i think I downloaded the drivers from a CD. Now I was trying to download...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:36.
Twitter Facebook Google+