Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 'Limited Access' to Wi-Fi Network after system restore????

09 Apr 2012   #1

Win 7 64bit
'Limited Access' to Wi-Fi Network after system restore????


I did a system restore on my PC (putting it to the set up I had 48 hrs earlier). The restore worked fine except bizzarely my Wi-Fi now says 'Limited Access' and instead of the proper network connection bars appearing bottom right of my taskbar, I have the blanked out connection bar with a yellow star over it.

I disconnected then tried to reconnect and the same happens again 'limited access'. As a result I am getting internet but only at 2to 3 mb/s, when i have a 20 megabyte connection (so 'indeed the connection is limited).

I have reset the router, nothing has changed. Everything seems fine on my computer, and in my network settings but alas 'limited Access' is always there. My PS3 and my flatmates PC are working at full speed so it seems to be something changed by restoring my computer.

Any idea? I'm using Windows 7 64-bit

My System SpecsSystem Spec
10 Apr 2012   #2

Windows 7 Home Premium 64-bit

Can you temporarily connect an ethernet cable to see what speed you can get wired - that way we can establish if it a wireless only problem.
My System SpecsSystem Spec
10 Apr 2012   #3

Win 7 64bit

Quote   Quote: Originally Posted by ibshaw View Post
Can you temporarily connect an ethernet cable to see what speed you can get wired - that way we can establish if it a wireless only problem.
Thanks for the reply I did this and am pleased to say that I am getting full speed on a wired ethernet link. On top of this my flatmates PC is doing fine wirelessly (full speed) as is his 360 and my PS3 (wirelessly also). Therefore the connection and router do not seem to be at fault.

To add to my original post.

* Before my connection was automatic, it connected automatically and in the 'Internet Protocol Version 4' property settings it was set to Obtain IP address and DNS server automatically. It did not work at all in this setting after the system restore, but it does work in its 'limited/watered down speed after i've manually entered the IP, DNS addresses in the 'Internet Protocol Version 4' properties.

* I have tried to run diagnostic/repair functions over the connection but Windows 7 tells me 'Diagnostic Policy Service is not running'
My System SpecsSystem Spec

10 Apr 2012   #4

Windows 7 Home Premium 64-bit

Two things to consider -I had a similar problem when I recently had to move my router when decorating and when it was back in is original position, the connection was unreliable when before it was rock solid. I discovered that my preferrred connection was not set to "automatically connect and it was connecting to another one instead - once I set this correctly the connection was back the way it used to be (how it got like that I do not know :)). Go to the wireless icon at the bottom right (like a staircase) and make sure the only one that is set to automatically connect is the one you normally use.

If you want to diagnose the Diagnostic Policy Service must be on - to check this, go to start, computer, right click - manage, go to Services under Management and Services tab and go to Diagnostic Policy Service and if it is stopped or manual, set it to automatic, started, by right clicking on it.

Let me know if any of this helps.
My System SpecsSystem Spec
10 Apr 2012   #5

Win 7 64bit

Thanks, but sadly I think it's more deep routed than that. I came across this thread, which seems to be echoing my issue.

the dependency service or group failed to start

If this thread is right then it seems as if something relevant to my wi-fi settings has corrupted. Have tried to renew the IP but no luck.
My System SpecsSystem Spec
10 Apr 2012   #6

Windows 7 Home Premium 64-bit

Are you able to restore to earlier than the 48hrs you already did, maybe a week ago to see if this resolves it ?

And, if you can't get any joy with the related thread you may be looking at a fresh install of the OS.
My System SpecsSystem Spec
10 Apr 2012   #7

Windows 7 Ult, Windows 8.1 Pro,

I don't know what could be causing this but it's pretty typical for system restore which never works right for me.

Using Windows file recovery to create a system image on a separate drive really works well for me. Having a current system image would be nice right about now.

Have you tried using the ole sfc/scannow command yet?

It sounds like you have a partial connection so perhaps using a flush .bat file to reset TCP/IP, winsock, flush the DNS.... would work for you.

Lets try flushing DNS cache and renewing your IP.

Flush the DNS cache and restore MS's Hosts file ...
Copy and paste these lines in Note pad.

@Echo on
attrib -h -s -r hosts
echo localhost>HOSTS
attrib +r +h +s hosts
ipconfig /release
ipconfig /renew
ipconfig /flushdns
netsh winsock reset all
netsh int ip reset all
shutdown -r -t 1
del %0

Save as flush.bat to your desktop. Right click on the flush.bat file to run it as Administrator.

Your computer will reboot itself.
My System SpecsSystem Spec
11 Apr 2012   #8

Win 7 64bit

I am pleased to say this is now solved. Annoyingly I couldn't fix it through conventional means, and so I did a Win 7 repair install...this has solved the issue. Looking online at similar posts i'm assuming some key file or bit of data became corrupted in the Restore process....leading to my issue.

Kudos to ibshaw, will mark thread as 'solved'
My System SpecsSystem Spec

 'Limited Access' to Wi-Fi Network after system restore????

Thread Tools

Similar help and support threads
Thread Forum
unidentified network, no network access, limited access
I have a brand new acer aspire notebook and I'm trying to connect to my airport extreme card built into my iMac desktop. The laptop sees the signal just fine, but it will not connect to the internet and I get "limited access". What can I do to connect?
Network & Sharing
Limited Access to network
Hi, I'm writing today because recently I've been getting the issue of the "Limited Access" when it comes to connecting to the internet at my school. I know it's something wrong with my laptop because every single person that is in the same area as me is receiving internet just fine, for some...
Network & Sharing
System Restore only shows limited restore points
Why does system restore only shows the two restore points where I backed up my computer to my external drive. And If I try to restore that, then it says, The backup drive could not be found. How would that matter though? I mean I only backed up my system to an external drive. I didn't create a...
Backup and Restore
Limited Access to wireless network
Hey guys, I have an issue with my wireless. It comes up now (for no apparent reason) that the network has Limited Access. Any suggestions please on what to do?
Network & Sharing
Unidentified Network; No Network Access; Limited Access
I have a Dell Inspiron 1750 with Windows Home Premium x64. This problem began occurring on Thursday after my brother put his hard drive from his laptop which runs Vista, into my laptop. I figured it was a stupid idea, but he stayed home and I went to school that day. (His CMOS battery needs to be...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:33.
Twitter Facebook Google+