Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to map network drive due to lost ownership

29 Apr 2012   #1

Windows 7 Home Premium 64 bit
Unable to map network drive due to lost ownership

I have a NAS drive hard wired to my computer. It has 3 logical drives one of which cannot be accessed. It is listed in the Network folder as shared. When I try to map the drive the response is that I don't have the correct permissions.

When I check the Ownership panel (attached) it says that it can't display the current owner.

I've tried accessing using either of other the existing users (there are no others) - won't work.

I've tried the command net use /d \\myserver\mysharename and this didn't work either.

I've also tried system restore that didn't help either.

I know I need to restore valid ownership details can anyone advise please.

My System SpecsSystem Spec
29 Apr 2012   #2

Windows 7 Home Premium 64 bit

Turns out the problem was with the permissions on the NAS server. Some how they had been set to restrict access - once changed I was able to map and access the drive as before.
My System SpecsSystem Spec

 Unable to map network drive due to lost ownership

Thread Tools

Similar help and support threads
Thread Forum
Lost ownership of Folders and files after removing XP and installing 7
Hello everyone, So I have been using win XP for many years, 2 years back I installed win 7. Everything was fine but today when I was trying to access 4-5 year old photos the Photo Viewer is giving the error "Windows Photo Viewer can't open this picture because you don't have the correct...
General Discussion
Taken ownership of files on old hard drive, still unable to open.
I have taken ownership of all the files and folders on an old hard drive, but am still unable to access many of these files. When checking in the Security tab, I see myself as the owner with full admin permissions, but still cannot open the files. Anyone know how to resolve this issue?
General Discussion
lost file ownership of computer
hi all, i have been searching the forum for answers and have tried a few things but am seeking help before i do anymore damage to my computer! first, i have a toshiba laptop running windows 7 32bit and made some changes to folder ownership that has wrecked havoc on my machine. i am the only user...
General Discussion
Access Denied and Can't Take Ownership on Network Hard Drive
I have a network hard drive mapped as Z: which I have become unable to do ANYTHING with. I can't delete anything, change anything, or add anything to the drive. I just get that blasted "Destination folder access denied. You need permission to perform this action." The internet has provided me...
General Discussion
After reinstall of pro, my D drive lost ownership?
I just reinstalled and it seems my D drive that has all my data, and i use for my docs. Has lost ownership i guess. First noticed because FF wouldnt download to it, to my downloads folder. Next tried to extract something and it wouldnt work. I can delete but have to hit continue, on the...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:52.
Twitter Facebook Google+