Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Network Adaptor Issue - Dell Insipron 1545 - Limited Connectivity

09 Jun 2012   #1

Windows 7 32-Bit Professional
Network Adaptor Issue - Dell Insipron 1545 - Limited Connectivity

Wonder if anyone can assist please?

Spec: Dell Insipron 1545
Win 7 64 Bit
Intel Pent Dual Core 2.2GHZ Processor

All of a sudden the laptop will not connect to the internet wirelessly. I have done the following

Installed Chipset
Installed all Network Drivers from DELL website
Ran ipconfig release/renew
Removed and replaced the Wireless Broadcom Card

I am unable to access the properties of the iPv4 in the LAN settings. In Device Manager I have the following:

Dell Wireless 1397 WLAN Mini-Card (No exclam or cross working normally)
Marvell Yukon 88E8040 Fast Ethernet (As above)
Microsoft ISATAP Adapter (Yellow exclam)
Teredo Tunneling Pseudo-Interface (Yellow exclam)
WAN Miniport (IKEv2) (Yellow exclam)

I have removed the ISATAP and re-added using legacy.

In ipconfig I get

Windows IP Configuration

In ipconfig /all I get

Host Name.............. julie-pc
Primary DNS Suffix..
Node Type.............. Broadcast
IP Routing Enabled... No
WINS Proxy Enabled No

When I try to access the DELL Wireless Lan Card Utility

There are currently no wireless adapters available and enabled

Please enable any available wireless adapters before accessing this configuration

I have also tried system restore, but no points are available

Can anyone help? Thanks in advance


My System SpecsSystem Spec
10 Jun 2012   #2

Win7 & Win8 64bit


Your ipconfig /all output is incomplete, please try it again then post it.

Verify that all your Network Services are Started from Control Panel and its Dependencies.
Click on the Start button and type services.msc press enter.
• COM+ Event System (for WZC issues)
• Computer Browser
• DHCP Client
• DNS Client
• Network Connections
• Network Location Awareness
• Remote Procedure Call (RPC)
• Server
• TCP/IP Netbios helper
• WLAN AutoConfig (needs to be Started if you're not using any wireless utility manager)
• Workstation
My System SpecsSystem Spec
10 Jun 2012   #3

Windows 7 32-Bit Professional

Hi 2xg

Many thanks for your reply. As previously described in ipconfig /all - that is all that is displayed.

In services, I am unable to start:

DHCP client - Error 1168 Element not found
Network Location Awareness - Error 1068 The dependency service or group failed to start
Server - Error 50 The request is not supported

All the other services are started.
My System SpecsSystem Spec

10 Jun 2012   #4

Win7 & Win8 64bit

Pleas try the following recommendations from this link to possibly resolve the errors. Check all those 3 Services after if they are now on Started mode.
My System SpecsSystem Spec
10 Jun 2012   #5

Windows 7 32-Bit Professional


I already tried that. Will re-installing the os resolve it?
My System SpecsSystem Spec
10 Jun 2012   #6

Win7 & Win8 64bit

If you have an image backup of your computer (if you have a backup of course) that might help. Make sure that you backup all your files before performing a restore of your backup image, things may go haywire.

Have you also ran sfc /scannow command from the first link that I gave you?

Please run CHKDSK:
How to use CHKDSK (Check Disk) - Windows 7

If unsuccessful, do a Startup Repair:
Startup Repair - Windows 7 features - Microsoft Windows
My System SpecsSystem Spec
11 Jun 2012   #7

Windows 7 32-Bit Professional


Ran the sfc /scannow and it's working! Many, many thanks!!!!
My System SpecsSystem Spec
11 Jun 2012   #8

Win7 & Win8 64bit

Good for you! You're Welcome.
Quote   Quote: Originally Posted by rikstaparr View Post

Ran the sfc /scannow and it's working! Many, many thanks!!!!
My System SpecsSystem Spec
04 Oct 2012   #9

win 7 32 bit

Hi, I have faced the exact same issue with the same feedback errors, did you do anything besides
sfc /scannow
? Did you reinstall your os?
Thank you,
My System SpecsSystem Spec
04 Oct 2012   #10

win 7 32 bit

thankx 2xg and rikstaparr! my internet is working well now. For other ppl looking for this issue. I didn't ran anything besides sfc /scannow. But you have to make sure that you run it as root.
Remember to open cmd as ROOT (ADMIN), because if you run directly from the menu, it pops up and goes, and seems like it is ran, but it appears a line for a (0.1sec) telling you this command should only be ran with authority. So you have to open the command as admin to run it properly. sfc takes about 15 min for my computer. So anything less than a second is wrong.
My System SpecsSystem Spec

 Network Adaptor Issue - Dell Insipron 1545 - Limited Connectivity

Thread Tools

Similar help and support threads
Thread Forum
Limited Connectivity issue (wireless)
A few weeks ago, My internet provided (WOW, or Wide Open West) had a DNS outage. My roommates were able to change their DNS so that they could restore internet connectivity. I, on the other hand, had no such luck. I've tried the following: -Using Google's DNS (, and as the...
Network & Sharing
Help! Limited connectivity because of wireless network adapter
Hey, Last night I uninstalled ad-aware and then I lost my internet connection. It keeps on saying: "limited access". I found a driver with a yellow exclamation mark in network adapters and I accidentally uninstalled it and made everthing worse-_- I don't even remember its name and when I scan for...
Network & Sharing
Limited connectivity to network with no errors
I had updated my laptop then allowed it to restart to finish the updates it did the install restart thing 5 times then finally booted up then turned it off for the day. I booted the device up the next day and it said that the computer was not turned off properly and needed to scan for errors even...
Network & Sharing
limited network connectivity - DHCP and DNS servers not responding
I have two laptops, L1 and L2. Recently, L2 stopped connecting to the internet via my Linksys wireless router. However, L1 can still connect just fine via the same router. L1 runs winXP SP3, L2 runs win7 Home Premium x64 SP1. Usually when L1 or L2 stops connecting, I turn off the wireless cards on...
Network & Sharing
Dell Inspiron 1545 VISTA only NETWORK
Hello to who ever may solve my problem with me laptop, my laptop has a wireless network card but a couple days ago i got a virus that i cloud not get rid of it so i had to reformatted it, so i installed the VISTA CD back on her but now my laptop say's This computer does not have a wireless network...
Network & Sharing
Limited Connectivity, Wired Network, Non-Administrator
Hey, Bit of an odd one here. I work at a company in the UK which is attempting to start rolling out Windows 7 to all computers (early adopters and all that, it's just a lot easier than the current mishmash of OSes we have!). One of the 4 users migrated so far is having an odd issue with her...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:58.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App