Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Wireless networks shows WEP instead of WPA

04 Sep 2009   #1

Windows 7
Wireless networks shows WEP instead of WPA

I have Windows 7 and I'm trying to connect to a wireless n router. When I look at it under available networks it says "Security Type: WEP" but my router is set for WPA. I can access it as WPA on my late 2008 macbook pro, but no matter what I do (disabling the wireless n adapter, restarting the computer, etc.) I can't get it to recognize my network as WPA and thus any password I enter is marked as incorrect.

Other networks in my area show WPA., and I'm using a Linksys N router.

Is anyone else having this problem?

TIA for any solutions...

My System SpecsSystem Spec
04 Sep 2009   #2

Windows 7

When you say "late" macbook this means you don't have it any more? Well even if you do I would say reboot and reconfigure your router. Try turning off the security on the router to see if you can connect. The idea is to rule out possible problems one at a time. Get connected first and then go from there with re-enabling things.
My System SpecsSystem Spec
29 Oct 2009   #3

Windows 7
Not a problem for long

I experienced the same thing. My brand new Win 7 installation saw my 802.11n access point as WEP despite the AP being set to WPA2.

Windows 7 would see it correctly if I set security to wep, turned off security altogether, or set the AP to 802.11g instead of 802.11n.

I have a Dlink DWA-130 USB adapter and am using the driver supplied with Windows 7 as Dlink has no Win 7 driver for this adapter as of this writing.

I ran Windows update hoping for a hotfix or driver update. Re-boot. Problem solved.

A number of hotfixs were downloaded as well a some security updates. Not sure which one contained the fix for this problem. If anyone knows specifically which one fixed this issue, please let us know!
My System SpecsSystem Spec

26 Jun 2010   #4

Windows 7

I had the same issue and also completely updated all windows updates after installing a fresh windows 7.
according to the wifi router the settings where WPA-psk tkip and aswell my phone and XP machine connect fine. the windows 7 indicated my networ as WEP????.
so the drivers should be fine you think, but the rt73 USB wireles LAN card (in my Packard Bell Hero c) driver realy was the problem. I tried updating the drive not windows indicated that this is the latest (i did not trust is and found in the details tab (under properties) the manufacturer name of the rt73 Same as RT2500).
this is Ralink ( and could download the latest driver.
now it showed my router as WPA...
My System SpecsSystem Spec
26 Jun 2010   #5

Vista 64 Ultimate, Windows 7 64 Ultimate, Ubuntu 9.10

It would really help us to have your specs filled in so we'd know what PC/laptop model you have so we can help you with answers that will get your issue fixed, other than that we'd only be guessing or continually asking you questions.
My System SpecsSystem Spec
08 Dec 2011   #6

Windows 7 Professional 32bit

Man this has me stumped. My daughter just got her school laptop - HP ProBook 4230s with Win7 Professional (32bit). I am trying to connect it to our Netgear DGND3700 router, which is configured for WPA-PSK/TKIP. The network SSID appears in the list of available networks from the taskbar on the Win7 PC, but when you mouseover it it reports the encryption to be WEP. It will not accept the passphrase to connect. I can add an external adapter and connect but the internal one just will not. I also run other Win 7 PC's, iOS devices and Macbooks all with no problem. Has anyone found a solution to this as it has me stumped. Thanks Cakehole
My System SpecsSystem Spec
17 Jun 2012   #7

Windows 8 Release Preview 64 bit

I have a ZyXEL KEENETIC and a DWA 140 USB Adapter, OS is Windows 7 32 bit, I've changed in router settings from 802.11 b/g/n to 802.11 g/n and after this computer detected it corrently, before that i had the same problem with WEP. Sorry for my English, i just wanted to help somebody with this problem :)
My System SpecsSystem Spec
04 May 2014   #8

Windows7 Home Premium 64 bit
WEP instead of WPA,WPA2 etc

It seems every time I get certain updates after resetting my computer to out of the box state,after 3 days of only putting the SoB to sleep,I wake it up to see the main router I use is some how showing it as WEP when I know it is set to WPA.I know because I set the sucker myself!!! The router belonged to Me before I let a Friend use it to connect because Our sorry assed ISP never came over and hooked Him up,only activated His account,charged Him,then tried to double bill for something they never did!!!(Give Him A router) I have been over to His Apartment to reset the router so many times from this dumb BS it's ridiculous!
I can reset remotely when I'm on it.Which solves the problem for 3 days,then it's back to the same old BS again!!!
If I drop my secondary or tertiary router any network showing the wrong security suddenly and miraculously switches back to showing the correct security protocol!!! And auto connects to it! In this case when it will not connect it shows as WEP,as soon as it will auto connect it shows WPA which is wtf it is set at to begin with!!! It doesn't seem to matter wtf kind of a computer I have or use as it seems to do this on ANY using the Windows 7 stop asking people,because it doesn't seem to Matter!!! The problem is something in Windows itself,not the Computer as this only occurs after certain updates.They(Microsoft) really need to get their shit together before pushing out updates that don't work or only partialy work and then a few Days later Trash your PC.
I used that so called fix,it worked for all of 10 Minutes then stared showing the router as WEP again after dropping me a switching me to one of the alternate networks I use. SO fed up with this Crap it's no longer funny,never was but I do laugh now when I see the BS going on again!
I want a REAL and PERMANATE FIX not something temporary!
I apologise in advanced if anyone takes offese to anything in this.It's not directed at any one,I'm just so pissed that this keep occurring and no one seems to be able to offer ANY straight forward answer to a simple question! How do you fix this!!!
My System SpecsSystem Spec
30 Jul 2018   #9

Windows 7 64

I had the same problem and solved it by changing my router's security setting from "Auto (WPA or WPA2)" to "WPA2 only". Apparently Windows 7 didn't understand the auto mode.
My System SpecsSystem Spec
30 Jul 2018   #10

Windows7 Home Premium 64 bit

Thanks man,but I solved this long ago and forgot to unsubscribe from the thread! :P I was able to get it to stay at WPA before getting another ISP(Shentel)Frontier SUCKS here! And a new dual band router box.The other was so old WPA2 wasn't even present on it! The first router from Shentel burnt out after @ a year! The newest has Dual band and is much faster than Frontier could imagine at the time(2)years ago!This router has WPA2 and runs circle around the crap router from Frontier!
Thanks for your help though!
My System SpecsSystem Spec

 Wireless networks shows WEP instead of WPA

Thread Tools

Similar help and support threads
Thread Forum
WiFi adapter finds no wireless networks. ends up with “No networks
I have Toshiba laptop and Win 7. It is brand new laptop and original windows. I tried to install AWUS036H and it was successful but unfortunately adapter doesn't detect any networks. It happened with my old laptop with Win 7(Acer) and I had to reinstall windows fresh and it worked. But I wouldn't...
Network & Sharing
Network and Sharing Center shows no available networks
So I have a mystifying and aggravating problem... I've owned my Dell XPS 13 for about 3 years, no significant issues, it's worked great. Just before leaving my office - I take my computer back and forth between my home and office - I stepped away from the computer for a few minutes. When I came...
Network & Sharing
the wifi in the task bar shows as networks are available
hello the wifi icon in my task bar shows as i m not connected to a network. it shows the yellow star although i m connected to a network. the picture shows that i m connected to a network with a name blink but still the icon shows the yellow star. it should show the signal of the network. thx
Netbook Won't Recognize Wireless Networks, Just Shows Red 'X'
Hello, So I've searched all over the internet for answers and asked some of my computer-savvy friends, but no one seems to know. Here is the problem (I'll try to give as much info as I can, and hopefully someone out there can help me): Basically, my netbook doesn't recognize any...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 23:15.
Twitter Facebook Google+