Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Installed new wireless router and now getting "Error 651"

14 Jun 2012   #1

Windows 7 Home Premium 64-bit system
Installed new wireless router and now getting "Error 651"

I recently switched from dial-up connection to DSL. For about a week I enjoyed it before installing a wireless router so that I could hook up MagicJack Plus. I was able to install the new router (Cisco Linksys WRT1120N) with my DSL modem (D-Link DSL-2320B), but now when I try to create an internet connection I get the 651 Error or "The DNS server isn't responding"

I already tried some things; uninstalled my network adapter, updated it, disabled IPv6, and disabled auto-tuning. I had issues with my modem before installing the router, I couldn't load sites such as Facebook or Hotmail even with Chrome, and my I contacted my ISP about that although I'm unsure whether they looked into that at all...

Please help me

My System SpecsSystem Spec
14 Jun 2012   #2

Microsoft Community Contributor Award Recipient

Windows 7 x64

It's the router that is failing to announce dns would be my guess.
Have you dug into its settings yet?

The computer isn't picking up anything because nothing is being supplied.
I would reset both modem and router too.
My System SpecsSystem Spec
14 Jun 2012   #3

Windows 7 Ultimate x64

Did you try turning your router onn/off? Error 651 means problem with your router.
If it doesnt help try the following:

Turn off Receive Side Scaling и Offloading support in the following way: in the register find HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
then create parameter DWORD witn the name EnableRSS. Set it to (0).

If it doesnt help:
FInd HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
Then create (if doesnt exist) parameter DisableTaskOffload and set it to 1. Restart.

Some of those should help. It helped with me on Server 2003 anyway.

Please write your results!
My System SpecsSystem Spec

14 Jun 2012   #4

Windows 7 Home Premium 64-bit system

Thanks for trying to help me out guys. After almost talking to my ISP and we went through the router settings and turning everything off/on; we figured out my problem was entirely the fault of the phone jack I was using. Before installing the router I moved my desktop to the other side of the room to take advantage of an actual phone jack, before I was using a phone line with a broken tip taped to an extension into my modem, but I plugged the modem back into the first phone line and I have net! Seems my issue was location.
My System SpecsSystem Spec
14 Jun 2012   #5

Windows 7 Ultimate x64

Quote   Quote: Originally Posted by kokuryuhaa View Post
we figured out my problem was entirely the fault of the phone jack I was using.
Some issues indeed have simple HARDWARE background
Glad it is resolved!
My System SpecsSystem Spec

 Installed new wireless router and now getting "Error 651"

Thread Tools

Similar help and support threads
Thread Forum
W7 Network map tree with "?" between laptop and wireless router
While flying through my computer. I found this instance that has me confused. I was looking at my network. Decided to go to the map and saw the basic map. (image 1). When I clicked on "see full map" link it showed the network map, only between my computer and my wireless router there is a...
Network & Sharing
A Good "Not Expensive" Wireless N Router?
Hello sevenforums! It's been a while since my last post. I'm looking to upgrade my Linksys WRT54G with SpeedBooster (Ver 6). I've been having stability problems with the devices (I believe it's because of the increased amount of devices in my network), such as my laptop with its crappy Centrino...
Hardware & Devices
When I connect to my wireless router it says "linksys 2"
When I connect to my wireless router it says "linksys 2" but the ssid is just "linksys" so where is this 2 coming from and how do i make it go away?
Network & Sharing
Sound error "no audio output device is installed"
Recently when I was trying to enable my sound card so I could make YouTube videos, I managed to somehow break my sound. I have a windows 7 64bit computer that runs realtek hd audio and nvidia hd audio. I have tried reinstalling windows and that does not work, as it comes up with an error message...
Sound & Audio
Laptop losses internet access, but says "connected" to wireless router
I bought a Cisco Valet M10 wireless router a few days ago and I have been having issues where my laptop says that it is connected to network and it shows maximum strength signal, but underneath the network name it says "No internet access". I have already contacted Cisco several times and also HP,...
Network & Sharing
"No programs are installed on this computer" error
Hey everybody! I'm new to the windows 7 forums. So here is my problem: when i go to the Add/Remove Programs list, instead of seeing the list of installed programs it displays "No programs are installed on this computer". I tried rebooting the computer but that did do anything. Haven't turned on...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:08.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App