Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Laptop wrongly thinks there are "no connections available"

05 Jul 2012   #11

Windows 7 Home Premium 64bit

VegasIP, is the driver auto-found the same as the one if you manually go to your service tag page itself? Could the detection process be wrong or did it take you to your service tag page? In other words, are the two pages identical? They probably are and it was my fault for missing that.

My System SpecsSystem Spec
05 Jul 2012   #12

Windows 7 Home Premium SP1 x64

I did double check that Dell got the service tag correct and also that they correctly identified it as a Studio 1555.

I tried once again to uninstall the driver, this time checking the box about deleting the device. I restarted the computer and this time it found a driver it could successfully install (turns out it is version

I was able to connect to the network and load several webpages!

Then, 5 minutes later, it was back to not being able to detect any networks. (I am 1 foot away from the router.)

Am I right to think it's sounding more like a hardware issue?
My System SpecsSystem Spec
05 Jul 2012   #13

Windows 7 Home Premium 64bit

Wow, is version the last version listed for the wireless at the Dell site? You could also cable plug it in and try a Windows update and hope Windows can update it.

You could also try a system restore to a time prior to the problems. Sometimes that sort of reinstalls everything to how it was when it worked well. That's been known to work sometimes.
My System SpecsSystem Spec

06 Jul 2012   #14

Windows 7 Home Premium SP1 x64

I'm not sure what you mean about using windows update. The Windows Update program says there no updates available.

If you uninstall and reboot, it seems like windows will install either the older ( from 2009) or the newer driver. If you select "update driver" through the device manager (even offline) it will find the newer one ( somewhere. If I cable plug the computer and choose to update the driver, it says the driver ( is up to date. This is odd since yesterday I had the newer driver installed, and both windows and intel detected that one as up to date.
My System SpecsSystem Spec
06 Jul 2012   #15

Windows 7 Home Premium SP1 x64

Also, I can't do a system restore as there are no restore points prior to the development of this problem.
My System SpecsSystem Spec
06 Jul 2012   #16

Windows 8 64 bit PRO

Sorry i been away the last two days, I should of left a short msg. Anyways, is there any other problem also occuring?
Earlier in the post you mention code 10, thats basically corrupted, outdated, or incompatible drivers.

You also mention Dell drivers do not work at all, because you can not install them. The reason for this is unknown so far. Your computer has wireless enabled but it does not pick up any signals/wireless broadcast. The ethernet port does work though...
You have been getting the drivers from intel site? So far none have worked. You basically tried everything related to uninstall and reinstalling drivers with no success. At this point I would recommend you backup your data and reinstall. Just to make sure this is not a software issue. Or you can keep trying and get a lucky break and it will work. Another option is buy and external USB wireless adapter/replace internal wireless adapter.
My System SpecsSystem Spec
06 Jul 2012   #17

Windows 7 Home Premium SP1 x64

Thanks for checking back in.

Replacing the card sounds preferable to a full OS reinstall. Any idea if the hardware solution is likely to work?

Also, do i need to select the card that Dell says are compatible or will any PCIe half mini card work?

My System SpecsSystem Spec
07 Jul 2012   #18

Windows 7 Home Premium SP1 x64

I posted the above question in a the hardware forum, which is perhaps more appropriate:

Replacing PCIe laptop wireless card
My System SpecsSystem Spec
03 Sep 2012   #19

Windows 7 Home Premium SP1 x64

Problem resolved.

I went ahead and bought a new adapter. Before installing it, I checked once again to see if it would work. It did work--at least for another week or so. Then I changed out the adapter with a different model. It's been working problem-free for about 2 months.

I wish I changed this $12 piece of hardware earlier rather than spending so much time trying to reinstall drivers etc!

Thanks for everyone's help.
My System SpecsSystem Spec
18 Feb 2013   #20

Windows 7 Professional 32 bit


Could you please tell which model/make of adapter you replaced with?

I have had exactly same problem in Dell studio 1555 for the past several days and spent lot of time reinstalling drivers/OS, troubleshooting etc with no luck. Now my wifi doesn't work at all. Thought it would be better to change the adapter once for all.

My System SpecsSystem Spec

 Laptop wrongly thinks there are "no connections available"

Thread Tools

Similar help and support threads
Thread Forum
Win thinks I have 2 monitors. Can't see "monitor 1"
I had a 2 monitor system. A few moments ago monitor 1 quit. I rebooted into safe mode and assigned monitor 2 to monitor 1. It still shows as monitor 2 so I don't get a menu bar and all right click actions are invisible as they are still going to the virtual monitor 1. How can I tell my system...
Graphic Cards
Laptop hangs at "Starting Windows" or getting "Error 0xC0000225"
Hi, I have a Toshiba r700-181 (PT310E) work laptop. It is running Windows 7 x64 Enterprise. It has one 4GB stick of ram which is PC3 10600. Windows works fine with this. I have obtained a 4GB stick of ram which is PC3 12800. With just this one in, Windows works fine. However, if I have...
General Discussion
No "usb legacy support" "qfan" options on my asus laptop bios.
Entering the bios limits me to certain options. Is there anyway to access the other options? sorry, newbie here.
Performance & Maintenance
Laptop speakers emit a "pop" sound after "Starting Windows"
For a couple weeks now, My laptop has been making a "pop" sound everytime on start up after the windows logo comes together it makes a faint pop sound then continues to the login screen. Everytime I muted or unmuted the speakers it would make the sound too. I changed my driver the the Windows...
Sound & Audio
Win7 thinks my 22" monitor is 17"! Resolution Probs!
Guys, I recently purchased a new Windows 7 HP computer and intended to use my Acer AL2216W (22" widescreen) monitor with it. The monitor worked fine on my XP PC, at it's native 1680x1050 res. Now i get this new Win7 PC and it can't figure out the resolution.. It's not offering me the 1680x1050,...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:42.
Twitter Facebook Google+