Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Marvell network adapter just disappears

09 Sep 2009   #1

Windows 7
Marvell network adapter just disappears

I'm using a Marvell Yukon 88E8053 Gigabit adapter. When I installed 7 and logged in for the first time, my ethernet did not work. I had to use a USB drive to get drivers to install it. So, I get it installed and working and then I add the PC to my domain, log in with a domain user and it cant even find the DC to authenticate to!

I log back in with the user on the workgroup and find that the ethernet is not working. I look under device manager and the "Network Adapters" node is not even there! I try to install the Marvell adapter and ony Intel adapters are listed. When I try to "Add Legacy Device" and use the drivers for my Marvell, it won't even display a list to choose a model from, so at this point I'm pulling my hair out. I reboot, log in with the worgroup user and the network card shows up; OMG.

At this point I can finally log in with the domain user. I'm installing a bunch of software and I finally stop and let the system lock the computer. I come back, log in and guess what, no stinkin adapter; not even in device manager. Looks I have to reboot every time this happens. I just set the power options to High Performance, so hopefully I can get past this issue for now.

Anyone else having this problem?

My System SpecsSystem Spec
16 Nov 2010   #2

Windows 7 Ultimate x64

My Marvell Yukon 88E8053 Gigabit adapter just disappeared and now is missing from device manager. I tried all a nkew to fix this but I had to finally attach a usb adapter.
I have the latest drivers from Marvell they don't even show up in the list when I use hdwwiz.exe.
Anyone else faced this problem?
My System SpecsSystem Spec

 Marvell network adapter just disappears

Thread Tools

Similar help and support threads
Thread Forum
Marvell network interface won't connect to network.
Running ultimate x64. The motherboard I am using has two built-in NICs. The Marvell interface won't connect to the network. Sometimes it will get labeled 'unknown network' and get a 169.***.***.*** address. Sometimes it will actually get assigned an IP in the network but it can't reach the...
Network & Sharing
Network Adapter Disappears
I think I may have a bug in my Windows 7 32 bit. I have this on and off problem with the Network Adapter. I could be using my computer and everything is ok. But maybe one or two hours later, I cannot get on the network. This has been happening for about 3 to 6 months and each time I was able to...
Network & Sharing
Network adapter disappears after reboot
I just recently bought a gaming laptop to replace my custom tower since my job requires a bit more portability. I just installed the important windows updates and now my network adapter disappears after I restart my computer. there are a few seconds when my desktop appears where I can quickly hit...
Network & Sharing
Marvell Libertas Wireless LAN Client Adapter Doesn't work
Marvell Libertas 802.11 b/g Wireless LAN Client Adapter Doesn’t Start My PCI card. I have installed a Rosewill RNX-G300E Wireless PCI card. I have attempted to install the drivers for it but keep getting ‘This device cannot start. (Code 10)’. As...
Bluetooth Stack for Marvell SD8688 BT adapter
I'm tried to used Bluetooth SD adapter which from Marvell(Marvell SD8688 BT) into Window 7. The driver has been installed and shown at the Devices Manager, but i can't found the service that available for the adapter. I need stack for my bluetooth adapter and i don't know whether Window 7...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 20:10.
Twitter Facebook Google+