Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't join Homegroup

23 Oct 2009   #121

Win7 Build 7600 x86

Just a tip (which you can also conclude from the last two posts).

When setting up a network, always, always, ALWAYS uninstall 3rd party firewalls, or at the least make sure you know how to configure it properly.

After everything works, install one 3rd party firewall at a time and make sure it is configured properly.

The windows firewall is more than enough to protect you while setting up your network.

People try an endless string of troubleshooting, installing new drivers etc.. while it was the firewall that blocked proper network functioning all the time.


My System SpecsSystem Spec
18 Nov 2009   #122
Big Tommy

Windows 7

I do not see a JOIN option on either computer wether I set up the homegroup on either machine. This is driving me nuts.
My System SpecsSystem Spec
19 Nov 2009   #123

XP,Windows 7,Fedora,Ubuntu,Open Solaris

....I am having the same friggin' problem.I have no problem with booting up in xp to share the printer with my Win 7 laptop though.This home group was working at one time!All I get now is 'Cannot create home group on this computer' when using the password from my desktops home group.Really don't care but it bugs the hell out of me.
My System SpecsSystem Spec

22 Nov 2009   #124

Windows 7
Maybe it's the original Network setup problem?

I have Windows 7 on 3 machines. I have Created the Homegroup on computer 1 (for the example it is called Caillah) and attempted to Join the Homegroup with computer 2 (called Test - PC). The second computer does not recognize the Homegroup being set up on the network.

I have checked the Peer Networking, Local internet connection, shut down the third party firewall and I still can't get it to work.

I tried the "trick" mentioned in this thread. I created the Homegroup on Comp 1 and then did the troubleshoot on Comp 2. I then created on Comp 2 and attempted to Join on Comp 1. For some reason Comp 1 now recognized that Comp 2 had created a Homegroup and gave me a join button and a place to enter the password. I did this and received an error message that a Homegroup could not be created on this computer.

I am wondering now if in fact it is a Network issue. When I go in to Network Sharing and click on Map, not all computers are properly recognized but I am not sure how to go about fixing that. I have done all the troubleshoot options but it can't find the error.

Both computer 1 and computer 2 are connected to the internet by ethernet. The third computer (Michael-Frost) is wireless and is also Windows 7 and at this point we have made not attempt to link it. The other computer (Sam) is a laptop, wireless but is still on Vista and I understand that Homegroup function with it (or at least not easily and the "easy" connect isn't working anyway ). We have a wireless printer and it works with both wired computers as well as the wireless laptop.

In the "My Computer" area Homegroup shows no other computers but in Network both Comp 1 and Comp 2 are visible as is the printer memory.

The network maps for Computer 1 (known as Caillah)and Computer 2 (known as Test - PC) are as attached. I have also included the error message on Computer 1 which I got when I attempted to "trick" it in to setting up from computer 2.

I hope you are able to follow what I have done. I see that many people are struggling with the same issue and I am hoping that my including my response we might all figure out what the glitch is.

Attached Thumbnails
Can't join Homegroup-network-map-test-pc.jpg   Can't join Homegroup-screen-cap-1.jpg  
Attached Images
Can't join Homegroup-network-map-caillah.jpg 
My System SpecsSystem Spec
22 Nov 2009   #125

Windows 7
Resolved my Issue of not being able to JOIN

I found a thread somewhere that suggested it might be the third party firewall.

I disabled my third party firewall on both machines and was able to join and be seen. I then enabled the firewall and it shut down. So I disabled the firewall again and switched to the Windows Firewall and had to do a troubleshoot for it "fix" it and it works fine now.

Hope this might help someone else.
My System SpecsSystem Spec
22 Nov 2009   #126
Microsoft MVP

Windows 7 Ultimate 32bit SP1

My System SpecsSystem Spec
23 Nov 2009   #127

XP,Windows 7,Fedora,Ubuntu,Open Solaris

.....My fix was to leave Home-group on both my desktop and laptop then create the home-group on my laptop and join home-group from my desktop.Really doesn't make sense to me.My desktop is the one with the printer.
My System SpecsSystem Spec
27 Dec 2009   #128

Windows 7 Ultimate
Head Ache has ended...

Well folks... I had similar problems that led me to this blog. I have found the Home Group creation to be a pain as well. I have a Toshiba a505 running Win7 Home and an AMD PC running Win7 Ultimate; both in 64bit. I was having fits because I could create the groups ok on the two systems and I could see the shared folders from each, but could not open them. Additionally, on my Home Group status screen I saw that there was a network printer available. I clicked the "install printer" button and nothing happened. If I clicked on any folder on the network I would get a message saying either system was unavailable. Thanks to one gentleman poster on this blog, I thought of my firewalls. I have installed Kapersky 2010 on my laptop and Vipre on my PC. My Vipre does not have a 64bit compatible firewall so I have to use Windows firewall, however I forgot that Kapersky has a firewall. DUH! Anyway... I went into my firewall settings for Kapersky and allowed my Home Group (which was listed) in the "Trusted" area, and bingo! Just goes to show sometimes the most obvious things can keep you up all night (or for days). Hope this helps someone such as I. Happy New Year... Swed :)
My System SpecsSystem Spec
09 Jan 2010   #129

windows 7
Homegroup on wireless computers

After weeks of frustration I finally was able to join a homegroup between two wireless computers. The frustrating part was the laptop would only join when physically plugged into the router - which led me to believe the drivers in the laptop were outdated. But that wasn't the case. It's because I used the "guest password" on the laptop that only connects to the internet. The guest password was setup when I installed my Belkin router. So instead I used the crazy long "network security key" and now everything works fine!
My System SpecsSystem Spec
10 Jan 2010   #130

Windows 10 Pro x64 x3, Ubuntu

One thing I have noticed with homegroup is that it is very aware of what other networks the machines are connected to.

I have found that a perfectly working Homegroup will refuse to connect if it discovers a connection, on one of the systems, to an open public network.

Not something that will apply to everyone but is more likely with the use of mobile broadband "dongles" and the like.

Something to be aware of anyway
My System SpecsSystem Spec

 Can't join Homegroup

Thread Tools

Similar help and support threads
Thread Forum
Unable to join homegroup, homegroup creating computer is no more
The computer that originally created the homegroup on my network is no more. It seems that because of this that my new computer is unavailable to join the homegroup that already exists. Other computers that were part of the homegroup before the "host" computer died are still part of the homegroup...
Network & Sharing
Homegroup problems - Homegroup detected, can't join. @wit's end
I have a desktop that is connected to my Belkin router via wire. I have 3 laptops that are all connected to the router wirelessly. All computers have Windows 7 64bit and synched clocks. All are connected to a Home network. All 3 laptops detect that a Homegroup has been created on the wired...
Network & Sharing
Homegroup encountered an error / This computer cannot join a homegroup
I get a "Homegroup encountered an error" message when I try to join my laptop and desktop to a homegroup. It does not matter which one sets it up and which one tries to join. It errors in either direction. I have tried leaving and creating, no use. The desktop is wired to a Belkin 300N router and...
Network & Sharing
Cannot join Homegroup
I have two computers: Dell Inspiron Laptop connected wirelessly and a Desktop with wired connection to router. I have been trying for 4 hours to connect to the homegroup with my desktop so I can view the files on my desktop on my laptop. Now I will detail the steps I have done. 1. I tried going...
Network & Sharing
Cannot join Homegroup
I have two Windows 7 desktop Pcs, connected via a 4-port router (wired connections). I can create a Homegroup on both machines, but neither PC can detect the other's Homegroup. So when I try to join the homegroup from either PC I always get the message 'there are no other Homegroups on this...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:10.
Twitter Facebook Google+