Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Import Pictures to NAS "Access Denied" Error Though User Has Access

28 Aug 2012   #1

Windows 7 Home Premium 64bit and Windows 7 Professional 64bit
Import Pictures to NAS "Access Denied" Error Though User Has Access

Hi, All.

I've got an interesting situation that I'm hoping can be resolved. I built a server using FreeNAS 8.2 to store family pictures, videos, music, and Windows backups. In my home we have Windows 7 Home Premium 64bit and Windows 7 Professional 64bit. The server is setup with 3 Windows (CIFS) Shares. One share for each of the two computers and then a common share for multimedia. The user accounts on the NAS belong to the common group "family." The Multimedia share has ownership (user:group) of root:family. The permissions on the directories in the Multimedia share are read/write/execute for owner, read/write/execute for group, and read/execute for everyone else (or 0775 in the *nix world). Sorry for the long setup explanation.

Anyway, on my computer (Professional) and my wife's computer (Home Premium), I see the shares in Windows Explorer | Network. I am able to access the shares, and the first time I accessed, I was prompted to enter user credentials, which I did along with checking the box to have the credentials remembered. So, now, when I access the shares in Windows Explorer, I have immediate access. I can read, write, delete, whatever through Windows Explorer.

On my computer, I was able to easily transfer my iTunes library to the Multimedia share through the iTunes application, and iTunes now sees all of my iTunes media from the NAS, rather than local. On my wife's computer, I am having a problem with pictures. I was able to easily move all of the 4.8 GB of pictures from my wife's My Pictures directory over to a Pictures directory on the Multimedia share. I then went into Windows Live Photo Gallery and added the Pictures directory on the Multimedia share as part of the library. The pictures on the NAS show up just fine in the application. I then went to set the Multimedia share Pictures directory as the Default Save Location, and I received an error that stated that the directory could not be set as the Default Save Location as it was Read Only. However, I had just transferred files to that directory. So, I copied over some other files just to make sure, and I had no problems reading, writing, deleting from the directory via Windows Explorer. If I set the Pictures directory on the Multimedia share as the target for importing pictures from the camera, I get an Access Denied error when trying to import. However, I can import the pictures to the local My Pictures directory and right after the import, I can use Windows Explorer to move the pictures over to the NAS without so much as a hiccup.

I have done some searching on the Internet, but thus far, I have not found anything that resolves this issue. I have tried using the Windows 7 Library Tool application to add the Pictures directory on the Multimedia share to the Windows 7 Pictures Library and to set that as the Default Save Location. This does set those values, and I can see all of the pictures on the NAS in the Windows Explorer Pictures Library. Also, Windows Live Photo Gallery now has the NAS share as the Default Save Location. However, I still get the "Access Denied" Error when trying to import pictures to that location. I have also tried setting the permissions on the NAS Pictures directory to 0777 or read/write/execute for everyone, but that didn't help.

Does Windows 7 utilize some other account that may not have access to the stored NAS credentials for accomplishing some aspect of the picture import process? I have used Task Manager to view the running applications with Windows Live Photo Gallery and the Camera Import application running, and I see my wife's user account listed for those processes.

I'm sorry for the long post, but I wanted any reader to understand the setup and what steps I have taken thus far. I would appreciate any insight.

My System SpecsSystem Spec
28 Aug 2012   #2

Windows 7 Ult, Windows 8.1 Pro,

So have you tried setting the permissions using the Security tab rather than the Sharing tab? Often times you need to set the permissions on both of those tabs in order to have complete access. The link below shows you how. :)

HDD sharing
My System SpecsSystem Spec
28 Aug 2012   #3

Windows 7 Home Premium 64bit and Windows 7 Professional 64bit

Thank you, chev65, for your reply. However, I'm not dealing with an external hard drive directly connected to any computer in my LAN. I am not trying to get Windows 7 to share a drive. The Multimedia share is on a FreeNAS server (which is built on FreeBSD a Unix-like OS) that is connected on my LAN. The Windows (CIFS) Shares use Samba to facilitate communication between FreeNAS and Windows, and the Windows Shares service on FreeNAS does utilize WORKGROUP for its work group property.

As I stated above, in Windows Explorer on both Windows 7 machines, I am able to read, write, and delete to that Multimedia share. iTunes was also able to easily transfer my iTunes library on my computer over to the Multimedia share. However, on my wife's computer, the Camera Import application seems to have an issue trying to write to the network share. The credentials for the share are in the Credentials Manager. The only thing I can think of is that the Windows Camera Import application utilizes some account at some point that does not have access to the stored credentials and thus cannot write to the network share. However, that could be completely wrong.

At the moment, I am at work. So, I do not have access to my wife's computer. I'll look tonight to see if there is anything in the Security tab for the Pictures directory on the Multimedia share.
My System SpecsSystem Spec


 Import Pictures to NAS "Access Denied" Error Though User Has Access

Thread Tools

Similar help and support threads
Thread Forum
Accidentally denied my regular user account access to "Network" dir.
I have a computer running windows 7 64bit ult. I changed settings on the Network-PC\users\BOB to deny all access to BOB. Immediately after doing this my desktop disappeared and things stopped working. I thought it was a simple fix. I went into the Admin account and changed it so that user BOB...
System Security
"User profile service failed the logon" special case access denied
Hello SevenForums! A friend of mine brought a Windows 7 Ultimate x86 laptop saying that he can't log in with his account. When he tries to log in it shows this message: "The User Profile Service failed the logon. User profile cannot be loaded." Now I've searched the internet and found a few...
General Discussion
Cannot create file "c:\User\...\Appdata\Roaming...". Access is denied.
I'm not sure what's the cause for this, but I believe it has to do with a recent SweetIM malware attack. I tried to fix it. And also did a system restore. Malware is gone, but this thing came up. The error message comes up upon closing an app (NoteTab Light). It's trying to save some info, but...
General Discussion
My Pictures "location is not available access is denied"
if i go to libraries and find mypictures there it is okay. how do i get all the win7 mypictures to talk to each other! thaks
General Discussion
Access denied (5) when trying to backup "User-folders" using Syncback
Hi, Brand new PC. Only one user (which is Admin). Running Syncback trying to backup "user-folders" like images and videos etc I get Access denied problems. I'm able to browse the folders just fine. I have checked the check-box on the program to run as admin. I do NOT want to use Libraries!...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:10.
Twitter Facebook Google+