Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Complex Network Adapter Problems

04 Sep 2012   #1

Windows 7 32bit
Complex Network Adapter Problems

Please bear with me.
Our house has an old Linksys Wireless-G Router that came with external USB Network cards.

I found that using one of those, my desktop can connect to the router, but gets about two bars of signal strength and provides a sluggish at best netowrk connection.

Eventually I got tired of it and bought a TP-Link WN951-N internal N Wireless card, thinking it would improve things.

However, when I would connect using only that, my signal strength averaged four bars, but I would be constantly disconnected from the router, making playing online games or chatting virtually impossible (even if for downloading or even streaming it was light years faster). Worse, after a certain duration - 8 or so hours, sometimes less, the card would lose it's connection to the modem, and would not even come up as an option in the Currently Connected To icon in my taskbar.

Resetting the Network Adapter (or disabling and re-enabling it, or choosing Diagnose as I don't know how to manually tell it to Reset unless the Diagnose button presents that as an option) does nothing, and it not only can't detect our router, but any of the other routers on our block. It just goes dead. The only way to resolve this is to restart the entire computer.

I found a compromise: by running both, I get the stability of the external card with the speed of the internal, and the bursts of lag from the internal 'clicking out' are negligible, but I still have the problem of the internal 'going blind' and being unable to connect to anything untill I restart the tower.

I've tried all kinds of driver solutions, and the only thing I can think of is that when I was installing the card, I broke the little plastic tab that holds cards installed in the back of the tower in place, and so maybe it isn't sitting fully flush, but every time I open the case and check it, it seems to be in place securely, though should I (ground myself and) touch it, it bumps loose fairly easily. However, nothing bumps against my tower.

Anyway, I'm sorry for my problem being long and confusing, and I know that purchasing a new router (we tried that actually, but we can't get our brand new router to install properly) or taking my computer into a shop and having professionals look at it (though money is a serious issue right now) might fix it, but I'm kind of hoping it might be something simple and easily fixed.

Attached is my Dxdiag, any help or assistance would be appreciated. :)

Attached Files
File Type: txt DxDiag.txt (33.7 KB, 3 views)
My System SpecsSystem Spec
04 Sep 2012   #2

win7 32bit

when the card goes dead if you open network and connection sharing and go to change adapter settings, choose disable then wait then enable do you get the connection back? are you taking a usb stick in / out while your online? is there anything on the USB that might be set to auto power on / off?
My System SpecsSystem Spec
06 Sep 2012   #3

Windows 7 32bit

No, disabling then enabling after a time does nothing.

When things are operating normally, if I click the Connection icon in the taskbar, it shows me USB Connection (the external) with a long list of routers each with 1-2 bars of signal strength, and Wireless Connection (the internal) with only 4 of those options each with 3-4 bars of strength.

When the internal 'craps out', Wireless Connection isn't even an option on the list. I can then go into Connection Sharing and disable/enable or Troubleshoot, the former doing nothing, the latter saying Troubleshooter Could Not Find a Solution.

Resetting the tower itself however will restart it just like Resetting the Network Adapter should
My System SpecsSystem Spec


 Complex Network Adapter Problems

Thread Tools

Similar help and support threads
Thread Forum
Network adapter is experiencing problems
My network adapter sometimes doesn't work, troubleshooting says "Network adapter is experiencing problems". This doesn't happen all time, more like every other time i turn on the computer. Disabling and enabling network adapter in device manager doesn't help, only way to fix it is to restart...
Network & Sharing
Problems with wireless network adapter and network connection driver
Hi, So recently I have removed a nasty zeroaccess rootkit virus(es) from my laptop. My Windows Firewall, Defender and Updates would not work (still won't), my browser kept redirecting to unrelated websites, and I was just overall having a TON of irritating issues. I installed MalwareBytes and...
Network & Sharing
Asus USB-N13 network adapter problems
Hi, I'm running Windows 7 32bit with a MSI ms-7698 motherboard. I'm trying to install the drivers for an Asus USB-N13 network adapter. I have no cd drive so I've downloaded the drivers from the Asus site. When I run the setup file for the driver it says it can only be ran on windows 7 (which is...
Hardware & Devices
Wireless network adapter problems
I have an Acer Aspire 5553 with an Atheros ar5b97 wireless adapter. I recently moved to France from England and until the move I was able to connect. I don't know if it's a coincidence but when I got to my new flat I was not able to connect to the wireless home network. Other computers can and I...
Network & Sharing
Belkin G+ Network adapter problems
Hey sevenforums im new here =]. Anyways i just got my windows 7 ultimate working and everything is working fine expect my network adapter. I installed the vista drivers found on the belkin website. Which did the trick and made it work. But i noticed every 2 hours or so the adapter would...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:44.
Twitter Facebook Google+